Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Stuttering/echoing sound


  • Please log in to reply
8 replies to this topic

#1

HastyLumbago

Posted 06 October 2010 - 10:29 AM

OK, So I just updated to Windows 7. It fixed the crash I was having in multiplayer, and introduced a new kind. But honestly, I don't really care about multiplayer at the moment, and the crashing gives me an excuse to avoid it for a bit.

What I do mind is the fact that now my sound stutters like crazy. In single player. It also seems to be abusing my framerate whenever I try to strike something repeatedly, like, say, my fist against a tree, or a pick against some stone, or my feet against some ground. So, yeah, like 98% of the time.

Here's a list of what I currently have installed:

Windows 7
Updated Audio Drivers for my Soundblaster Audigy-series card
Graphics Drivers for my ATI something-or-other card (Which has not been an issue as of yet)
Chrome
Steam
Minecraft
WinRAR

I can't see where the conflict or issue might come from. Someone suggested somewhere or other that I check appdata to make sure I actually had all the sounds, and I totally do. Any help?

Register or log in to remove.

#2

xyphentis

Posted 06 October 2010 - 10:32 AM

maybe an acid flash back?

#3

HastyLumbago

Posted 06 October 2010 - 07:06 PM

xyphentis said:

maybe an acid flash back?

No, those are both easily spotted, and more enjoyable. Honestly, I'm a little peeved at this. I finally update Windows, specifically to make Minecraft work, and now it works even less. Obviously, I'm not angry wit Minecraft or Notch, But this is seriously no fun  :Notch:

#4

xtremeqg

Posted 06 October 2010 - 07:10 PM

Underpowered processor... IRQ conflicts, insufficient memory... Pick one.

#5

Ilnore
    Ilnore

    Out of the Water

  • Members
  • 2 posts

Posted 25 February 2011 - 09:32 AM

Do not go and blame unpowered processors at each problem, please. This is not a processor power issue; a lot of processors SHOULD be able to run Minecraft fine.

I'm also experiencing stuttering, and it only seems to happen with sound, and usually when there's lots of things going on, so lots of sounds playing.

As I see, it's to do with something with how Minecraft handles audio mixing internally.

Many sounds on top of eachother, Minecraft audio mixer crappy --> random stuttering. Not necessarily a CPU issue.

I think Minecraft uses OpenAL (?), though that still doesn't explain this, other games using OpenAL seem to do quite fine for me at least.

Anyways, regardless of where the issue is, a quick fix would be to allow for two things:

1) Give an option to disable footstep sounds. This will reduce the number of concurrently playing sounds.
2) Give an option to limit the amount of concurrent sounds to a set limit. Most likely there is a threshold above which the stuttering starts to go bad. This and a bit of experimenting around with the setting value would at least solve the stuttering, and still allow for proper sound in most situations.

#6

Malkierian

Posted 26 February 2011 - 03:44 AM

Ilnore and HastyLumbago:

I believe I at least had a similar problem to yours, if not the same one.  For me, the stuttering was most noticeable when music was playing, and let me tell you, it was annoying!   :)

So, I googled a few different phrases, and came up with this thread (post linked to has my solution):

Sound/Music problems (FIXED) - Minecraft Forums

It appears that the OpenAL32.dll distributed with minecraft is so old it doesn't even have proper version details.  The one I grabbed from my \system32 fixed the problem immediately.

So, you might want to give it a try.  (and yes, I joined the forum just so I could post this possible answer :D)

In case you were wondering, I just downloaded the client yesterday (just bought it yesterday, in fact), and so everything that Minecraft downloaded into its \.minecraft data folder was fresh off the servers.
Posted Image

#7

Ilnore
    Ilnore

    Out of the Water

  • Members
  • 2 posts

Posted 28 February 2011 - 11:59 AM

Malkierian, thank you!

This helped a lot. I also tried googling around a bit, found my way into three different forums, and didn't stumble across a true answer. But yes, this did help me a lot, awesome!

Nice of you to go through the trouble of answering.

#8

Malkierian

Posted 03 March 2011 - 03:49 AM

You're quite welcome, just glad I could help.
Posted Image

#9

jk_storm
    jk_storm

    Out of the Water

  • Members
  • 2 posts

Posted 24 May 2011 - 08:16 PM

I had the same problem of stuttering and an associated frame skip problem on my winXP pro laptop (Dell M4400). After awhile, it would quit stuttering and everything worked fine. However, I started messing with the video settings and, for some reason, turning off "Advance OpenGL" solved my problems.

I'd be interested to know if turning that option off helps anyone else, too.