Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Bad drivers - ATI Mobility Radeon HD2300(another one)


  • Please log in to reply
14 replies to this topic

#1

seraphus
    seraphus

    Out of the Water

  • Members
  • 5 posts

Posted 05 October 2010 - 08:45 AM

So I'm sure people are tired of reading these topics but I can't get Minecraft to work with this (ATI Mobility Radeon HD2300).  My PC is a Gateway C-142XL tablet pc and I believe finding drivers for this set is a pain to begin with (still can't find any).  Am I to believe that people who are unable to update their drivers are out of luck?  It's a shame if that's the case, because of all the praise I've been hearing...(and also because I've already paid for the game)

Quote

    Bad video card drivers!      
      -----------------------      

Minecraft was unable to start because it failed to find an accelerated OpenGL mode.
This can usually be fixed by updating the video card drivers.



--- BEGIN ERROR REPORT 7fe0271 --------
Generated 10/5/10 1:09 AM

Minecraft: Minecraft Alpha v1.1.2_01
OS: Windows 7 (x86) version 6.1
Java: 1.6.0_20, Sun Microsystems Inc.
VM: Java HotSpot™ Client VM (mixed mode, sharing), Sun Microsystems Inc.
LWJGL: 2.4.2
[failed to get system properties (java.lang.NullPointerException)]

org.lwjgl.LWJGLException: Pixel format not accelerated
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:185)
at org.lwjgl.opengl.Display.createWindow(Display.java:311)
at org.lwjgl.opengl.Display.create(Display.java:856)
at org.lwjgl.opengl.Display.create(Display.java:784)
at org.lwjgl.opengl.Display.create(Display.java:765)
at net.minecraft.client.Minecraft.a(SourceFile:196)
at net.minecraft.client.Minecraft.run(SourceFile:554)
at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT fbd412e9 ----------


Register or log in to remove.

#2

Digithor

Posted 05 October 2010 - 09:52 AM

I suppose relying on the manufacturer of the computer to keep up to date with drivers could be a nuisance when they don't properly enable their custom drivers to fully utilize the hardware.

The Mobility Radeon HD 2300 you have is from the R600 family (HD 2000 series) and should work with standard ATI Catalyst drivers.  If you have not done so, download them from http://support.amd.c...ages/index.aspx

Choose the following:

Step 1 - Notebook Graphics
Step 2 - Mobility Radeon Series
Step 3 - Mobility Radeon HD 2xxx Series
Step 4 - Choose your OS

Then download and install the drivers.
The epitome of optimistic thinking is when you hear some guy has tried to hang himself and immediately believe he was only trying to become taller.

#3

seraphus
    seraphus

    Out of the Water

  • Members
  • 5 posts

Posted 05 October 2010 - 05:51 PM

I've tried that and I get a "Your computer does not contain a proper graphics adapter."  I guess I forgot to mention I'm also running Window 7 32bit.  Could that be why?

#4

seraphus
    seraphus

    Out of the Water

  • Members
  • 5 posts

Posted 05 October 2010 - 08:08 PM

I believe this may be relevant info.  I've tried updating drivers as you would normally, but perhaps I have to use some other method.

Posted Image

#5

Digithor

Posted 05 October 2010 - 08:15 PM

I looked at the Mobility Radeon GPUs that are supported with the Win 7 32bit driver and I don't see the HD 2300 listed.  Actually for that version of ATI Catalyst, I just don't see the HD 2300 listed anywhere.  So I did a bit of searching and ran into this - http://www.hardwareh...com/modtool.php  It could explain the reason why some hardware doesn't seem to be supported by the drivers from AMD/ATI.

In a nutshell, AMD actually needs permission by the notebook manufacturer to allow AMD's own generic references drivers to be recognized and installed on various notebooks and mobile devices.  Pretty stupid, but that's business.

The tool located at the link, should allow most users to force the installation of drivers that are supposedly "unsupported".  If you want to use that tool, make sure you read everything on that page's instructions and backup your computer's data before you do anything.  the HD 2300 is shown to be supported by that mod tool so it should work.
The epitome of optimistic thinking is when you hear some guy has tried to hang himself and immediately believe he was only trying to become taller.

#6

seraphus
    seraphus

    Out of the Water

  • Members
  • 5 posts

Posted 06 October 2010 - 04:36 AM

After hours and hours of trying to find versions that work with the MM tool, I finally got it working.  10.2 legacy driver is the only one I've found to work so far.  Thank you Digithor!  You are a god!

#7

Digithor

Posted 07 October 2010 - 01:19 AM

Woot, that's good news :SSSS:

Glad I could be of some help.
The epitome of optimistic thinking is when you hear some guy has tried to hang himself and immediately believe he was only trying to become taller.

#8

brayden94

Posted 07 October 2010 - 06:46 AM

i get the same message, but i cant figure out how to fix it. My operating system is microsoft windows XP home edition (5.1, build 2600)
Please help!

#9

Digithor

Posted 07 October 2010 - 09:39 AM

Are  you also using the same GPU?  Mobility Radeon HD 2300?
The epitome of optimistic thinking is when you hear some guy has tried to hang himself and immediately believe he was only trying to become taller.

#10

Doomsdave
  • Location: United Kingdom

Posted 10 October 2010 - 04:58 PM

Im having the same problem!

Im running a Toshiba Equium A100-337 and a Mobile Intel® 945 Express Chipset Family Graphics Card. Im not too keen on the idea of having to buy a new graphics card, but the driver update program on my laptop and the Toshiba website, says there is no better driver for it.

Im just not sure what to do, not to mention that I have already bought the game. leaving me with a lot of anger and frustration.

If anyone has got a solution to this problem, Id be really grateful.
Posted Image
Posted ImagePosted ImagePosted ImagePosted Image

#11

tristan123

Posted 06 December 2010 - 05:44 PM

i have the same problem and i really waqnt to play this please help me

#12

MKU
    MKU

    Iron Miner

  • Members
  • 273 posts

Posted 06 December 2010 - 05:46 PM

Here they come! Getcha penny farthings out! (Not the bicycle kind!)

dylanweber said:

Minecraft actually works. It's linked to your forum account. Whenever you don't understand what Beta means, more hours are added to the jar launcher's troll timer.

WTFClock said:

Is your hand ok
From punching that fire

#13

ezstar
    ezstar

    Newly Spawned

  • Members
  • 1 posts

Posted 25 January 2011 - 04:30 AM

I had to make an account just to reply here and say thanks to both Digithor and the OP. I've been dealing with the horrible lack of OpenGL support on the native Win7 drivers for this graphics card (I have the same laptop too), and the version seraphus used (10.2 legacy) worked fine for me. Now I can play minecraft! and many, many other indie titles that should have worked but didn't due to OpenGL problems. Anyone with a mobility chipset should give these things a try, even if you've been trying to fix the same  :(  :Spider:  :Zombie:  :Sheep: problem for 2.5 years and it hasn't worked.

#14

lumberking

Posted 13 March 2011 - 02:00 PM

I also have to thank this thread.  Had the same problem with the same specs (ATI HD 2300).  Playing Minecraft and enjoying it!

To make it simple for anyone just now trying this out,

1. Uninstall drivers.  Since I didn't want to F my computer up, I made sure to do it the right way, which cost me $10.  I got a driver cleaner from http://www.drivercleaner.net so I could have clear instructions on how to uninstall everything properly, and then their program cleaned everything up to make sure it was good for any new drivers I wanted to install.  There's probably a way to do this without paying, but that's what I did.

2. Use Digithor's link to get Mobility Modder

3. Make a search and download for "ati legacy 10.2 x#", where "#" is either 32 or 64 depending on your processor.  (Mine is 64-bit, so my search was "ati legacy 10.2 x64", and here's the link it got me http://support.amd.c... ... sta64.aspx )

3. Run Mobility Modder for your new driver software (MM has instructions)

4. Install the driver.

5. Enjoy Minecraft!

If I was too vague, let me know and I'll write something more specific.

#15

tkahn
    tkahn

    Newly Spawned

  • Members
  • 1 posts

Posted 30 June 2012 - 11:13 AM

Hi!

I used to have Minecraft up and running perfectly on a Fujitsu Siemens Amilo PI 2530 with Windows Vista installed.
This laptop has the ATI Radeon HD 2300 graphics chipset.

Yesterday I installed a new hard drive with a clean install of Windows 7.
After that Minecraft wouldn't start.

Having followed the various threads I understand that the out-of-the-box Windows drivers that I get when I install Windows 7 will not work with ATI Radeon HD 2300. I get the "Bad video card drivers" error. And I can't install the latest version of AMD Catalyst since it won't install on a computer with this rather old card. So I tried the ATI Legacy 10.2 version and patched it with MM. After that I could install Catalyst and it would run on the computer, but Minecraft still wouldn's work.

I think it's so strange that I can run it on Vista but not on Windows 7 with exactly the same hardware(!) This is also the reason why I haven't given up.

If everything else fails I still have the old hard disk with Vista on it intact so I could just install the old drive. But before I do that I would just like to check if anyone else have solved this problem.

Regards,
Thomas

- - -

UPDATE - PROBLEM SOLVED!
  • I decided to try one last thing. I went to the Fujitsu Siemens support page: http://support.ts.fu...nload/Index.asp

  • There I entered the data for Fujitsu Siemens Amilo PI 2530: Mobile Devices -> former models AMILO -> AMILO Pi -> AMILO Pi 2530

  • Then I expanded the Windows Vista list and selected Graphic. I downloaded the Mobility Radeon X2300 HD driver, version 8.37. This saved a zip archive on my disk.

  • I expanded the zip archive and located and clicked on Setup. I went through the installation process and in the end I was asked to reboot the computer.

  • I rebooted and when Windows 7 was done loading I fired up Minecraft and it worked!

I'm not 100% sure what did the trick. It could be the fact that I downloaded the driver pack from Fujitsu Siemens instead of AMD. Or it could be the "X" in the ATI Radeon X2300 HD that made all the difference?

If anyone knows, please post it here. I'm just happy I finally got it to work!