Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Failed to Find Accelerated OpenGL Mode[Problem Solved][Fix]


  • Please log in to reply
63 replies to this topic

#1

Riseing
    Riseing

    Zombie Killer

  • Members
  • 191 posts

Posted 30 September 2010 - 03:13 PM


Only attempt this fix if updating your graphics drivers has failed.


This is the fix that worked for me.

Mkay I know alot of people have this problem. It may not look exactly like this  but the main issue is "failed to find an accelerated OpenGL mode"


Example Error
Bad video card drivers!
-----------------------

Minecraft was unable to start because it failed to find an accelerated OpenGL mode.
This can usually be fixed by updating the video card drivers.



--- BEGIN ERROR REPORT 7fe0271 --------
Generated 30-9-10 0:01

Minecraft: Minecraft Alpha v1.1.2_01
OS: Windows Vista (x86) version 6.0
Java: 1.6.0_21, Sun Microsystems Inc.
VM: Java HotSpot(TM) Client VM (mixed mode, sharing), Sun Microsystems Inc.
LWJGL: 2.4.2
[failed to get system properties (java.lang.NullPointerException)]

org.lwjgl.LWJGLException: Pixel format not accelerated
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:185)
at org.lwjgl.opengl.Display.createWindow(Display.java:311)
at org.lwjgl.opengl.Display.create(Display.java:856)
at org.lwjgl.opengl.Display.create(Display.java:784)
at org.lwjgl.opengl.Display.create(Display.java:765)
at net.minecraft.client.Minecraft.a(SourceFile:196)
at net.minecraft.client.Minecraft.run(SourceFile:554)
at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT 6e25d0ea ----------


Before attempting this fix you need to have gone STEP BY STEP through this thread
viewtopic.php?f=17&t=39953


If your drivers are updated and you still have the problem then read on.

Disclaimer- In this I will be having you delete registry keys. This is at your own risk. i am not responsible if you fuck your computer. Please backup before you edit anything!

*Note- Do not attempt this fix if your graphics card is onboard.

Step One- Confirm your Error

In order for the fix to work you need to know this is the correct problem.
So visit http://www.realtech-...w/download.html

Download and install the openGL version viewer.

Now run it and navigate to the "Summary" Tab"
Posted Image

Now next to Renderer if it says GDI Generic then you have found your problem

Step Two- The Solution

Explanation
Heres whats going on.
You may have updated your drivers but windows is still reading the old OpenGL driver. To fix this you must remove the old one and make windows find the new one.

So lets solve this

1- Backup your registry NOW http://windowsxp.mvps.org/registry.htm

2- Make sure you are not using an onboard graphics card.
Rough Guide
1. Click "Start," then "All Programs," then "Accessories." Click "Run."

2. Type "devmgmt.msc" in the text field. Click "OK" to open Device Manager. If a User Account Control window appears asking for your permission to continue, click "Continue."

3. Click the plus sign located next to "Display Adapters" to find the name of your graphics card. If there is more than one driver displayed, it's possible that you have both a graphics card installed to one of the expansion slots on your computer and an onboard graphics card installed to your motherboard itself.

Please remember the name of your onboard card
you will need it later. Your onboard card should be the one on top.


3- Click "Start" then "Run" and type "regedit" and hit enter.
Navigate to HKEY_LOCAL_MACHINE/SOFTWARE/"Your Onboard card name"
Ex:
HKEY_LOCAL_MACHINE/SOFTWARE/Intel
HKEY_LOCAL_MACHINE/SOFTWARE/ATI
HKEY_LOCAL_MACHINE/SOFTWARE/NVIDIA
HKEY_LOCAL_MACHINE/SOFTWARE/SIS

4- Delete them. Delete the whole damn file. Kill all of your onboard drivers. Then reboot. (If you onboard and ofboard card have the same maker only delete the file with the onboard in it)
5- Run the openGL version viewer again and it should now say something different besides 'GDI Genric"

And there you go please enjoy. if anything detrimental happened to your computer please use that registry backup I had you create.

Register or log in to remove.

#2

Poohbear
    Poohbear

    Newly Spawned

  • Members
  • 1 posts

Posted 03 October 2010 - 12:15 PM

My appologies for the post but i rally want to play minecraft.
i have the error: org.lwjgl.LWJGL.Exception: pixel format not accelerated.
after some searching i found out it is a driver problem.
i have a ATI Mobility Radeon x1400 the i checked for updates on the ati radeon site.
they sent me to the manufacturer's site and according to that site i got the latest driver.
after that i checked if it was the opengl 2.0 problem with the opengl extensions checker.
this said i was using generic gdi and version 1.1.

now my question is does this also work for your laptop?

#3

zelemzol
    zelemzol

    Out of the Water

  • Members
  • 2 posts

Posted 06 October 2010 - 08:02 PM

Ive got the exact same problem. so i followed your steps up until the point of deleting the folder marked intel (thats my graphics card) and i was hovering over the delete button when i thought. why would deleting this folder change anything? so could op answer my Q please :)

#4

Riseing
    Riseing

    Zombie Killer

  • Members
  • 191 posts

Posted 08 October 2010 - 12:02 PM

Because Windows for some reason will sometimes refuse to drop the old Open GL driver and you need to help it out. By removing the old one you are forcing Windows to find your new one.


Poohbear said:

My appologies for the post but i rally want to play minecraft.
i have the error: org.lwjgl.LWJGL.Exception: pixel format not accelerated.
after some searching i found out it is a driver problem.
i have a ATI Mobility Radeon x1400 the i checked for updates on the ati radeon site.
they sent me to the manufacturer's site and according to that site i got the latest driver.
after that i checked if it was the opengl 2.0 problem with the opengl extensions checker.
this said i was using generic gdi and version 1.1.

now my question is does this also work for your laptop?
I have no idea.....try it and find out =/

#5

Annuh
    Annuh

    Tree Puncher

  • Members
  • 31 posts

Posted 08 October 2010 - 12:45 PM

Holy you were so right about the drivers, I have an Nvidia 7950 gt and I had updated them to the latest ones 259.31 and when I checked in the device manager the driver date said 2008! I am going to see if deleting the old one will fix it *fingers crossed* haha

#6

Riseing
    Riseing

    Zombie Killer

  • Members
  • 191 posts

Posted 11 October 2010 - 03:59 PM

Please post back with the results.

#7

Jackler
    Jackler

    Out of the Water

  • Members
  • 6 posts

Posted 12 October 2010 - 04:40 AM


EDIT: **Minecraft works now**. I found and deleted the "ASUS Enhanced Display Driver". Rebooted, and WinXP now sees OpenGL 3.3. :Skeleton:


I will try this. I'm having the same OpenGL 1.1 bug too. 9600GT card here on WinXP32.

Edit: Still getting OpenGL 1.1 here after deleting the registry keys in [HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation]. I even tried deleting the
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\OpenGLDrivers] branch as i saw these entries in there:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\OpenGLDrivers\ATKOGL]
"Dll"="ATKOGL32.dll"
"DriverVersion"=dword:00010000
"Flags"=dword:00000003
"Version"=dword:00000002

After deleting the keys, uninstalling the drivers, and rebooting, then reinstalling. Sure enough, the following entries came back:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\OpenGLDrivers\RIVATNT]
"Dll"="nvoglnt"
"DriverVersion"=dword:00010000
"Flags"=dword:00000003
"Version"=dword:00000002

Have not tried deleting the INTEL keys though, as i'm pretty sure my motherboard doesn't support any onboard graphics.

#8

Turkeyrox2
  • Location: Alberta, Canada

Posted 13 October 2010 - 03:47 AM

you said several times not to do this if using an on-board graphics card, so two questions
1. why?
2. if i shouldnt do this fix, what other ways are there to fixing this?

#9

sinjin13
    sinjin13

    Newly Spawned

  • Members
  • 1 posts

Posted 15 October 2010 - 11:02 PM

I went through all of your steps and deleted the ATI onboard video card files in the registry. My PCIex video card is an Nvidia Geforce gt220 and the drivers were up to date but i tried reinstalling them to make sure. i checked the opengl version and it is still saying 1.1 for some reason even though my card can handle up to 3.3. please help.

#10

Riseing
    Riseing

    Zombie Killer

  • Members
  • 191 posts

Posted 20 October 2010 - 12:31 PM

Make sure they all got deleted.

#11

Cabbage
    Cabbage

    Tree Puncher

  • Members
  • 24 posts

Posted 20 October 2010 - 03:50 PM

Well, i've only got an onboard graphics Card (Nvidia GeForce GT220) And you said, not to do this with an onboard graphics card...
Do i have to buy an offboard card to use this fix? Because the PC doesn't work, if i take the graphics Card out of it, right?
I don't do it for tha Money! I do it for tha Diamonds!!

trunksbomb said:

    

GoodOldGamer said:

      What's mine is mine when I mine. :o)
But it's mine when you mine in my mine. You can keep what you mine in your mine, mind you.

#12

Pjczar
    Pjczar

    Tree Puncher

  • Members
  • 12 posts

Posted 20 October 2010 - 10:27 PM

I was able to find every thing exactly as you listed them but when i deleted the folder and rebooted, nothing had changed except now the folder is gone.  I cant re-delete becuase its not there, but it also didnt change anything.
thanks for all this though

*EDIT*
Turns out i needed to update my entire PC.  after i did that,  took about 30 minutes, I was able to run the game.

Thanks to everyone who posted about how they fixed thier problem and to OP.

This thread is now  :Skeleton:  :iapprove:  :P  :stone:

#13

iChorion
    iChorion

    Out of the Water

  • Members
  • 3 posts

Posted 20 October 2010 - 11:31 PM

Umm mine doesnt say GD Generic. It says Intel®965 Chipset Accelerator :D so i did not find my problem. any suggestions?

#14

Thujone1
    Thujone1

    Out of the Water

  • Members
  • 2 posts

Posted 22 October 2010 - 03:39 PM

Problem resolved,  Don't try to run over remote desktop! ;)

#15

Dr_Rhythmus

Posted 23 October 2010 - 03:33 PM

Mhm, I have tried all the steps in the other thread you linked to and all the steps in this thread and still it says
GDI Generic on OpenGL Extensions Viewer.

Is it possible that I did something wrong?
I have an ATI Radeon X1950 GT and am running Windows 7 32bit
I use these drivers: 10-2_legacy_vista32-64_wdm.exe
I deleted the ATI folder from my registry and the intel folder. I did not find a NVidia or SIS Folder.

#16

PolakXXL
    PolakXXL

    Tree Puncher

  • Members
  • 21 posts

Posted 23 October 2010 - 04:10 PM

For me there isnt any GDI Generic.

I'ts
Intel 965 963 Graphic Media Accelelator
What now?

1000x :Yellow:  for anyone who will help.

BTW
My open Gl version is 1.5
What one i need?

#17

iChorion
    iChorion

    Out of the Water

  • Members
  • 3 posts

Posted 23 October 2010 - 05:26 PM

@PolakXXL: Me too dude. mine says the exact same. :P and for somereason /the program doesnt show the type of openGl i have

#18

Turkeyrox2
  • Location: Alberta, Canada

Posted 23 October 2010 - 10:45 PM

PolakXXL said:

BTW
My open Gl version is 1.5
What one i need?

i believe that you need atleast version 2 to run minecraft from your pc
although, i heard you can do a different fix if its above 1.4....

ill search around for what i found as the temp fix, but getting the updated version of GL is probs your best fix

#19

brine
    brine

    Out of the Water

  • Members
  • 2 posts

Posted 24 October 2010 - 01:46 AM

I just want to add some extra steps to your procedure in the original post.

I used the procedure unsuccessfully, it seemed that no matter what version of the ATI graphics driver I installed, my openGL version was always 1.1.  I tried the registry changes as well as deleting the ATI folders in the C:/ and program files.

I have an HP laptop with ATI radeon graphics card, this may be a unique issue to this combination but it may work with other combos as well (i.e. Toshiba, NVIDIA, etc)

Here's what I did BEFORE DOING THE ABOVE PROCEDURE to get it working:

1. Download the latest ATI catalyst driver (this might work with NVIDIA's equivalent driver as well, haven't tested it)
2. Find where the setup files are unzipped, for ATI it's at C:\ATI\SUPPORT\10-10_vista64_win7_64_dd_ccc_ocl  (or whatever driver you have)
3. Copy the contents of this folder, then go to C:\SWSETUP\DRIVERS\VIDEO  and delete the contents of this folder, replacing them with your pasted files.   NOTE:  This is where the folder is for HP computers, other brands may have them in a different folder.  The important thing to know is that this is the folder where all the factory default drivers are located.
4. Go to C:\WINDOWS\SYSTEM32 and scroll down to the ATI files, there will be a whole bunch of them.  Move these to a safe place in your desktop, DO NOT DELETE BECAUSE I AM NOT 100% SURE THESE ARE ACTUALLY ATI GRAPHICS FILES.  The goal is just to take them out of the system folder.
5. Now uninstall your current graphics driver, delete the registry values, and program files as per above procedure
6. Reboot computer, once loaded back up windows should attempt to locate a driver for the now non-existant graphics driver.  Let it finish, but just to be safe install the driver you got from step 1 again.  Reboot.

My theory is that as soon as you uninstall the graphics driver, windows automatically searches for a driver to reinstall, first looking in the factory-default SWSETUP folder.  This driver is badly outdated.  However, for some stupid reason attempting to install/update a new driver never seems to work properly.  So this will trick windows to start fresh with the most updated driver.

#20

Swifty
    Swifty

    Out of the Water

  • Members
  • 3 posts

Posted 24 October 2010 - 02:40 AM

I assume you're screwed if you only have one video card driver?