Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

no route to host?


  • Please log in to reply
No replies to this topic

#1

cosmoji
    cosmoji

    Out of the Water

  • Members
  • 3 posts

Posted 24 September 2010 - 07:28 PM

i've dug and dug and have yet to find any post that covers this for me, so i'll ask directly.  hopefully somebody knows what i'm doing wrong.  my friend always gets "java.net no route to host"

     i'm trying to host a server for a friend and i to play the alpha multiplayer together.  i have forewarded the port(25565) through both my router and windows firewall.  my antivirues does not act as a firewall, but i have made sure it allows the programs.  in my server properties i have changed the name check to false(in the hopes it might make connecting easier), the monsters to true(so i can get stuff from them) and have put my internal ip into the server ip field.
      now, before somebody says that's the problem, we've had the same problem with or without it.  the only difference i've seen is that with it blank, i can enter my world with "localhost" and with the ip in there, i have to use my internal ip to connect.
     i'm honestly at a loss.  i know what i'm doing with computers for the most part, but i learn everything by experience, and have no idea what i'm doing with servers, this being the first thing i've ever tried.  can anybody tell me where we're going wrong?

_______________________________

well, nobody has responded, but i do believe i've fixed it myself.  if it's telling you there's no route to host, it means that IN YOUR ROUTER the port is opening, but it is not pointing that connection to your computer.  you need to enter your internal ip in the ip field when setting up the port forewarding.   then save it, start your server, and you can check if you're having success with canyouseeme.org and puting in the port you're using for minecraft.

i for some reason have a wrong ip set up for my bittorrent client(though it beats me how its still working) and had coppied that.  i didnt know what i had to use for the ip field, and copied the wrong one.  now that i've typed it in correctly, i've had a successful connection with canyouseeme.  before you panic, you will see on the server console that an ip had disconnected, that was the quick connect and disconnect of canyouseeme testing the port.

Register or log in to remove.