Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[Windows 7] Blackscreen after login


  • Please log in to reply
26 replies to this topic

#1

Mannerheim

Posted 21 September 2010 - 10:08 AM

Hey guys!

I bought and downloaded Minecraft this thursday and have played it frequently ever since. I played about 4 hours earlier today and now when I try to launch it wont start!

After I've clicked the client, filled in my username and password and pressed "Login" I get a quick glimpse of the loading bar displaying "Updating something..." and then it is just pitch black. Nothing happends until I shut down the client by pressing the red exit button.

I have already tried to re-install Java and I've downloaded the game client (both versions from http://www.minecraft.net/) several times with no results.

Is this happening to anyone else? What should I do to fix the problem?

:P

Register or log in to remove.

#2

bigpapi567

Posted 21 September 2010 - 01:43 PM

im running vista having the same problem wierdest part is i could play it fine for a while and im going on a week with it doing this

#3

WitchHunter

Posted 21 September 2010 - 04:43 PM

Go to Appdate> Roaming ( to do this, press the Windows logo +r to run, and type %appdata% and OK)
Go into the .minecraft folder, and DELETE EVERYTHING EXCEPT THE SAVES FOLDER.
When you start MineCraft up, the Black Screen won't appear anymore.

It worked for me, hope it'll also help you guys.
Posted Image  Posted Image

#4

happyknife

Posted 21 September 2010 - 04:52 PM

It downloaded, then went to a black screen... :P

#5

Deluxx
    Deluxx

    Forum/Wiki Sponsor

  • Curse Premium
  • 33 posts
  • Minecraft: Deluxx

Posted 21 September 2010 - 06:08 PM

Yeah, same problem here.


Although, it still works on my other Windows XP computer.

#6

whythisname

Posted 22 September 2010 - 12:38 PM

WitchHunter said:

Go to Appdate> Roaming ( to do this, press the Windows logo +r to run, and type %appdata% and OK)
Go into the .minecraft folder, and DELETE EVERYTHING EXCEPT THE SAVES FOLDER.
When you start MineCraft up, the Black Screen won't appear anymore.

It worked for me, hope it'll also help you guys.

Have been having the same black screen issue as you guys since the server went down (on Win 7 Ulti 64-bit), but the solution WitchHunter gave worked like a charm for me as well :iapprove: I did need to play it online once though (online as in your browser on the minecraft homepage).

#7

Darkflere
  • Location: Aotearoa

Posted 24 September 2010 - 10:39 AM

WitchHunter said:

Go to Appdate> Roaming ( to do this, press the Windows logo +r to run, and type %appdata% and OK)
Go into the .minecraft folder, and DELETE EVERYTHING EXCEPT THE SAVES FOLDER.
When you start MineCraft up, the Black Screen won't appear anymore.

It worked for me, hope it'll also help you guys.

Worked for me also, ty. <3
Posted Image

#8

Micta
    Micta

    Tree Puncher

  • Members
  • 14 posts

Posted 01 November 2010 - 05:52 PM

I'm still having this problem. I've already tried deleting my .minecraft. :c
Is it just me, now?

#9

thetyler101

Posted 01 November 2010 - 06:30 PM

Micta said:

I'm still having this problem. I've already tried deleting my .minecraft. :c
Is it just me, now?

Nope, I still have this problem. First time playing, can't log in once on my machine. Keep getting this weird error every time too. Works for XP machines at school just fine though. :SSSS:

#10

rueracer
    rueracer

    Out of the Water

  • Members
  • 3 posts

Posted 02 November 2010 - 04:34 AM

WitchHunter said:

Go to Appdate> Roaming ( to do this, press the Windows logo +r to run, and type %appdata% and OK)
Go into the .minecraft folder, and DELETE EVERYTHING EXCEPT THE SAVES FOLDER.
When you start MineCraft up, the Black Screen won't appear anymore.

It worked for me, hope it'll also help you guys.

This worked perfectly, I deleted everything but the file Last Login and it works now.

#11

FWEAS
    FWEAS

    Tree Puncher

  • Members
  • 10 posts

Posted 25 November 2010 - 11:39 PM

Finally a solution with a decent chance of success, worked perfectly for me, thanks.
I looked out upon this fledgling world, a land of opportunity, and I conquered it.

#12

Ninjy
    Ninjy

    Tree Puncher

  • Members
  • 30 posts

Posted 11 January 2011 - 04:54 AM

it doesn't work for me ive already done that deleting stuff but it didn't work
i could go on for a day and then the next day i couldn't
+ there would aslo be errors in notepads that poped up on my desktop
My Minecraft Blog
http://ninjy7.tumblr.com/

Posted Image

#13

Benjipants

Posted 11 January 2011 - 06:33 AM

i have same trouble but its an OpenGL problem.

How do you change it from direct x to open gl on windows 7?
Posted Image Posted Image Posted Image Posted Image

#14

fatsofatso

Posted 18 February 2011 - 10:14 PM

rueracer said:

WitchHunter said:

Go to Appdate> Roaming ( to do this, press the Windows logo +r to run, and type %appdata% and OK)
Go into the .minecraft folder, and DELETE EVERYTHING EXCEPT THE SAVES FOLDER.
When you start MineCraft up, the Black Screen won't appear anymore.

It worked for me, hope it'll also help you guys.

This worked perfectly, I deleted everything but the file Last Login and it works now.
:obsidian: i just got this computer, and i don't have a last login save to save, so i try to delete the .minecraft folder and redownload, but it does not work...

i have survived for two weeks without minecraft on my computer, but i'm not sure how much longer i can last @_@
Posted Image

Posted Image

#15

tie_twix
    tie_twix

    Redstone Miner

  • Members
  • 558 posts
  • Location: England

Posted 18 February 2011 - 10:32 PM

WitchHunter said:

Go to Appdate> Roaming ( to do this, press the Windows logo +r to run, and type %appdata% and OK)
Go into the .minecraft folder, and DELETE EVERYTHING EXCEPT THE SAVES FOLDER.
When you start MineCraft up, the Black Screen won't appear anymore.

This doesn't work for me either, I've tried all the methods posted on Minecraftforums and I still get the black screen. Do you think it might just fix itself if I leave it on the black screen for as long as I can afford?

Edit: I should probably say that at the same time I started black screening on Minecraft Beta, the same started happening on Classic aswell. I never had this problem before today.
Posted Image

#16

gnomeo76

Posted 21 February 2011 - 05:26 PM

Worked well, and after a while and all the files had been regenerated it went black again. do you know what i should do?

#17

Tezor01
    Tezor01

    Out of the Water

  • Members
  • 6 posts

Posted 20 April 2011 - 05:59 PM

seems like this error is only on Vista/7 . i have win 7 :sponge:  , when i log in and load the map i'm playing for 2-10 mins and then the blackscreen strikes. I Re-installed java over and over i've COMPLETLY deleted every single minecraft thing from my PC and still the black screen strikes. i can play it in browser on the minecraft site but if u have mods the browser won't work, and i can't live without mods.... guess :Iron:  Notch :Iron:  needs to do something. Minecraft is a great game i don't want to stop playing it bcz this stupid error. :Iron:

#18

madjack32
  • Location: Minecraftia / Netherlands
  • Minecraft: madjack32

Posted 24 September 2011 - 12:17 PM

Ok i might have something that helps:
Just as you get a blackscreen, start spam-clicking the minecraft window, usually you would get an error message(You can either wait a period of time too, but spam clicking is faster).

I  got this error message;
	  Bad video card drivers!	  
	  -----------------------	  

Minecraft was unable to start because it failed to find an accelerated OpenGL mode.
This can usually be fixed by updating the video card drivers.



--- BEGIN ERROR REPORT 7fe0271 --------
Generated 24-9-11 14:10

Minecraft: Minecraft Beta 1.8.1
OS: Windows 7 (x86) version 6.1
Java: 1.6.0_27, Sun Microsystems Inc.
VM: Java HotSpot(TM) Client VM (mixed mode), Sun Microsystems Inc.
LWJGL: 2.4.2
[failed to get system properties (java.lang.NullPointerException)]

org.lwjgl.LWJGLException: Pixel format not accelerated
	at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
	at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
	at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:185)
	at org.lwjgl.opengl.Display.createWindow(Display.java:311)
	at org.lwjgl.opengl.Display.create(Display.java:856)
	at org.lwjgl.opengl.Display.create(Display.java:784)
	at org.lwjgl.opengl.Display.create(Display.java:765)
	at net.minecraft.client.Minecraft.a(SourceFile:233)
	at net.minecraft.client.Minecraft.run(SourceFile:629)
	at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT b93425ef ----------


And if you DO NOT get an error message, try updating your java!
but anyhow, This error message is REALLY helpful, since as you can see, java tells me that my Video card drivers are not up-to-date.

This causes an OpenGL problem, and since minecraft uses OpenGL, it cant run!
I hope this helps, --madjack32

Edit: i took the long way, and decided that i wanted to check what video card i had(NVIDIA GEFORCE 7025),
and all i had to do was right click it and select "Update drivers".
P.S. if you take MY way, its the long way, usually you can just use the NVIDIA/Radeon control panel, but i didnt have that....
meh. + Special thx to scokeev9
Posted Image

#19

richerds1234

Posted 28 December 2011 - 02:47 AM

View Postmadjack32, on 24 September 2011 - 12:17 PM, said:

Ok i might have something that helps:
Just as you get a blackscreen, start spam-clicking the minecraft window, usually you would get an error message(You can either wait a period of time too, but spam clicking is faster).

I  got this error message;
	  Bad video card drivers!	  
	  -----------------------	  

Minecraft was unable to start because it failed to find an accelerated OpenGL mode.
This can usually be fixed by updating the video card drivers.



--- BEGIN ERROR REPORT 7fe0271 --------
Generated 24-9-11 14:10

Minecraft: Minecraft Beta 1.8.1
OS: Windows 7 (x86) version 6.1
Java: 1.6.0_27, Sun Microsystems Inc.
VM: Java HotSpot(TM) Client VM (mixed mode), Sun Microsystems Inc.
LWJGL: 2.4.2
[failed to get system properties (java.lang.NullPointerException)]

org.lwjgl.LWJGLException: Pixel format not accelerated
	at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
	at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
	at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:185)
	at org.lwjgl.opengl.Display.createWindow(Display.java:311)
	at org.lwjgl.opengl.Display.create(Display.java:856)
	at org.lwjgl.opengl.Display.create(Display.java:784)
	at org.lwjgl.opengl.Display.create(Display.java:765)
	at net.minecraft.client.Minecraft.a(SourceFile:233)
	at net.minecraft.client.Minecraft.run(SourceFile:629)
	at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT b93425ef ----------


And if you DO NOT get an error message, try updating your java!
but anyhow, This error message is REALLY helpful, since as you can see, java tells me that my Video card drivers are not up-to-date.

This causes an OpenGL problem, and since minecraft uses OpenGL, it cant run!
I hope this helps, --madjack32

Edit: i took the long way, and decided that i wanted to check what video card i had(NVIDIA GEFORCE 7025),
and all i had to do was right click it and select "Update drivers".
P.S. if you take MY way, its the long way, usually you can just use the NVIDIA/Radeon control panel, but i didnt have that....
your a idiot thats not what the rest of us are geting we dont get a eror mesage we black screen with no mods nothing we just on get a blackscreen after we lanch the game

#20

dynamic_darkhead

Posted 07 January 2012 - 06:30 PM

i deleted anything that has the name minecraft and re-downloaded the lot now it seems to work