Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Minecraft Version Changer


  • Please log in to reply
37 replies to this topic

#1

flippit
    flippit

    Tree Puncher

  • Members
  • 23 posts

Posted 23 April 2011 - 04:57 AM

The public release of Minecraft Version Changer is finally here, a small utility I wrote to change your Minecraft version so you can connect to servers running older Minecraft versions. You will find it at http://flippit.ath.cx.  I hope you find it useful.

flippit.

Register or log in to remove.

#2

CorruptedDragon

Posted 23 April 2011 - 05:01 AM

you do relize that theres already somthing out there like this, and infact a lot more people are likley to use it then this due to the information provided, this post will be regarded as spam. add pics add details and then this topic might go somewhere.

#3

flippit
    flippit

    Tree Puncher

  • Members
  • 23 posts

Posted 23 April 2011 - 05:15 AM

CorruptedDragon said:

you do relize that theres already somthing out there like this, and infact a lot more people are likley to use it then this due to the information provided, this post will be regarded as spam. add pics add details and then this topic might go somewhere.

Hi CorruptedDragon,

Thanks for your honest feedback.  My intention is not to create spam, but share a utility that I originally wrote for family members who use my brother's Minecraft server.  It has taken me a while to write this as before I did I had never used visual basic and I had to learn a lot.  When I started writing it there was nothing I could find that did the job, there may be alternatives available now, if so that's good for all of us who enjoy Minecraft.

Regards,

flippit.

#4

flippit
    flippit

    Tree Puncher

  • Members
  • 23 posts

Posted 23 April 2011 - 05:22 AM

I've got a screenshot to post but I keep getting this message when I try to upload:

"Sorry, the board attachment quota has been reached."

any ideas?

flippit

#5

Desttroy4

Posted 23 April 2011 - 06:02 AM

flipit, use an image hosting site such as http://imgur.com and the use the iamge tags to post your image. btw here is a program like yours Posted Image
Hope i Helped :Notch:
Posted Image

#6

flippit
    flippit

    Tree Puncher

  • Members
  • 23 posts

Posted 23 April 2011 - 06:58 AM

Here is a screenshot:

Posted Image

Thanks Desttroy4 for your help.  The screenshot you posted of the other program looks so similar to mine, it's amazingly similar looking and no wonder CorruptedDragon thought it was some sort of copy!

flippit.

#7

danpengo
    danpengo

    Out of the Water

  • Members
  • 3 posts
  • Minecraft: danpengo

Posted 23 April 2011 - 07:44 AM

It Worked Last Version!

I Will Try This Version

:SSSS:  :Notch:
:Ham:  :Diamond:
:Iron:  :tnt:

#8

Lgit_NewB

Posted 23 April 2011 - 08:10 AM

Umm, Why does it require SP3?

#9

flippit
    flippit

    Tree Puncher

  • Members
  • 23 posts

Posted 23 April 2011 - 09:42 AM

Lgit_NewB said:

Umm, Why does it require SP3?

Hi Lgit_NewB and thanks for your question.  MVC needs Microsoft .NET 4 to be installed on your computer.  Some people may already have this but if not it then it is a free download from Microsoft and the current link to the download page for this is on the MVC website at http://flippit.ath.cx.  Microsoft lists the Windows platforms that support  .NET 4 and for XP they specify SP3.  If you are running XP then maybe earlier service packs will work too and Microsoft are just promoting their latest service pack for XP!

Basically if you have .NET 4 then MVC will install.  MVC checks for the presence of .NET4 during installation and will display a message to advise if it is needed.  Later versions of Windows should have no problem.

#10

flippit
    flippit

    Tree Puncher

  • Members
  • 23 posts

Posted 02 May 2011 - 03:36 PM



#11

Elite6809
  • Location: Depends which world I'm in...
  • Minecraft: Elite6809
  • Xbox:Elite 6809

Posted 02 May 2011 - 04:07 PM

If this contains/downloads the .jar files directly then it's against the board rules. You can't distribute .jar files, or tools to distribute .jar files in any way, shape or form.
If it uses bsdiff/bspatch like MCNostalgia, though, you're OK.

05 Dec 2010 - Today


#12

flippit
    flippit

    Tree Puncher

  • Members
  • 23 posts

Posted 02 May 2011 - 11:56 PM

Elite6809 said:

If this contains/downloads the .jar files directly then it's against the board rules. You can't distribute .jar files, or tools to distribute .jar files in any way, shape or form.
If it uses bsdiff/bspatch like MCNostalgia, though, you're OK.

Thanks Elite8609 for sharing your point of view.  This issue is discussed in the FAQ section on the MVC site at http://flippit.ath.cx

#13

flippit
    flippit

    Tree Puncher

  • Members
  • 23 posts

Posted 30 May 2011 - 02:22 AM

Version 7.0 of Minecraft Version Changer has been released, with support for Minecraft versions up to Beta 1.6.5

Minecraft Version Changer is available at http://flippit.ath.cx

Screenshot:
http://i.imgur.com/JwfRB.jpg

#14

=D
    =D

    Redstone Miner

  • Members
  • 600 posts
  • Location: In the Rainbow Factory. Where you fears and horrors come true.

Posted 30 May 2011 - 08:07 AM

Like it but I don't need it and I has alot of mods that's be destroyed :D

Posted Image

http://www.desktopponies.com/ (<--- didnt make but 100% support)


#15

flippit
    flippit

    Tree Puncher

  • Members
  • 23 posts

Posted 05 June 2011 - 11:43 PM

View Post=D, on 30 May 2011 - 08:07 AM, said:

Like it but I don't need it and I has alot of mods that's be destroyed :D

A good point, thanks for raising it. Minecraft Version Changer uses clean, unmodified copies of version files, so if you are one of the people who have modified Minecraft with client side mods these will need to be reinstalled after making a version change.

#16

flippit
    flippit

    Tree Puncher

  • Members
  • 23 posts

Posted 05 June 2011 - 11:45 PM

Version 8.0 of Minecraft Version Changer has been released, with support for Minecraft versions up to Beta 1.6.6

Minecraft Version Changer is available at http://flippit.ath.cx

Screenshot: http://i.imgur.com/uIdC1.jpg

#17

LukeRay
    LukeRay

    Iron Miner

  • Members
  • 270 posts
  • Location: Zielonka, Poland
  • Minecraft: LukeRay

Posted 06 June 2011 - 07:28 AM

Another program to change Minecraft version... :P

Here is mine and does similar things:

Posted Image


However, my version doesn't contain Minecraft files. It just makes backup of every version you have and then allows you to play them after updates.

Posted Image


#18

=D
    =D

    Redstone Miner

  • Members
  • 600 posts
  • Location: In the Rainbow Factory. Where you fears and horrors come true.

Posted 06 June 2011 - 11:26 AM

*lulz*
since my last post I need this quite alot

*lulz more*

Posted Image

http://www.desktopponies.com/ (<--- didnt make but 100% support)


#19

petersmileface
  • Location: Australia
  • Minecraft: petersmileyface

Posted 06 June 2011 - 12:08 PM

These program variations keep getting better and better imo

#20

flippit
    flippit

    Tree Puncher

  • Members
  • 23 posts

Posted 07 June 2011 - 06:40 AM

View PostLukeRay, on 06 June 2011 - 07:28 AM, said:

Another program to change Minecraft version... :P

Hi LukeRay,

I tried your app "Minecraft Versions" (v1.1_01).  It worked well for me and looks great.  Congratulations on putting this together and well done.

flippit.