Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

accelerated OpenGL mode


  • Please log in to reply
98 replies to this topic

#1

Decidus_Raiken

Posted 30 August 2010 - 06:42 PM

I installed the game after purchase and i can't get it to work. I load her up and this is what i get;

      Bad video card drivers!      
      -----------------------      

Minecraft was unable to start because it failed to find an accelerated OpenGL mode.
This can usually be fixed by updating the video card drivers.



--- BEGIN ERROR REPORT 7fe0271 --------
Generated 8/30/10 2:16 PM

Minecraft: Minecraft Alpha v1.0.17_04
OS: Windows 7 (x86) version 6.1
Java: 1.6.0_21, Sun Microsystems Inc.
VM: Java HotSpot™ Client VM (mixed mode), Sun Microsystems Inc.
LWJGL: 2.4.2
[failed to get system properties (java.lang.NullPointerException)]

org.lwjgl.LWJGLException: Pixel format not accelerated
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:185)
at org.lwjgl.opengl.Display.createWindow(Display.java:311)
at org.lwjgl.opengl.Display.create(Display.java:856)
at org.lwjgl.opengl.Display.create(Display.java:784)
at org.lwjgl.opengl.Display.create(Display.java:765)
at net.minecraft.client.Minecraft.a(SourceFile:196)
at net.minecraft.client.Minecraft.run(SourceFile:553)
at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT 62fd04ec ----------


I'm running a Radeon X1950 Series, ATI technologies. I reinstalled the drivers, thinking that might work. I honestly have no idea though.

Register or log in to remove.

#2

boran_blok
    boran_blok

    Lapis Lazuli Collector

  • Members
  • 936 posts

Posted 30 August 2010 - 08:38 PM

Did you reinstall the driver from the ATI page? (see my sig)
Minecraft does not run? Check the alpha Hardware Requirements
Update your drivers for Intel, ATI and nVidia
Getting the message "Customized computer manufacturer graphics driver is detected" ? Use the workaround described here

#3

ryuuzaki
    ryuuzaki

    Tree Puncher

  • Members
  • 22 posts

Posted 13 September 2010 - 02:06 PM

I have installed the latest drivers for my ATI mobility radeon HD 4570 graphics card from the ATI page, and it still shows the same error as posted here.
I'm running on Windows 7 64-bit.
Is there some other solution to this problem???

#4

Milo1337
    Milo1337

    Tree Puncher

  • Members
  • 37 posts

Posted 13 September 2010 - 03:17 PM

viewtopic.php?f=17&t=35672

Try the things suggested there

#5

Nytmare
    Nytmare

    Tree Puncher

  • Members
  • 33 posts
  • Location: Pittsburgh, PA, USA, Earth

Posted 03 October 2010 - 04:57 PM

So just to add to the confusion:  I bought MineCraft for my laptop while I was on vacation and everything worked perfectly, till I unplugged my secondary monitor.

With the secondary monitor, my drivers are fine.  With just the laptop screen, my drivers are inadequate.

WTF, over?

#6

kjym
    kjym

    Newly Spawned

  • Members
  • 1 posts

Posted 17 October 2010 - 01:22 PM

For my computer I just changed the screen setting. In the advanced settings I changed the accelarations setting from full to somewhere in the middle. Works fine!

Good luck!

#7

andubadea

Posted 01 November 2010 - 08:00 AM

i discovered a way to play minecraft even with bad drivers.... write "java -Xmx800m -jar "C:\Documents and Settings\NAME\Desktop\Minecraft.jar" in cmd.... move the minecraft.exe to desktop and rename it minecraft.jar....it should work

#8

StrykeBlayde

Posted 20 December 2010 - 03:32 AM

andubadea said:

i discovered a way to play minecraft even with bad drivers.... write "java -Xmx800m -jar "C:\Documents and Settings\NAME\Desktop\Minecraft.jar" in cmd.... move the minecraft.exe to desktop and rename it minecraft.jar....it should work

So I bought the game just now and I'm having the same problem as the OP.

Can someone translate the quoted post into English for someone who isn't quite 'tech-savvy'?

#9

TheGuardian001

Posted 20 December 2010 - 04:09 AM

StrykeBlayde said:

andubadea said:

i discovered a way to play minecraft even with bad drivers.... write "java -Xmx800m -jar "C:\Documents and Settings\NAME\Desktop\Minecraft.jar" in cmd.... move the minecraft.exe to desktop and rename it minecraft.jar....it should work

So I bought the game just now and I'm having the same problem as the OP.

Can someone translate the quoted post into English for someone who isn't quite 'tech-savvy'?
That was the non-tech savvy version. Just type the command (java -Xmx800M -jar "LOCATION_OF_MINECRAFT_HERE") into cmd (start->run->cmd).

#10

miner3216

Posted 21 December 2010 - 08:13 PM

Where was I supposed to go to change my acceleration settings?

#11

luckyseth

Posted 23 December 2010 - 08:47 PM

HELP ME TOO I HAVE NO IDEA ON WHAT TO DO ARRGH I WAS ABLE TO PLAY IT FOR ABOUT A WEEK THEN I HAD TO GET A NEW HARD DRIVE (CORRUPT) AND NOW IT DOESN'T WORK! (IM GONNA CRY) NOT EVEN CLASSIC! RAAAAAAAAAAAAAAAAAAAAAAAAAAGE!!!!!!! :D  :VV:  :VV:  :VV:  :VV:

#12

andubadea

Posted 26 December 2010 - 03:48 PM

luckyseth, what error do you get when you try to play??
Try the solutions above and if they don't work, try reinstalling java....

#13

adiktuz
    adiktuz

    Newly Spawned

  • Members
  • 1 posts

Posted 31 December 2010 - 10:06 AM

Do this...

put your minecraft.exe in any folder, just make sure you copy the path, and rename it to minecraft.jar

then open notepad, paste this line

java -Xmx800m -jar "PATH\Minecraft.jar

paste the path to the folder where minecraft is into PATH

then click save -> save it as NAME.bat (NAME can be anything that you want)

then from now on, double-click this NAME.bat file to open minecraft... and do not close the cmd that will open...

example:

I put minecraft.jar on C:\

so on notepad I do this:
java -Xmx800m -jar "C:\Minecraft.jar

#14

JustAnOrange

Posted 02 January 2011 - 06:58 PM

Hey,

I tried to do the thing with the notepad but when I open it, in a flash it says: 'Unable to access jarfile C:\Minecraft.jar'
(I saved the jar file directly on the C: thing(dunno how it's called in English, I'm Dutch)).
What's wrong?

And I have a second question:
You said you need to make it a .jar file but do I only have to rename it to: Minecraft.jar or do I have to do lotsa hard things? :o

Thanks

#15

DracoSilverscar

Posted 04 January 2011 - 01:39 AM

I'm running a Radeon 9800 Pro and it refuses to open for the same reason... The drivers are as updated as they get. Any solution?...

#16

Scheballs

Posted 07 January 2011 - 05:08 PM

JustAnOrange said:

Hey,

I tried to do the thing with the notepad but when I open it, in a flash it says: 'Unable to access jarfile C:\Minecraft.jar'
(I saved the jar file directly on the C: thing(dunno how it's called in English, I'm Dutch)).
What's wrong?

Thanks

I am having the same problem as JustAnOrange is having, The .bat file when double clicked just flashes that command window, nothing else. I have a gateway laptop and have had a very hard time getting display drivers to be recognized. In my device manager it shows that I have the up to date drivers installed but the dxdiag in the command window does not even show a graphics card.
I have a Nvida 8800M GTS 512Mb card, I know it works great I've ran EvE online for over 3 yrs and when I stoped EvE and started newer games like Star Trek Online, Thats where my display drivers were having issues. I mean I cant even run minecraft for Gods sake!   Im searching for help anywhere I can!

#17

okal
    okal

    Glowstone Miner

  • Curse Premium
  • Curse Premium
  • 3497 posts
  • Location: UK

Posted 07 January 2011 - 05:23 PM

Scheballs said:

dxdiag in the command window does not even show a graphics card.
Device Manager is showing the 260.99 drivers installed? Do the 8800M drivers on nvidia.com not work?
Can you clarify the above? If the device is not present in dxdiag then a right-click Uninstall in Device Manager, reboot, should fix it.
The .bat file not working indicates you typed something wrong, I'd start by checking you enclosed the path in ""
I can't see why it would fix the issue reported though, all it does is allocate more RAM to Minecraft.

#18

naisanza
    naisanza

    Newly Spawned

  • Members
  • 1 posts

Posted 22 January 2011 - 02:32 AM

TheGuardian001 said:

That was the non-tech savvy version. Just type the command (java -Xmx800M -jar "LOCATION_OF_MINECRAFT_HERE") into cmd (start->run->cmd).

THANK YOU SO MUCH. THIS HELPED. I can now show my girlfriend the world I created. Now she knows what I've been doing all winter break long.

#19

Harry23
    Harry23

    Newly Spawned

  • Members
  • 1 posts

Posted 25 January 2011 - 09:49 PM

addict]uz said:

Do this...

put your minecraft.exe in any folder, just make sure you copy the path, and rename it to minecraft.jar

then open notepad, paste this line

java -Xmx800m -jar "PATH\Minecraft.jar

paste the path to the folder where minecraft is into PATH

then click save -> save it as NAME.bat (NAME can be anything that you want)

then from now on, double-click this NAME.bat file to open minecraft... and do not close the cmd that will open...

example:

I put minecraft.jar on C:\

so on notepad I do this:
java -Xmx800m -jar "C:\Minecraft.jar


I tried this, and the command window just flashes, then nothing

#20

deadbOlt
    deadbOlt

    Tree Puncher

  • Members
  • 18 posts

Posted 25 January 2011 - 10:42 PM

There is a very simple fix that worked for me without needing to type anything in a command line.

1.  Right click on your desktop, somewhere empty

2.  Click on 'Properties'  (or just navigate to your Display Properties window in Control Panel)

3.  Click 'Settings'

4.  At the bottom right of the window that pops up is a tab titled 'Advanced' <---- click this tab

5.  One of the tab options at the top of the window will be 'Troubleshoot' <---- click this tab

6.  Now you will see 'Hardware acceleration and a slider bar that says 'None' on the left and 'Full' on the right.

7.  You need to move the slider bar to just about the middle spot.  For me it was the point just left of the middle that allowed it to work for me.

8.  Click 'Apply'

9.  Now go play Minecraft.


My laptop had this issue and I was able to get it running (pretty low fps) with this method.  My laptop has an integrated Intel GMA950 graphics chipset.

Hope this helps.