Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[1.7.4] OptiFine HD D1 (FPS Boost, HD Textures, AA, AF and much more)


  • Please log in to reply
40618 replies to this topic

#27841

harley155

Posted 27 January 2013 - 05:31 PM

View PostWaffles13, on 27 January 2013 - 01:00 AM, said:

I've gone back 10 pages and haven't seen any solution to this, other than "Don't use Multi-Core loading", which doesn't help.

Any time I try to put render distance over Far, the game will load for a while, then all chunks beyond those that would be within Far go transparent. This happens on Multi-Core, Smooth and Default loading. I've tried allocating between 1 and 4 GB of RAM. I'm using 64-bit Java 7 and LWJGL 2.8.4. I'm using Forge 499 and B6 Ultra on 1.4.7 currently, although this has happened since at least B2 and 1.4.6. My computer is an i5-3570k @ 4.4GHz, a GTX 680 and 16 GB DDR3-1866. With Optifine everything is maxed except AntiAliasing is off and FPS is set to 60.

In the console (using MultiMC), the chunks always load fine until it hits "[INFO] [ForgeModLoader] Unloading dimension 1". The game runs fine after this point, except that it doesn't render past far unless I quit and restart. The Unloading dimension 1 issue seems to only happen if I look around; if I load the world and don't touch anything, it generally loads fine, but the second I turn or move more than a bit, the above line shows up and the past-Far chunks all disappear.

Here's the log; the last line is probably all that matters, but I put the whole thing, just in case. Note that the world I'm loading is called "Multiplayer".

Spoiler:


I have the exact same issue. I have tried alot of different settings, but none work. I also have pretty powerful computer (i7 2700k @ 4.5 GHz)

Register or log in to remove.

#27842

strikee
    strikee

    Tree Puncher

  • Members
  • 16 posts

Posted 27 January 2013 - 06:02 PM

View Posteshep, on 27 January 2013 - 05:06 PM, said:

So many folks here keep complaining about OptiFine not working with the "latest" version of Forge.  Saying it doesn't work with this version or that.  I ask you (and everyone else) this; What is the recommended version of Forge?  Furthermore, does anyone complaining about the compatibility know why builds are referred to as "recommended" or "stable"?
there is a litlle thing here, we all know that the recommended forge is 497, but alot of mods are using 507 now, for example, new version of BC or extra bees requires forge 507, i know that OF will update sometime, but dont you hate when this awesome mod add new optional options or fix "dyed armor" instead of making it compatible with lasts forge? i use 50+ mods and this is the only mod who force me to use older forge, consequently, preventing me from updating all the others

#27843

-+- Archer -+-
  • Location: In a tree, hunting you down ^^
  • Minecraft: Archer6621

Posted 27 January 2013 - 06:11 PM

I tried Optifine B6, but my average fps was about 3 times lower than it was on B5, this is on a Sapphire HD6870, using these drivers http://support.amd.c...L42BetaWin.aspx , catalyst 13.1 gave me terrible desktop glitches and problems in chrome so I ended up using those.

Not sure what's going on, or why B6 is way slower than B5 for me
Posted Image
Click on the image to visit my Soundcloud profile!

#27844

walkerjonny

Posted 27 January 2013 - 07:38 PM

Hi,

it seems that Forge Build 507 and above are using a changed bdz.class causing server side crashes upon loading a world.
Unfortunately there are some mods that depend on Forge Build 507 and above (for example Buildcraft 3.4.2)...
Could you check this out, please?

#27845

eshep
    eshep

    Tree Puncher

  • Members
  • 12 posts

Posted 27 January 2013 - 07:58 PM

View Poststrikee, on 27 January 2013 - 06:02 PM, said:

there is a litlle thing here, we all know that the recommended forge is 497, but alot of mods are using 507 now, for example, new version of BC or extra bees requires forge 507, i know that OF will update sometime, but dont you hate when this awesome mod add new optional options or fix "dyed armor" instead of making it compatible with lasts forge? i use 50+ mods and this is the only mod who force me to use older forge, consequently, preventing me from updating all the others

That's great that those mods are keeping up with the development of Forge but I don't see how that's any fault of the development progress of OptiFine.  Maybe if those modders were to make sure that their mod was still capable of being able to run on a version that has been approved for public consumption this would not be an issue.  Maybe your requests should be aimed at these 50+ mods you speak of instead of "the only one" that's sticking to the correct order of development.

No, I do not hate it when current issues are fixed in the order they were intended.  If you do not understand that using testing/unstable versions of a program come with the price of instability then I can see your point.  Otherwise you should have more respect for the overall development process.

How is stable considered "old"?  Especially when it hasn't even been a month since it's release.

#27846

Bars96
    Bars96

    Zombie Killer

  • Curse Premium
  • Curse Premium
  • 182 posts
  • Minecraft: iBars

Posted 27 January 2013 - 08:37 PM

View Postsp614x, on 26 January 2013 - 11:37 PM, said:

I have never seen such menu flashing.
This does not look like vanilla. Which mods are installed?
There Russian language and button added by me in MCP.

Installed mods: FML (Forge), Custom Stuff 2*, More Furnaces*, Rei's Minimap, Railcraft*, Macro KeyBind (with LiteLoader) and TooManyItems.

* - Installed in mods folder.
The mods that I use:
Custom Stuff 2, More Furnaces, Railcraft, Macro KeyBind, WorldEdit CUI, FML, OptiFine HD, Rei's Minimap, TMI.

#27847

Olangotang
  • Location: Plotting with the Endermen
  • Minecraft: Olangotang
  • Xbox:Langester97

Posted 27 January 2013 - 08:54 PM

So I'm working on a map thats on a Superflat world. I download B6 Ultra because the previous version would make some blocks invisible when on normal + renders. I get a new jar, close MC. Delete metainf, install optifine, close MC. Open up my map on a superflat world, it crashes. Other worlds are fine though. So I thought, "Hey, I'll just make a new world!" World tick crashes. Open minecraft,  Open the world, all fine and dandy. "Finally!" Open inventory, it fking crashes.

Does anyone else have this problem?


Ok, must be my fault. I had A3 in Magic Launcher active :l
Posted Image

#27848

BigMacJoe

Posted 27 January 2013 - 09:11 PM

If at all possible I was wondering if this mod can somehow be integrated with Better Skies. I want to be able to change my sky with my own texture and do not like using MC Patcher (specially since I can't use Optifine with Mc Patcher).

#27849

TheSkepticalTech
  • Minecraft: Skeptical_Tech

Posted 27 January 2013 - 09:19 PM

Anybody having an issue with dyed leather armor always appearing white in the inventory  and during crafting? It's fine when worn. I noticed that some people have reported it as a minecraft bug, but they seemed to indicate that it's an optifine bug. Still occurring in the latest version.

#27850

xJTDesign
  • Location: Blyth,United Kingdom
  • Minecraft: Gscape112
  • Xbox:XeN JoKeRzZ

Posted 27 January 2013 - 09:50 PM

Does anyone know if there is a optifine for snapshot 12w04a?

#27851

Dafaqyoulookingat
  • Location: Twilight's House
  • Minecraft: Superkiller1000

Posted 27 January 2013 - 10:12 PM

when i installed optifine i tried to load a world and it wouldn't load Please help
Posted Image

#27852

Enderassassin123

Posted 27 January 2013 - 10:30 PM

Why can't i use shaders with the Optifine HD B6 and Optifine is not really increasing my FPS but still 6 Diamonds.
Enderassassin123

#27853

Darxler
    Darxler

    Out of the Water

  • Members
  • 2 posts

Posted 27 January 2013 - 10:58 PM

Is there a reason as to why all of the download links on your website are broken, and just lead me on an adfly loop? Everything redirects to the first page.

#27854

LaBucherie

Posted 27 January 2013 - 11:09 PM

View PostDarxler, on 27 January 2013 - 10:58 PM, said:

Is there a reason as to why all of the download links on your website are broken, and just lead me on an adfly loop? Everything redirects to the first page.
There is no "loop". Go through the adfly page, then click on "Download OptiFine_1.4.6_HD_U_B6.zip". Do not click on the "Downloads" menu item.

#27855

Fedsniz
    Fedsniz

    Coal Miner

  • Members
  • 139 posts
  • Minecraft: RustikGaming

Posted 28 January 2013 - 12:51 AM

View PostDafaqyoulookingat, on 27 January 2013 - 10:12 PM, said:

when i installed optifine i tried to load a world and it wouldn't load Please help
you must use Forge version 6.6.0.499 if you are using the most recent version of Optifine


Posted Image

A double resolution resource pack that stays faithful to the original Minecraft textures.


#27856

troghead

Posted 28 January 2013 - 12:56 AM

I love optifine!

#27857

strikee
    strikee

    Tree Puncher

  • Members
  • 16 posts

Posted 28 January 2013 - 01:28 AM

View Posteshep, on 27 January 2013 - 07:58 PM, said:

That's great that those mods are keeping up with the development of Forge but I don't see how that's any fault of the development progress of OptiFine.  Maybe if those modders were to make sure that their mod was still capable of being able to run on a version that has been approved for public consumption this would not be an issue.  Maybe your requests should be aimed at these 50+ mods you speak of instead of "the only one" that's sticking to the correct order of development.
there isnt a specific fault from OF team, but they could do better, maybe integrating a little their code with forge? the last dozens of pages here are all complaining about the compatibility. Forge update just one version and most of times this is enough to break optifine. Ok, i get it, we must keep with the recommended version, but if another mod release a new version, we "must"/want use it, and here enter what i said, today BC release a new version, i could just update it and use the forge required, tomorrow forestry update, the same thing, the day after tomorrow, IC2, the same thing,... but i cant do any of those because OF only release versions that are compatible only with the recommended forge, and even the newest versions of optifine dont touch in that compatibility problem. In other words, i can't play 50 mods because optifine, instead of updating their forge compatiblity more frequently, they are using their time to fix "dyed armor"
They are doing their part releasing a version to recommended forge, but this is the minimum thing to do. If there is a way to do better like everyone else are doing, why not? Posted Image

*1 month and 20 new releases are enough to consider 497 old

#27858

Xordaii
    Xordaii

    Carpenter

  • Members
  • 59 posts

Posted 28 January 2013 - 01:38 AM

As a programmer, I side with the "release with the stable build" routine.  Growling at the mods that don't update will not help, and the general opinion of these forums has always been that you don't beg for updates. That is rude.

We play with 60+ mods, and BC and Forestry are the only ones who are pushing that build of Forge.  While sad that BC and Forestry decided to update to an incompatible build of Forge, even Forge people don't recommend it. They make it hard to get those latest builds on purpose, and only recommend you use them to make sure the bug you are reporting hasn't already been fixed on the latest build. Confusing for the general user, but sane.

Our server just won't update until forge does.  The new shinies in the latest updates will wait, after all.  They won't leave.

#27859

Theutus
    Theutus

    Carpenter

  • Members
  • 44 posts

Posted 28 January 2013 - 01:44 AM

How can I get blocks 2402 - 2402:7 and 4094 - 4094:2 to be recognized? I'm sorry if this has been covered I've been scouring the forums for a solution and everything I find is from last year or a lot older..

excerpt from my optifog.log:

Spoiler:


#27860

Keybounce

Posted 28 January 2013 - 03:41 AM

View Postsp614x, on 26 January 2013 - 07:59 PM, said:

Most probably there is a chunk in 12 block radius that is constantly updating.
When the mouse button is pressed OptiFine switches to classic update mode for the chunks which are near the player (radius 12 blocks). This is to avoid texture flicker when placing or removing blocks. The chunks further than 16 blocks are still updated multi-core.
Version B6 should behave better when updating near chunks.

So here is an interesting question for you:

Some mods -- and "Grey Goo" and "Mystcraft" are the two that come to mind right away -- generate very large numbers of blocks that generate constant block updates/alterations on each tick.

For Mystcraft, I get much better performance in such cases with optifine disabled, and using vanilla render code.

Is there any chance of a "high-update" mode for optifine? I have no problem if this is a switch that I have to manually turn on in video settings; better would be if OF could detect the large number of chunks that constantly need updating.
My channel with Mystcraft, and general Minecraft Let's Plays: http://www.youtube.com/user/Keybounce
** NEW: FtB "Magic Farm", performance testing and java flags.
My main world: http://www.minecraft...ts-play-series/
"Wait, an update?! Geez, I didn't know we skipped Easter and went straight to Christmas."