Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[BUKKIT] Name tag help? Permission edit help


  • Please log in to reply
4 replies to this topic

#1

jimmy7949

Posted 04 April 2011 - 01:00 AM

Hello everyone,

Before you start, I'm very grateful you click on my question and hopefully help me solve this.

I was going to originally post this in BUKKIT Forums..but it was glitchy as in I log in and it takes me back to homepage with me signed out.. so.. have to post it here :'(.
-

I use bukkit to run my server, I got permissions so I can have MisturJames as my name in my server. To do so I am using permission.. but no matter how I edit it.. I can't get it to show up in game. Here is a series of images of my set up.. Please help me edit or fix if wrong! :'(


Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image


Quote

# System is no longer used, but may become used in the future
# Copies is for multiple-world support
#   Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
#   If this file is for your default world (the one in server.properties) then you must
#   leave copies blank.
#  Example: copies: Derp    -  This will clone the permissions of the world Derp
#
# Make sure to rename this file to the name of the world that is in sever.properties under
# level-name.  So if it is level-name: world  then this should be world.yml and in the
# plugins/Permissions directory (ie. plugins/Permissions/world.yml)
#
# NOTE: Do not use tabs while editing this document.  Use only spaces.  A good way to avoid
# doing this is to use Notepad++ and replace the tab with 4 spaces.
plugin:
    permissions:
        system: default
        copies:

##        
# AntiBuild is included with this.  To disable a group from being able to build then
# set the build: flag to false (build: false).  If you want a group to be able to build
# then set it to true.
##
# Groups can contain inheritance.
#   To make a group inherit the permissions from another
#   group simply place the groups name in the "inheritance:" like so:
#
#   Example:
#       inheritance:
#           - Default
##
#   All permissions including the asterisks must be placed in single quotes.
#   like so:
#
#       - 'foo.bar'
#
#   Otherwise errors will happen!
##
#   Globalized Permission settings:
#
#       If a permission contains periods (.) you can denote a globalized parameter:
#
#           - 'foo.*'
#
#       This will allow you to use all general commands.
#
##
#   Single Asterisk denotes all commands:
#
#       - '*'
#   If you give a group this permissions, do not have the group inherit any permissions
#   from other groups.  Any users assigned to this group should NOT be given any additional
#   permissions either.
##
#   To exempt a node use the - prefix like so:
#       - '-foo.bar'
##
#   prefix: and suffix: do not do anything on their own.  You need another outside plugin
#   such as iChat or HeroChat in order for these to do anything.
groups:
    Guest:
        default: true
        info:
            prefix: '&2'
            suffix: ''
            build: true
        inheritance:
        permissions:
            - 'foo.bar'
    Moderator:
        default: false
        info:
            prefix: '&d'
            suffix: ''
            build: true
        inheritance:
        permissions:
            - '*'
    Admins:
        default: false
        info:
            prefix: ''
            suffix: ''
            build: true
        inheritance:
        permissions:
            - '*'

##
# Users denote which users are included in which group.
# TheNo1Yeti is in the Admin group
# Herpina is a member of the Moderator group but also has access
# to the herp.derp permissions
# Derpina is a member of the admin group but does not have access
# to the derp.derp permission node
# Users can also have a prefix and suffix as seen with Herpina
##
users:
    TheNo1Yeti:
        group: Admins
        permissions:
    MisturJames:
        group: Moderator
        info:
            prefix: 'Moo'
            suffix: 'Cow'
        permissions:
            - '*'
    Derpina:
        group: Admins
        permissions:
            - '-derp.derp'

Posted Image

Register or log in to remove.

#2

Spidermike9

Posted 08 April 2011 - 12:13 AM

You Will need to Get iChat. This allows the Chat to have special features like you want.

You will need to make a Group called "Owner" in your permissions config (which is the name of your world). I would just change Your Admin group to Owner, because it is already set up to use all Commands.

Inside iChat, u will see this:

message-format: '[+healthbar+prefix+group+suffix&f] +name: +message'

The healthbar shows how much health the user has at the moment they talk, this can be taken off. Prefix is the Color. &4 will give you dark red, this is what i use. Group says your group, and ive never bothered with suffix so it doesnt really matter. Then the name outside the brackets will be there, then the actual message.

This results in ----> [:(::YFlower::::Owner] Spidermike9: Hello!

If i missed anything, lemme know.


Oh, and you can get rid of Theno1yeti and Derpina etc... those are only examples and are not real players.

#3

deren909
    deren909

    Out of the Water

  • Members
  • 3 posts

Posted 12 May 2011 - 02:50 PM

Mine just says deren909[Admin]: hello! got any fixes :P ??

#4

Tashiiee01

Posted 03 October 2011 - 06:23 PM

I added it but every time someone speaks it keeps showing as default and not the group with the colour. how do I fix this?

#5

miner10101

Posted 02 July 2012 - 10:54 PM

wha? I have absaloutely no clue.I'm not good with tech stuff