Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Another Wolf Glitch...


  • Please log in to reply
16 replies to this topic

#1

Starmode
    Starmode

    Tree Puncher

  • Members
  • 24 posts
  • Location: FL

Posted 02 April 2011 - 03:39 AM

So I have 7 wolves in a little pen I made, along with a den and a water trough. I've been playing with them for about two real life days, having a good time fighting with them and what not.

However, about 10 minutes ago, I logged onto Minecraft to find my dogs, sitting as usual, in their little pen. For some reason, when I right click any of my dogs, they just sit there, doing nothing. I tried giving them some bones, nothing happens. I give them some raw porkchops, they eat it, they regain health, but nothing happens. I pushed like 3 of them into their water trough, they swim around in it, then hop out, shake the water off, but then sit down again without my consent! Now one of them is just constantly hopping up and down while sitting, and I don't know how to fix it.

After all this happened, I just started hitting them with my bare hands. But then they betrayed me and started attacking me until I died. One of them actually got stuck in a fence block, and the only way to get him out was to kill him  :iapprove: .

If anyone else is experiencing this glitch and knows how to fix it, please tell me! I haven't seen any other threads summarizing this glitch, though. I'm desperately looking for help, I've wasted so many bones on these guys, I don't want to have to kill them all and get new wolves!
QfqQIiilE0Y
Got a video up, maybe it will make things easier to understand.
Posted Image

Register or log in to remove.

#2

punchin
    punchin

    Lapis Lazuli Collector

  • Curse Premium
  • Curse Premium
  • 1159 posts

Posted 02 April 2011 - 03:44 AM

Confining them in the pen may be part of it. Do they teleport to you if you move far away from them? Also, they may not have loaded properly. Did you try relogging?
If you think the title and OP tells you everything you want to know about a thread, don't reply. If you want to actually read the thread and post an intelligent reply, you're welcome to it.

#3

Darerd
    Darerd

    Gold Miner

  • Members
  • 379 posts

Posted 02 April 2011 - 03:45 AM

Why does this happen? Minecraft has two compilers, the graphics and the system. The graphics is how you render the game and the system is everything else. The bug is that when you save and quit to title, sometimes the graphics say the wolves are sitting and the system saya it is not, so there's an error when you right click them and they are stuck in their sitting position.

To fix the bug, right click on each one a few times then leave/enter the world again.
Posted Image

#4

Starmode
    Starmode

    Tree Puncher

  • Members
  • 24 posts
  • Location: FL

Posted 02 April 2011 - 03:49 AM

punchin said:

Confining them in the pen may be part of it. Do they teleport to you if you move far away from them? Also, they may not have loaded properly. Did you try relogging?

They're not teleporting when I walk far away from them. The pen was working fine earlier, and I have tried relogging.

Darerd said:

Why does this happen? Minecraft has two compilers, the graphics and the system. The graphics is how you render the game and the system is everything else. The bug is that when you save and quit to title, sometimes the graphics say the wolves are sitting and the system saya it is not, so there's an error when you right click them and they are stuck in their sitting position.

To fix the bug, right click on each one a few times then leave/enter the world again.

It didn't work.
Posted Image

#5

Pyro627
    Pyro627

    Redstone Miner

  • Members
  • 591 posts

Posted 02 April 2011 - 04:42 AM

This is happening to me too, and since it makes my hard-won dogs useless, I am desperately in need of a fix.
Posted ImagePosted ImagePosted ImagePosted ImagePosted Image

dusty328 said:

This man really is a genius. Never have i seen such a clear and well written forum post.

#6

Starmode
    Starmode

    Tree Puncher

  • Members
  • 24 posts
  • Location: FL

Posted 02 April 2011 - 04:48 AM

Pyro627 said:

This is happening to me too, and since it makes my hard-won dogs useless, I am desperately in need of a fix.

Well, at least I found someone else feeling the same pain. I don't think there's any fix for it, though, I've already tried so many experiments, killing 3 of my 7 dogs in the process.
Posted Image

#7

Baygulls
    Baygulls

    Out of the Water

  • Members
  • 3 posts

Posted 02 April 2011 - 06:54 AM

It also happened to me, but for some reason, after restarting my minecraft a couple of times. I was able to use them again...If it doesn't work. you can try to catch another wolf, restart, and try that.

#8

Mister_Crowley
  • Location: New Atlantis, The Moon
  • Minecraft: Mister_Crowley

Posted 02 April 2011 - 07:01 AM

Happened to me too. Sadfaic.
If you play offline though, it fixes it.

MinecraftCreeper said:

Do you think there should be options no lag and lag in minecraft?

#9

Ocelot60
    Ocelot60

    Blaze Extinguisher

  • Members
  • 4852 posts

Posted 02 April 2011 - 07:14 AM

That's a real shame, hopefully it will be fixed within the next few days!

#10

kingtkuehn
  • Location: united states ,, st.cloud mn

Posted 02 April 2011 - 06:16 PM

yey its happening to my nine mutts too this sucks

#11

GunboatDebater

Posted 02 April 2011 - 06:23 PM

It's not a glitch, but I thought it was a few days ago.

The wolves are keyed in only to obey your unique player ID.  Anyone who's played on a server using Authenticate will know that if you're playing offline, you're assigned the generic ID, "Player."  Now, let's say your account is "Foo," and you got your wolves whilst playing offline.

Wolf: My owner is Player!
Foo: Get up!
Wolf: ???

Unfortunately, the wolves you got offline won't work online, and vice versa.  This is how I lost my first kennel.  :/
Posted ImagePosted ImagePosted ImagePosted ImagePosted Image

#12

Enjay
    Enjay

    Nether Resident

  • Members
  • 2392 posts

Posted 02 April 2011 - 06:30 PM

Yes, it happened to me too.  I went back in and out of the game a few times - nothing.  So, I just left it alone for a while and when I logged back on, everything was working again.

What GunboatDebater said doesn't seem to explain my situation because my Wolves were responding then suddenly they weren't - during the same SP game.

(edit However, what GunboatDebater said is certainly reproducible: if I log in with my username Wolves respond to me.  If I bypass the login they don't.)
LOL MineDrama. Posted Image

#13

strenbeath

Posted 04 April 2011 - 12:48 PM

Sweet Ride said:

Only untamed wolves attack you if you hurt them. Although, if you punch one, and they attack you whilst sitting down, I'd suggest getting off of offline mode. Offline mode makes them not recognize you, because it checks the servers for your username, to make sure whether or not you're the owner. If you're offline, it will think you're somebody else.

in case anyone is still reading this thread....this was posted in another thread and it works.   :iapprove:

#14

Legoonie
    Legoonie

    Tree Puncher

  • Members
  • 23 posts

Posted 11 December 2011 - 08:29 PM

View Poststrenbeath, on 04 April 2011 - 12:48 PM, said:

in case anyone is still reading this thread....this was posted in another thread and it works.   :iapprove:

Your solutions are great advised cause I had the bug only playing SSP. Why ? Because I ran the game with launcher and while testing mod I ran the game with MCPatcher. This last solution won't make a connection with the server and you can't make your wolf obey. Quit and restart with the official launcher. Miracle !

:rolleyes:
Carry on !
------------------------------------------------------------------------------------------------Posted Image
Posted Image

#15

rooteh
    rooteh

    Tree Puncher

  • Members
  • 22 posts

Posted 05 March 2012 - 10:04 PM

I have that glitch too.. I'm playing on a Multiplayer Survival server, so not offline. Original patch client, so properly logging in.

And it keeps on happening. During the session that I catch the wolves in, they work fine. Then when I leave the game and come back later, they seem to be stuck, sitting, not moving.

After I lost my first set of wolves (that wouldn't move) to some hole-in-the-world glitch my friend had, I caught new ones - but the same problem again.

I tried madly clicking on them, logging out and back in, pushing them into water, even punching them. The only thing that solved the problem was a creeper exploding on them - and after logging out and back in, they're stuck again.

Help please?

Edit: Correction - apprently that glitch doesn't apply to all of my wolves but only those in my direct visibility/loading/effect range when entering the game. Wolves sitting around farther away work fine.

#16

jainaseagol
  • Location: Going back and putting /sarcasm on all my posts...

Posted 05 March 2012 - 10:21 PM

Tried spawning new ones?

Quote

Quote

Chickens are spawning in my house!  Help!  PLEASE!
Your house has been compromised therefore you must blow it to hell.

#17

rooteh
    rooteh

    Tree Puncher

  • Members
  • 22 posts

Posted 06 March 2012 - 08:45 AM

Spawning as in what? Breeding? Yes. They eat food and regain health but as they sit they cannot breed. Collect new ones? Would be tiresome to always run into the forest and find some, but new caugth ones work fine.

Else, how should I spawn some.