Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

1.4 Local Server Commands


  • Please log in to reply
1 reply to this topic

#1

MarkusRising

Posted 01 April 2011 - 01:58 AM

Support Preliminary Info:


Operating system: Mac OS X 10.6.7

Browser: Irrelevant, as I'm using Minecraft installable Beta. But for intensive purposes, Safari 5.0.4

Type of internet connection: 9.4 Mbps Wireless DSL

How did it happen: Beta 1.4 Update, Patched with "LB Photo Realism x256 3.0.0" 256 x 256 texture pack. Latest minecraft_server.jar file downloaded, and opened up to create a 'localhost' server within my home network

Is Java up to date? Yup.


Basically, we all know Minecraft updated today. I got it downloaded, and attempted to launch my local server software so that my roomie and I can keep working on a map we've had running for a week now. Server said "outdated server", so I got the latest version from Minecraft.net and removed the old stuff, in with the new. Now, when launching the map, everything works fine EXCEPT for the commands. /give, /set time 0, that kind of basic usage.

My thoughts relating to problematic cause are either:

a) 1.4 patch really botched things, or
:) Saving my 'World' folder from the older server and putting it into the new one is causing a non-fatal incompatibility that has blocked off the commands from working.

From the java file's textlog:

[INFO] [playername] tried command: give markusrising 46 64
[INFO] [playername] tried command: give markusrising 46 64
[INFO] [playername] tried command: time set 0

Has anyone else come across this yet? Most of the issues I found with 1.4 on the forums are based on bugged items, rather than functionality of commands. Thoughts? I'm pretty sure I'll have to trash 'World' and start over, but that would be a pretty big bummer.

Register or log in to remove.

#2

MarkusRising

Posted 01 April 2011 - 02:23 AM

Well, turns out that it was a real 'derp?!' moment when I figured out what happened.

I had backed up 'world' and removed Minecraft_Server folder. Making the new one, I just didn't add myself or my roomie to the Ops.txt file.