Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Minecraft Is Too Dark


  • Please log in to reply
48 replies to this topic

Poll: Is minecraft too dark? (68 member(s) have cast votes)

Is minecraft too dark?

  1. Yes, minecraft is too dark (35 votes [51.47%])

    Percentage of vote: 51.47%

  2. No, Increase your screens brightness yourself (8 votes [11.76%])

    Percentage of vote: 11.76%

  3. No, just turn off smoothlighting. Update: (Has got some ugly graphical glitches after 1.5) (6 votes [8.82%])

    Percentage of vote: 8.82%

  4. No, it's good (19 votes [27.94%])

    Percentage of vote: 27.94%

Vote Guests cannot vote

#1

Hej100
    Hej100

    Stone Miner

  • Members
  • 73 posts

Posted 29 March 2011 - 06:23 PM

With/without "better light aka smooth lightning"
Look at thoose bright blocks up left from the cursor. The reason why they get darker is because they stick out from the ground(not smooth). Caves are not smooth, which make them dark + there is no sunlight in caves.
Posted Image


EDIT: Minecraft without smooth lighting is no longer supported. They showed this by adding some really ugly shadows on stairs if you have smooth lighting turned off since beta 1.5!



Since beta 1.3 minecraft has gotten darker. You might think that "better light" actully makes the lighting better.

The truth is that the only thing "better light" do is darkening the game with shadows. I think notch really should fix this.

Just check at your own cave with "better light" on/off.

My point is NOT that smooth lighting looks bad. I just think it's too dark. If smooth lighting makes the game darker then the pre-darkend game should be lighter.


Are you with me?


Register or log in to remove.

#2

amwilkinson

Posted 29 March 2011 - 06:26 PM

I'm fine with both settings in the day, but at night I find it hard with both settings. When I say day and night I mean in the game, not real life.
Creepers are my slaves!!!!

#3

voordal
    voordal

    Creeper Destroyer

  • Members
  • 5680 posts
  • Location: Vegas

Posted 29 March 2011 - 06:26 PM

1) Press Esc
2) Click Options
3) Click Video Settings
4) Turn Smooth Lighting "Off"

There. Problem solved.

EDIT: Also, using a massive font sort of makes your post annoying.
Did your world disappear from minecraft? Is it corrupt? Lags? Can't move? "Saving Chunks" Crash? Crashes when you open chests? It can be saved!
Minecraft Saver World Recovery Website: http://mcsaver.net.  Recover and save your precious worlds! Over 1500 saved!

#4

Thescorpi0n
  • Location: Somewhere over the double rainbow

Posted 29 March 2011 - 06:27 PM

Who has ever said that better light actually made it brighter?
No one.
It just makes the lighting better by smoothing it out.
If you don't like it, turn it off.

Posted Image



duartel said:

Monkah_Boy said:

DimMyXx said:

Cool.
Story.
Bro.

#5

the_bidji
  • Minecraft: the_bidji

Posted 29 March 2011 - 06:30 PM

Hej100 said:

Since beta 1.3 minecraft has gotten darker. You might think that "better light" actully makes the lighting better.

The truth is that the only thing "better light" do is darkening the game with shadows. I think notch really should fix this.

Just check at your own cave with "better light" on/off.

Are you with me?
not with characters that size I'm not.
besides, you can't say that "the only thing "better light" do is darkening" because it just isn't true. it does darken the game a bit, but mostly, it softens the shadows' edges and makes the game (in my opinion) look a lot better.
other than that, I agree that minecraft, in general, is too damn dark if, like me, you have a crummy LCD screen and don't want to set it to 'ultra bright', and there should be a gamma slider in the video options. :P

Bartender said:

Let me get these straight:
[Diamond] Emalards? Emalards were early in the game, Notch changed them into Diamonds.

rmvarunn2 said:

dungeon ddut bu ... is lot [Zombie] !!!
die keep ?? but box is . has [Iron] an [GP] apple gold bu
ALWAYS is [Zombie] ??? ggu make how ??
want box !!! plz help !!!!

#6

KingCreeper
    KingCreeper

    Lapis Lazuli Collector

  • Members
  • 1083 posts
  • Location: Lost in a cave...

Posted 29 March 2011 - 06:34 PM

I love the way minecraft looks with the better light. Yes, it's kind of darker, I admit, but it's just a few extra torches to light my house up more. You can turn it off if you don't like it, anyways...
Posted Image

#7

Hej100
    Hej100

    Stone Miner

  • Members
  • 73 posts

Posted 29 March 2011 - 06:35 PM

My point is NOT that smooth light looks bad. I just think it's too dark. If smooth light makes the game darker then the pre-darkend game should be lighter.

#8

Asger_Alan

Posted 29 March 2011 - 06:37 PM

all those dudes saying we should turn off smooth lighting if we don't like it are completely missing the point.

IMHO, the avarage brightness of a block in smooth light should be equal to the brightness of the same block in blocky light, now the brightest part is the same, and the rest is darker giving the player irritations while playing => epic design fail.

If something is not right, it should be fixed. work-arounds and  if-you-don't-like-it-don't-use-it-OMGs are not desired here. So either leave your honest opinion about the matter itself, or find another tread to post in.
Posted Image
You should hunt them too!

#9

Enjay
    Enjay

    Nether Resident

  • Members
  • 2392 posts

Posted 29 March 2011 - 06:43 PM

I like the slightly darker look and I have no problem seeing stuff in game on my monitor.

Of course, if I did have problems seeing stuff, I might turn the brightness control on my monitor up a notch. :P
LOL MineDrama. Posted Image

#10

KingCreeper
    KingCreeper

    Lapis Lazuli Collector

  • Members
  • 1083 posts
  • Location: Lost in a cave...

Posted 29 March 2011 - 06:48 PM

I don't even see how you would "fix" better light to make it brighter. I'm sure you can adjust your monitor than having to edit mincraft itself because it's too dark.
Posted Image

#11

Bondo
    Bondo

    Lapis Lazuli Collector

  • Members
  • 1067 posts

Posted 29 March 2011 - 06:50 PM

I sort of agree with the OP.  Though I don't think the game should be BRIGHTER, per-say.  Lighting should just be made more effective.

One thing that's always bugged me is how light sources don't really seem to be all that strong.  Especially lightstone.  Making lights truly appear bright using some effect.  Maybe a fullbright texture kind of effect, or a bloom effect, would be ideal.  And the way lights work on blocks should be more obvious.  Brightness from the lightsource out should be clear.  This effect CAN be achieved, even with smooth lighting.

On the other hand, it's not that big a deal.  The current lighting still looks fine, and the game is quite playable.  Though I still find myself toggling smooth lighting on and off, because I prefer the smooth clean look of smooth lighting.  But I prefer the way light is actually LIGHT with smooth lighting off.

@Notch said:

I have a plan, honest. =)

#12

Magixxxx

Posted 29 March 2011 - 06:53 PM

I have no problem with the darkness in normal textures but with painterly pack textures, even in completely torched out areas the game seems too dark.

Does anyone else get this?

(Can't say anything about other textures, haven't used anything else)

#13

kalajel
    kalajel

    Obsidian Miner

  • Members
  • 1450 posts
  • Location: QC, Canada
  • Minecraft: kalajel

Posted 29 March 2011 - 06:54 PM

Yeah, I've noticed that too. Now my caves have roughly 50% more torches in them to keep them nice, safe, and illuminated…

#14

rodabon
    rodabon

    End Dweller

  • Members
  • 7187 posts

Posted 29 March 2011 - 06:56 PM

I recommend going into your video card settings and turning up your gamma a little.  If your vid card doesn't allow this then you may consider upgrading to one that does.  Playing with monitor brightness and contrast isn't the same nor as satisfactory.  

I understand how some of you have issues with how dark it can be on certain system defaults.  On my PC at home I have no issue.  When I visited my folks and setup minecraft on their PC, WOW, dark was D A R K.  Between their monitor, the default vid settings and playing on a PC in a room that was well lit, I couldn't see the tool that was in my hand in front of my face.
Re: 3D Minecraft - Anyone tried it?
by c0yote  

I tried it with terrible results. I gave my wife my glasses for a second, a creeper showed up and now my wife is pregnant.
Stupid 3D..

#15

Steves
    Steves

    Void Walker

  • Members
  • 1720 posts

Posted 29 March 2011 - 06:57 PM

Two things:-

1: turn on 'fancy'  as you'll get more light through the trees.

2: perhaps turn up the gamma on your monitor?

#16

Magixxxx

Posted 29 March 2011 - 07:00 PM

Steves said:

Two things:-

1: turn on 'fancy'  as you'll get more light through the trees.

2: perhaps turn up the gamma on your monitor?

You can always change your computers settings, that's not the problem. The problem is that the game is darker than it was before. Why do I have to change my monitor settings JUST for minecraft when I didn't have to do it before?

It's like notch would make one stone block mine for an hour with a diamond pickaxe and then you come in and say "but you can hax your java to make minecraft run faster"

#17

voordal
    voordal

    Creeper Destroyer

  • Members
  • 5680 posts
  • Location: Vegas

Posted 29 March 2011 - 07:03 PM

I did some testing.

Basically, yes and no.

The actual block the torch is on, is darker. Yes.

However, all the other blocks, at the center of the block, are the SAME light, with or without better light. The problem is that the entire block, from one end to the other, is also illuminated with that same level, which creates a sort of optical illusion that its brighter, when its just the hard gradients vs the smooth gradients.

TL:DR version: Source block is darker, all other blocks are the same luminance. If you dont like it, turn it off. Making it brighter would more or less beconsidered 'too bright' as it would be brighter than intended.
Did your world disappear from minecraft? Is it corrupt? Lags? Can't move? "Saving Chunks" Crash? Crashes when you open chests? It can be saved!
Minecraft Saver World Recovery Website: http://mcsaver.net.  Recover and save your precious worlds! Over 1500 saved!

#18

Hej100
    Hej100

    Stone Miner

  • Members
  • 73 posts

Posted 29 March 2011 - 07:10 PM

Just found this:

Creator of betterlight said:

BetterLight makes everything too dark - Working on this.

Also

Should i really need to increase gamma to play minecraft?

#19

Jannubee
    Jannubee

    Tree Puncher

  • Members
  • 27 posts
  • Location: Narnia
  • Minecraft: jannybanny

Posted 29 March 2011 - 07:12 PM

Quote

TL:DR version: Source block is darker, all other blocks are the same luminance. If you dont like it, turn it off. Making it brighter would more or less beconsidered 'too bright' as it would be brighter than intended.

This^.
I was just thinking about that.

Posted Image

halofreak506 said:

Okay so I let him in, he broke my toilet and ran off... WHERE AM I SUPPOSED TO POOP NOW  D':


#20

Ikaza
    Ikaza

    Zombie Killer

  • Members
  • 231 posts

Posted 29 March 2011 - 07:12 PM

voordal said:

1) Press Esc
2) Click Options
3) Click Video Settings
4) Turn Smooth Lighting "Off"

There. Problem solved.

EDIT: Also, using a massive font sort of makes your post annoying.

this.
Posted Image