Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Mysterious lag problem! (Read before posting about lag!)


  • Please log in to reply
508 replies to this topic

#501

adventurephotographer

Posted 23 June 2012 - 12:07 AM

I hav this problem as well, but i play in single player and only one world lags. i hav the mod "Tale of Kingdoms" loaded on this world, so i dont know if that is affecting it or not. my other worlds hav minimal lag and doesnt affect game play as much as it is slightly annoying. but in my Tale of Kingdoms world i cant move, place/destroy blocks, etc and it takes a little over a minute to load anything during game play. i would really like to hav my own kingdom so PLEASE help!!

Register or log in to remove.

#502

featherwinglove

Posted 07 July 2012 - 08:20 PM

I heard that Minecraft 1.3 SSP was going to go to the server+client setup that I had described, so I guess Minecraft single player had not been so designed from the start.  I'm currently playing an SMP mode game with a vanilla server (I had to /op myself before I could break or place a block, but I could kill mobs.  /whitelist and /gamemode had no effect (but /gamemode 1 let me fly).  I laughed at my misfortune while trying "/kill featherwinglove" which IMHO really really needs to be in every "Ways To Die In Minecraft" video on Youtube!)

So far in Release 1.2.5 (both client and server) Java 6u33, it is lagging hard only when it is obviously loading new chunks.

Update 1: I made this post while in the initial hunger period (i.e.: my character found no edible animals in his bizarre spot of swamp next to biome), so I busted some grass and planted a garden next to the nearest water.  Then I realized, hey, I can hydrate it by /toggledownfall in the server console.  After that, I realized that since the garden was next to water, it made no difference.  I suspect this lag is Java 7 related, so I am going to try Java 7 again.  When I was playing the Classic 0.30 applet while waiting for Paypal to get their zits sorted out w.r.t. my bank account (which took so long, the transaction went off my recent activity list before it was done!)  I had a very different problem: clicks would randomly trigger the game menu (i.e. Esc).

Update 1b: I found a new (to me) bug where when switching from other apps (i.e. my browser in which I am typing this post) to the Minecraft client, it doesn't redraw the game windows innards, which I successfully worked around by resizing the window.  I think this happened to me in SSP, but I killed it because I thought it had crashed.  I can't repeat it consistently, so I'll pay attention for it in SSP and see if it works the same way.

Terry

Edited by featherwinglove, 07 July 2012 - 08:43 PM.


#503

featherwinglove

Posted 07 July 2012 - 08:58 PM

View Postsadpickle, on 23 February 2012 - 08:59 AM, said:

I had all the problems detailed in the first post. SSP worked fine, SMP stopped working for me after a couple days. However, I have installed Optifine Standard and that has fixed the problem for me. I hope this works for others.

Optifine turned out to be a flat-out disaster for me.  My results were about the worst possible: Slight improvements in performance for the first few minutes and then after a few hours, I was lagging so hard, I could no longer play, even with graphics settings tuned worse-than-vanilla.  I had to kill it, there was no other option left.  This was on SSP; I didn't have the chance to try it SMP.

Terry

#504

xXGreyWolfXx
  • Minecraft: xXGreyWolfXx

Posted 06 August 2012 - 10:31 PM

Getting this to..
http://dragcave.net/...XGreyWolfXx.png
Please click to help my dragons :3

#505

UnoWild
    UnoWild

    Zombie Killer

  • Members
  • 172 posts
  • Location: Puerto de Santa Maria, ES
  • Minecraft: UnoWild

Posted 11 August 2012 - 03:05 PM

I too have these issues but not all are as extreme on my end as some have stated here.

After rreading the comments and those from another thread I've noticed TWO things that people have tried and claimed to have resolved the issues.

1) Log in to Minecraft, then a server, on another computer.
2) Turn OFF the new 'snooping' feature.

With both of these things Im getting the feeling that the reason why only a small % of people are haveing these issues when playing SMP is from their IP vs the Minecraft Login Server which is why I feel its the 'snooping' feature.


Please try these two and report back here, thanks.


:-)
---------------------------------

View Postgr295, on 26 March 2011 - 02:41 PM, said:

. . . . .

:Green: Facts: :Green:

1. This lag problem is for all servers, but may only affect some people.
2. This lag problem ISN'T caused by the server or the client.
3. It seems to be computer, not user, specific.
4. Sometimes it happens, sometimes it doesn't.



#506

MrSkarbonke

Posted 12 January 2013 - 10:28 AM

It's 1.4.7 Full release and it's still lagging for me i have these symptoms and don't know what to do! :(

#507

beagledog

Posted 25 January 2013 - 03:35 PM

Using a network sniffer reveals a lot of TCP retransmissions to and from the server, which indicates packet loss. This doesn't happen with any other communication, just minecraft SMP. Googling "java tcp retransmissions" reveals... Not a lot to me personally, because I'm not a java programmer. Packet buffering is mentioned in some of the results, but when I used the tcpbuffer program nothing changed.

I've tried playing from another computer and experienced the same symptoms, and also turned off the snooper but that didn't help. This problem existed long before the snooper was implemented, and nothing in the setting affects it.

Something interesting I found: apparently this problem isn't for *all* servers. There was one server (which is now gone unfortunately) where I didn't experience this problem almost at all, except when a mob or a player took damage. I don't know why that was or how to find another such server. I think it had to do with the hosting company - something like redstone hosting - because the server moved several times but kept the hosting company; when it was changed the problem worsened.
Getting insane lag on multiplayer? Raise awareness. Post here.

#508

txtsd
    txtsd

    Coal Miner

  • Curse Premium
  • Curse Premium
  • 138 posts

Posted 31 January 2013 - 06:03 PM

I'm suffering from this problem too. My laptop has an Intel chipset, so that's most likely the problem.
Posted Image

#509

SpiderRider

Posted 06 February 2014 - 10:20 PM

Breaks block.... block reappears.... 30 seconds later block breaks and drops.
....
Damn this mountain is taking too long ta take down....
Posted Image