Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Error "java.io.IOException: An existing connection was forcibly closed by the remote host" Keeps kicking everyone from the server.


  • Please log in to reply
10 replies to this topic

#1

AlexanderMoore
  • Location: Suzhou, China

Posted 30 December 2013 - 09:44 AM

Any idea what this is about? My server will run, you'll play on it a while, and it'll kick EVERYONE giving them this error.

Here's the event happening to a player in the log:

AnticPosition lost connection: TranslatableComponent{key='disconnect.genericReason', args=[Internal Exception: java.io.IOException: An existing connection was forcibly closed by the remote host], siblings=[], style=Style{hasParent=false, color=null, bold=null, italic=null, underlined=null, obfuscated=null, clickEvent=null, hoverEvent=null}}
[17:07:55 INFO]: AnticPosition left the game

Before anyone asks, no it's not set to kick any idle players. Here's my server.properties

#Minecraft server properties
#Mon Dec 30 08:45:22 CST 2013
generator-settings=
op-permission-level=4
allow-nether=true
level-name=world
enable-query=false
allow-flight=false
announce-player-achievements=true
server-port=25565
level-type=DEFAULT
enable-rcon=false
force-gamemode=false
level-seed=
server-ip=
max-build-height=256
spawn-npcs=true
white-list=false
spawn-animals=true
hardcore=false
snooper-enabled=true
online-mode=false
resource-pack=
pvp=false
difficulty=1
enable-command-block=true
gamemode=0
player-idle-timeout=0
max-players=51
spawn-monsters=true
generate-structures=true
view-distance=15
spawn-protection=16
motd=China PvE Survival Server

And here's the .vbs I use to run the server:

Set objShell = CreateObject("Wscript.Shell")
objShell.Run "java -Xms12288M -Xmx12288M -jar minecraft_server.1.7.4.jar -o false" ,0,true

(Though the issue started before I started using .vbs instead of .bat method).

An occasional random kick is manageable, but this is happening very often!

Can't seem to figure out what the cause is. Any ideas?

Thanks in advance!

- Alex

Register or log in to remove.

#2

AlexanderMoore
  • Location: Suzhou, China

Posted 31 December 2013 - 02:44 AM

So I guess not much knowledge out there about this particular issue?

Welp, going to bed for now. Hope to see something later maybe.

#3

jimtown85
    jimtown85

    Out of the Water

  • Curse Premium
  • Curse Premium
  • 2 posts

Posted 31 December 2013 - 03:22 PM

We are also getting the error about every 30 min,  I set a timer for 29 min and we get ready to get booted,   but 1 thing I have noticed if the Server admin is online we do not get booted?

#4

Rilesthegiles
  • Location: United States
  • Minecraft: Rilesthegiles
  • Xbox:Opop12345678

Posted 31 December 2013 - 09:18 PM

Don't need to allocate that much memory first of all..

Set objShell = CreateObject("Wscript.Shell")
objShell.Run "java -Xms6144M -Xmx12288M -jar minecraft_server.1.7.4.jar -o false" ,0,true

Also what OS are you using?

Posted Image
-------------------------- Owner of Runecraft.us--------------------------

------------------------------------------------------------------------------


#5

AlexanderMoore
  • Location: Suzhou, China

Posted 01 January 2014 - 09:31 AM

Windows 8.1

#6

AlexanderMoore
  • Location: Suzhou, China

Posted 03 January 2014 - 10:32 AM

Well, the Minecraft bug report place closed my case because I'm operating in offline mode.

I guess any help I'll be getting will be coming from here. Otherwise, the issue will just remain unfixed I suppose.

#7

Adderhead

Posted 09 January 2014 - 10:33 AM

A few of my players are having this same problem.

#8

BrotherHolmes
  • Location: Utah
  • Minecraft: BrotherHolmes

Posted 01 February 2014 - 05:54 AM

This has been happening to me too!

#9

JK82NL
    JK82NL

    Carpenter

  • Curse Premium
  • Curse Premium
  • 49 posts
  • Location: Netherlands
  • Minecraft: JK82NL

Posted 15 February 2014 - 04:56 PM

My server as well.

Craftbukkit 1.7.2-R0.3 Beta (Also happened on 1.7.2-R0.2)
40+ plugins

Even when I am on my server alone it kicks me. I am not an OP but have the '*' in my permissions.It just happened to me twice within 30 minutes. And after the second session i got this error ingame trying to connect :
Failed to connect to server
Failed to login: Invalid Session (Try restarting your game)
And this on the server console:
2/15/2014 17:54:50 [INFO] GameProfile{id='null', name='username'} (/ip:45181) lost connection: Disconnected

#10

ayeitsaustin

Posted 03 March 2014 - 12:33 AM

Same thing is happening to my server:(

#11

Eldodsite

Posted 05 March 2014 - 05:46 AM

I am currently fighting the same error.

Windows 7 - 64 bit
Java 7 Update 51 (Most Current)
All users are running the same version as the client (This has been happening since 7.4) - but not until January, coincidentally this is when JAVA 7_51 came out...
We are currently running the Minecraft 7.5 Environment.
Completely Vanilla Server, has never seen a mod a day in its existence - Recently moved to the .bat launch style (But the error occurs using the .exe launcher for the server as well)
2G Ram allocated, 2 TB of free space on the box

I have been searching for weeks trying to correct this or find a thread that has a source to this issue to no avail.
I am beginning to believe this is within the source code from the NET overhaul that was done as of 7.2

For anyone jumping at the edge of your seats, ready to blame server properties... just as the original post has listed, that has nothing to do with it "Player-idle-timeout=0" is set by default and is in place. If that property was the issue the user would be notified that they were kicked due to Idle too long, not the IO Exception of the host forcibly closing.

So if anyone has any updates to this error, please don't hesitate to update this thread.