Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

cannot install Forge on 1.7.4 Minecraft - 'need to run the version 1.7.2 manually at least once'


  • Please log in to reply
8 replies to this topic

#1

Ninjachorlton

Posted 28 December 2013 - 07:13 PM

Hi hope someone here can help with this issue.

I have a complete fresh install of Minecraft using the latest, 1.7.4, version.
I am using Windows 7.

Minecraft itself works fine, and I decided I wished to try some mods.
After looking through some forums etc.. It seemed like installing Forge was the first step.

I have downloaded the latest version from here http://files.minecraftforge.net/ 10.12.0.971 1.7.2
12/27/2013 11:53:28 PM

When I attempt to run the forge installer I get the message
'You need to run the version 1.7.2 manually at lest once'

My first action was the obvious, I loaded up Minecraft, closed it and then tried to install Forge.

I have tried several suggested solutions, none of which worked

tried to run the file directly, and tried open with java

tried the installer and installer-win files

completely removed Minecraft and re-installed

I have been told that Forge should see no difference between 1.7.2 and 1.7.4, but this seems to me to be an obvious discrepancy.
Do you think that using an install of the 1.7.2 Minecraft client would be worth attempting? if so, do you know where I could obtain this?


many thanks for any help you can give

Register or log in to remove.

#2

bilde2910
    bilde2910

    Diamond Miner

  • Curse Premium
  • Curse Premium
  • 829 posts
  • Location: Stavern, Norway
  • Minecraft: bilde2910

Posted 28 December 2013 - 11:05 PM

1.7.2 Forge doesn't support 1.7.4. There's a difference between the versions. As you error says, you need to run 1.7.2 at least once before installing, otherwise Forge won't have anything to install itself into. I do recommend you use 1.6.4, though, as there are hardly any Forge mods for 1.7.2. I think there's only one, and it's functionality is severely limited compared to its 1.6.4 version.

ChatLog is a mod updated for Minecraft 1.7.8.

Click here to check it out: http://bit.ly/clmcmod


(PS. Are you an IRC chatter? You'll love this.)


#3

Ninjachorlton

Posted 29 December 2013 - 12:27 AM

View Postbilde2910, on 28 December 2013 - 11:05 PM, said:

1.7.2 Forge doesn't support 1.7.4. There's a difference between the versions. As you error says, you need to run 1.7.2 at least once before installing, otherwise Forge won't have anything to install itself into. I do recommend you use 1.6.4, though, as there are hardly any Forge mods for 1.7.2. I think there's only one, and it's functionality is severely limited compared to its 1.6.4 version.

Thank you for the response.
I've had a look at the changes between 1.6.4 and 1.7.4 and there seem to be quite a few.
I would assume that by changing to version 1.6.4 a lot of the worlds created under 1.7.4 would have issues/not work.
Is this the case? Both of my daughters also play and it would be a real shame for them to lose the worlds they have been working on.

Do you think that forge/more mods will be updated to work under 1.7.4 and it would be worth holding out for this?
Or is there another way you would recommend to use mods which would work now under 1.7.4?

again, thanks for your assistance.

#4

Anon10W1z
  • Minecraft: Anon10W1z

Posted 29 December 2013 - 12:34 AM

View PostNinjachorlton, on 29 December 2013 - 12:27 AM, said:

I've had a look at the changes between 1.6.4 and 1.7.4 and there seem to be quite a few.
Quite few? 500,000 lines of code changes is quite few?
Just read this webpage.

Worlds created under 1.7.4 will show up a little messed up when it comes to 1.6.4, but this is if the world consists of mainly the new biomes.
Maker of the MCredone modpack and the Bedrock Reloaded mod.
Basketball fan of the Golden State Warriors!
Hockey: San Jose Sharks
Football: 49ers

#5

bilde2910
    bilde2910

    Diamond Miner

  • Curse Premium
  • Curse Premium
  • 829 posts
  • Location: Stavern, Norway
  • Minecraft: bilde2910

Posted 29 December 2013 - 01:27 AM

View PostNinjachorlton, on 29 December 2013 - 12:27 AM, said:

Thank you for the response.
I've had a look at the changes between 1.6.4 and 1.7.4 and there seem to be quite a few.
I would assume that by changing to version 1.6.4 a lot of the worlds created under 1.7.4 would have issues/not work.
Is this the case? Both of my daughters also play and it would be a real shame for them to lose the worlds they have been working on.

Do you think that forge/more mods will be updated to work under 1.7.4 and it would be worth holding out for this?
Or is there another way you would recommend to use mods which would work now under 1.7.4?

again, thanks for your assistance.
You're welcome :)

If you made a world in 1.7.x, I recommend you wait out until mods are released for newer versions. You should in such case play at least 1.7.2 (1.7.4 was mainly about twitch streaming support). So for now, just wait.

ChatLog is a mod updated for Minecraft 1.7.8.

Click here to check it out: http://bit.ly/clmcmod


(PS. Are you an IRC chatter? You'll love this.)


#6

giddeanx
    giddeanx

    Out of the Water

  • Members
  • 2 posts

Posted 04 February 2014 - 08:19 PM

View PostAnon10W1z, on 29 December 2013 - 12:34 AM, said:

Quite few? 500,000 lines of code changes is quite few?
Just read this webpage.

Worlds created under 1.7.4 will show up a little messed up when it comes to 1.6.4, but this is if the world consists of mainly the new biomes.

He wrote "quite a few".  As in a lot.

#7

Volron
    Volron

    Carpenter

  • Members
  • 41 posts

Posted 06 February 2014 - 04:36 PM

Is there a link somewhere to get 1.7.2? I'm stuck under the same problem as the original post, but I have Windows 8 instead.

#8

theminerforlife3
  • Location: Wattpad.com
  • Minecraft: theminer4life3

Posted 06 February 2014 - 04:39 PM

Just use the profile selector and make a new profile with the version "update 1.7.2" or 1.7.4 and play it. :)

+1 for helping. Much appreciated! :)

God ain't dead.

Herobrine ain't dead.

I, on the other hand, am.


#9

Volron
    Volron

    Carpenter

  • Members
  • 41 posts

Posted 06 February 2014 - 06:07 PM

View Posttheminerforlife3, on 06 February 2014 - 04:39 PM, said:

Just use the profile selector and make a new profile with the version "update 1.7.2" or 1.7.4 and play it. Posted Image

+1 for helping. Much appreciated! Posted Image

You sir, are a miracle worker. Thank you.