Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

High CPU Usage


  • Please log in to reply
6 replies to this topic

#1

fyucel
    fyucel

    Out of the Water

  • Members
  • 2 posts

Posted 18 December 2013 - 09:16 PM

Hello, whenever I play Minecraft my computer uses more than 85% CPU usage. I have 4GB of RAM allocated and I am playing Minecraft 1.7.4 with no mods or forge at all.

My CPU usage is only 50-75% while playing Battlefield 4 on maxed out settings, why is Minecraft using so much then? My computer specs are:

AMD Phenom II X4 955 3.8GHz quad core processor, 8GB 1600 RAM, Radeon R9 290X 4GB 512-bit video card, and Windows 7 Ultimate 64-bit

Register or log in to remove.

#2

A_Herb
    A_Herb

    Void Walker

  • Members
  • 1517 posts

Posted 18 December 2013 - 09:46 PM

View Postfyucel, on 18 December 2013 - 09:16 PM, said:

Hello, whenever I play Minecraft my computer uses more than 85% CPU usage. I have 4GB of RAM allocated and I am playing Minecraft 1.7.4 with no mods or forge at all.

My CPU usage is only 50-75% while playing Battlefield 4 on maxed out settings, why is Minecraft using so much then? My computer specs are:

AMD Phenom II X4 955 3.8GHz quad core processor, 8GB 1600 RAM, Radeon R9 290X 4GB 512-bit video card, and Windows 7 Ultimate 64-bit

Are you having any actual problem? Why do you care about the CPU usage?
---
If I helped a bit, please click the little Posted Image or Posted Image thingy on my post, to give me 'reputation'. Thanks!

#3

fyucel
    fyucel

    Out of the Water

  • Members
  • 2 posts

Posted 19 December 2013 - 04:17 AM

It makes the game have a little lag and I can't multi task (watch a YouTube video and play simultaneously for example)

#4

PopuliMinistrum
  • Location: That one place doing that one thing

Posted 19 December 2013 - 05:36 AM

View PostPopuliMinistrum, on 19 December 2013 - 05:34 AM, said:

First off, never allocate that much RAM to Minecraft, it straight up doesn't need it. Also, one thing I have noticed about 1.7 is that it has some memory leakage. Go to edit profile in the launcher and in JVM Arguments type these:
-Xmx600M -Xincgc
The first one limits Minecraft to a max of 600MB (An unmodded client should never have to go above that) but tell it to dynamically allocate only what it needs, and the second one tells Java to speed up garbage collection on the game, which will greatly reduce wasted memory. Using both of these, I was able to go from 30-40 FPS in 1.7 to 70-80. I can't say for sure if it will work quite as well for you, but it is worth a shot.
I am gonna quote my reply to another post in this section, using those codes should make Minecraft manage its CPU usage much more efficiently and increase your overall performance.
The problem with the truth, is that it never lies.

#5

Tape_City
  • Location: Columbus, Ohio
  • Minecraft: Tape_City

Posted 19 December 2013 - 07:43 PM

View Postfyucel, on 19 December 2013 - 04:17 AM, said:

It makes the game have a little lag and I can't multi task (watch a YouTube video and play simultaneously for example)

I  Seem to have a similar issue but I only have high usage when I venture into an unexplored areas of a world OR multitask (ie ITunes or skinviewer and MC) I only allocate 512mb my processor is a Pentium and I have windows 7, 4mb of ram.
Posted Image Posted Image
www(dot)youtube(dot)com/user/TapeCity Replace (dot) with .

#6

A_Herb
    A_Herb

    Void Walker

  • Members
  • 1517 posts

Posted 19 December 2013 - 08:56 PM

The latest versions of minecraft require quite a good computer to pay them, especially at higher settings.

Nothing you've written so far seems 'unusual' to me.

If it's a bit laggy, try turning down the settings a bit. perhaps.
---
If I helped a bit, please click the little Posted Image or Posted Image thingy on my post, to give me 'reputation'. Thanks!

#7

Tape_City
  • Location: Columbus, Ohio
  • Minecraft: Tape_City

Posted 21 December 2013 - 08:40 PM

Try lowering the fps or turn on Vsync. if either of those fail then lower the render distance by 2 or 3. I tried all of these and it has solved the issue for me on superflat worlds but not on default worlds. you may have better luck than I'm having. But if this keeps up then my MC days may be numbered Posted Image
Posted Image Posted Image
www(dot)youtube(dot)com/user/TapeCity Replace (dot) with .