Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Requires java 1.6?

java 1.6

  • Please log in to reply
5 replies to this topic

#1

dazzledazz

Posted 05 December 2013 - 07:56 AM

Hi Peeps

i'm trying to get minecraft to work on my windows 7 laptop.

i have the most up to date version of java 7 update 45, but when i hit the minecraft launcher it tells me i need Java 1.6, but i have the latest version. and it take me to the java webpage to down load the same thing i have already installed

does anybody have a fix for this?

Cheers Dazz

Register or log in to remove.

#2

mg127
    mg127

    Lapis Lazuli Collector

  • Curse Premium
  • Curse Premium
  • 1003 posts
  • Location: Germany

Posted 05 December 2013 - 12:52 PM

looks like your java isn't registered in the "Path"

Open "My Conputer" -> General Settings -> Environment variables
scroll down to "Path" and insert the path to the bin folder inside java if it isn't listed there, seperate this entry with ; from the others in the same line

or you have installed multiple versions
uninstall all java versions and lookup the path noted above if there is anything left and remove it. then install the latest java again and add it to the "path"

i suggest to use only 64bit java if you have a 64bit windows
Posted Image

#3

StalePhish
  • Location: New England
  • Minecraft: StalePhish

Posted 06 December 2013 - 02:53 PM

View Postmg127, on 05 December 2013 - 12:52 PM, said:

i suggest to use only 64bit java if you have a 64bit windows
My guess is that it was going to be something about this. He probably has Java x86 on a 64-bit OS

#4

A_Herb
    A_Herb

    Void Walker

  • Members
  • 1517 posts

Posted 06 December 2013 - 03:06 PM

You can also explicitly tell minecraft which version of java to use, in the launcher, by editing the profile.

Under 'Java Settings' you'd checkmark "Executable" and put the path to it, which is probably C:\Program Files\Java\jre7\bin\javaw.exe
---
If I helped a bit, please click the little Posted Image or Posted Image thingy on my post, to give me 'reputation'. Thanks!

#5

dazzledazz

Posted 06 December 2013 - 03:17 PM

k well i fixed it for some reason it was giving me a 32bit java instead of 64 just deleted everything and forced a 64 bit down load and alls good

bricks away :)

#6

A_Herb
    A_Herb

    Void Walker

  • Members
  • 1517 posts

Posted 06 December 2013 - 04:10 PM

View Postdazzledazz, on 06 December 2013 - 03:17 PM, said:

k well i fixed it for some reason it was giving me a 32bit java instead of 64 just deleted everything and forced a 64 bit down load and alls good

bricks away Posted Image
Great, thanks for letting us know :-)

Diggy-diggy.
---
If I helped a bit, please click the little Posted Image or Posted Image thingy on my post, to give me 'reputation'. Thanks!