Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

minecraft server not working. log an chat blank.


  • Please log in to reply
2 replies to this topic

#1

gannit
    gannit

    Out of the Water

  • Members
  • 7 posts

Posted 18 November 2013 - 06:42 AM

I tried a few thing sot fix this but nothing working, here the log file.

[01:40:27] [Server thread/INFO]: Starting minecraft server version 1.7.2
[01:40:27] [Server thread/INFO]: Loading properties
[01:40:27] [Server thread/INFO]: Default game type: SURVIVAL
[01:40:27] [Server thread/INFO]: Generating keypair
[01:40:27] [Server console handler/ERROR]: Exception handling console input
java.io.IOException: The handle is invalid
at java.io.FileInputStream.readBytes(Native Method) ~[?:1.7.0_21]
at java.io.FileInputStream.read(Unknown Source) ~[?:1.7.0_21]
at java.io.BufferedInputStream.read1(Unknown Source) ~[?:1.7.0_21]
at java.io.BufferedInputStream.read(Unknown Source) ~[?:1.7.0_21]
at sun.nio.cs.StreamDecoder.readBytes(Unknown Source) ~[?:1.7.0_21]
at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.7.0_21]
at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:1.7.0_21]
at java.io.InputStreamReader.read(Unknown Source) ~[?:1.7.0_21]
at java.io.BufferedReader.fill(Unknown Source) ~[?:1.7.0_21]
at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.7.0_21]
at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.7.0_21]
at ll.run(SourceFile:78) [minecraft_server.1.7.2%20(1).exe:?]
[01:40:28] [Server thread/INFO]: Starting Minecraft server on 96.58.164.216:25565
[01:40:28] [Server thread/WARN]: **** FAILED TO BIND TO PORT!
[01:40:28] [Server thread/WARN]: The exception was: java.net.BindException: Cannot assign requested address: bind
[01:40:28] [Server thread/WARN]: Perhaps a server is already running on that port?
[01:40:31] [Server thread/INFO]: Stopping server
[01:40:31] [Server thread/INFO]: Saving worlds
[01:40:31] [Server thread/ERROR]: Exception stopping the server
java.lang.NullPointerException
at net.minecraft.server.MinecraftServer.a(SourceFile:272) ~[minecraft_server.1.7.2%20(1).exe:?]
at net.minecraft.server.MinecraftServer.n(SourceFile:297) ~[minecraft_server.1.7.2%20(1).exe:?]
at net.minecraft.server.MinecraftServer.run(SourceFile:390) [minecraft_server.1.7.2%20(1).exe:?]
at ky.run(SourceFile:617) [minecraft_server.1.7.2%20(1).exe:?]
[01:40:31] [Server Shutdown Thread/INFO]: Stopping server
[01:40:31] [Server Shutdown Thread/INFO]: Saving worlds

Register or log in to remove.

#2

Matbag248

Posted 18 November 2013 - 12:41 PM

Hey, what things did you do to get the log and chat back to normal? because mine is just blank. I've looked around but I can't find a fix.

Thanks.

#3

GrimTheReaper
  • Location: USA
  • Minecraft: Grim_TheReaper

Posted 18 November 2013 - 04:54 PM

View Postgannit, on 18 November 2013 - 06:42 AM, said:

I tried a few thing sot fix this but nothing working, here the log file.

[01:40:27] [Server thread/INFO]: Starting minecraft server version 1.7.2
[01:40:27] [Server thread/INFO]: Loading properties
[01:40:27] [Server thread/INFO]: Default game type: SURVIVAL
[01:40:27] [Server thread/INFO]: Generating keypair
[01:40:27] [Server console handler/ERROR]: Exception handling console input
java.io.IOException: The handle is invalid
at java.io.FileInputStream.readBytes(Native Method) ~[?:1.7.0_21]
at java.io.FileInputStream.read(Unknown Source) ~[?:1.7.0_21]
at java.io.BufferedInputStream.read1(Unknown Source) ~[?:1.7.0_21]
at java.io.BufferedInputStream.read(Unknown Source) ~[?:1.7.0_21]
at sun.nio.cs.StreamDecoder.readBytes(Unknown Source) ~[?:1.7.0_21]
at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.7.0_21]
at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:1.7.0_21]
at java.io.InputStreamReader.read(Unknown Source) ~[?:1.7.0_21]
at java.io.BufferedReader.fill(Unknown Source) ~[?:1.7.0_21]
at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.7.0_21]
at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.7.0_21]
at ll.run(SourceFile:78) [minecraft_server.1.7.2%20(1).exe:?]
[01:40:28] [Server thread/INFO]: Starting Minecraft server on 96.58.164.216:25565
[01:40:28] [Server thread/WARN]: **** FAILED TO BIND TO PORT!
[01:40:28] [Server thread/WARN]: The exception was: java.net.BindException: Cannot assign requested address: bind
[01:40:28] [Server thread/WARN]: Perhaps a server is already running on that port?
[01:40:31] [Server thread/INFO]: Stopping server
[01:40:31] [Server thread/INFO]: Saving worlds
[01:40:31] [Server thread/ERROR]: Exception stopping the server
java.lang.NullPointerException
at net.minecraft.server.MinecraftServer.a(SourceFile:272) ~[minecraft_server.1.7.2%20(1).exe:?]
at net.minecraft.server.MinecraftServer.n(SourceFile:297) ~[minecraft_server.1.7.2%20(1).exe:?]
at net.minecraft.server.MinecraftServer.run(SourceFile:390) [minecraft_server.1.7.2%20(1).exe:?]
at ky.run(SourceFile:617) [minecraft_server.1.7.2%20(1).exe:?]
[01:40:31] [Server Shutdown Thread/INFO]: Stopping server
[01:40:31] [Server Shutdown Thread/INFO]: Saving worlds
When it says "Failure to bind port, is there another port running on that server?" it means basically what it says. There is something wrong with your Portforward. Make sure the ports are set to 25565.

View PostMatbag248, on 18 November 2013 - 12:41 PM, said:

Hey, what things did you do to get the log and chat back to normal? because mine is just blank. I've looked around but I can't find a fix.

Thanks.
I have gotten this bug with the default Minecraft Launcher, what I did is make a start.bat file for my server when I hosted it myself. The .bat file allows you to allocate certain RAM to your server aswell.

Here is the code for Vanilla servers:(Once inside a word program, IE: Notepad, click Save As and title it Run.Bat)
java -Xmx1024M -jar minecraft-server.jar -o true
PAUSE

Posted Image


Posted Image