Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[1.7.5] [1.7.4] [1.7.2] XRay (FORGE COMPATIBLE!)

1.7.2 xray coords cheating cheats 1.7.4 1.7.5

  • Please log in to reply
722 replies to this topic

#1

AmbientOcclusion

Posted 16 November 2013 - 03:17 PM

XRay for Minecraft 1.7.2 - 1.7.5

(Yes, this is compatible with Forge, Optifine, Rei's Minimap, and many others!)



> Downloads (the current patcher version is: v4)
XRay for 1.7.5: Download (class files)
XRay for 1.7.4: Download (class files)
XRay for 1.7.2: Download (class files)

> Features
Spoiler:

If you have any suggestions or feature requests, feel free to send me a PM.

> Default Keybindings
Spoiler:

> Install howto
Spoiler:

> Configuration
Spoiler:

> Copyright
You may distribute it with the original links, and only the original links, on any website or forum you wish.
You may not download and then re-upload it to any site without my written permission.
Seriously guys, stop trying to steal my mod.


> Troubleshooting
If you try to patch and you get an error, or something crashes, try using the Auto Repair button first before reporting it. This has been programmed to fix most commonly encountered problems.

If you use the XRayPatcher and you don't have XRay, make sure you properly set the Use version setting:

Posted Image

> Awesome mod reviews (some a little outdated)

Spoiler:

1.7.2 & 1.7.4 Mods: XRay, Coords, and Fly.
Click here for more information.

Register or log in to remove.

#2

LauFon
    LauFon

    Tree Puncher

  • Members
  • 17 posts

Posted 16 November 2013 - 04:24 PM

How do you install it?

#3

AmbientOcclusion

Posted 16 November 2013 - 04:28 PM

View PostLauFon, on 16 November 2013 - 04:24 PM, said:

How do you install it?
This tutorial explains it pretty well.
1.7.2 & 1.7.4 Mods: XRay, Coords, and Fly.
Click here for more information.

#4

Felix1606

Posted 16 November 2013 - 04:29 PM

Siiiiiickkk downloading

#5

LauFon
    LauFon

    Tree Puncher

  • Members
  • 17 posts

Posted 16 November 2013 - 04:31 PM

View PostAmbientOcclusion, on 16 November 2013 - 04:28 PM, said:

This tutorial explains it pretty well.

Great took me 30 seconds and it's working perfectly for 1.7.2!


#6

Felix1606

Posted 16 November 2013 - 04:34 PM

also how do you use it? I can download it and all but how do you use the mod.

#7

LauFon
    LauFon

    Tree Puncher

  • Members
  • 17 posts

Posted 16 November 2013 - 04:40 PM

Ahh I can launch the game with the x-ray files but while im in-game when I press X or L it doesn't do anything :X

__________________________

---- Minecraft Crash Report ----
// Hey, that tickles! Hehehe!

Time: 13-11-16 11:41
Description: Initializing game

java.lang.UnsupportedClassVersionError: ble : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$000(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at bng.<init>(SourceFile:26)
at bnq.<init>(SourceFile:37)
at bcn.<init>(SourceFile:29)
at azd.Z(SourceFile:376)
at azd.e(SourceFile:689)
at net.minecraft.client.main.Main.main(SourceFile:103)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$000(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at bng.<init>(SourceFile:26)
at bnq.<init>(SourceFile:37)
at bcn.<init>(SourceFile:29)
at azd.Z(SourceFile:376)

-- Initialization --
Details:
Stacktrace:
at azd.e(SourceFile:689)
at net.minecraft.client.main.Main.main(SourceFile:103)

-- System Details --
Details:
Minecraft Version: 1.7.2
Operating System: Windows 7 (amd64) version 6.1
Java Version: 1.6.0_20, Sun Microsystems Inc.
Java VM Version: Java HotSpot™ 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
Memory: 50287008 bytes (47 MB) / 76087296 bytes (72 MB) up to 954466304 bytes (910 MB)
JVM Flags: 2 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
Launched Version: 1.7.2 xray
LWJGL: 2.9.0
OpenGL: AMD M880G with ATI Mobility Radeon HD 4250                 GL version 3.2.9704 Compatibility Profile Context, ATI Technologies Inc.
Is Modded: Very likely; Jar signature invalidated
Type: Client (map_client.txt)
Resource Packs: []
Current Language: ~~ERROR~~ NullPointerException: null
Profiler Position: N/A (disabled)
Vec3 Pool Size: ~~ERROR~~ NullPointerException: null
Anisotropic Filtering: Off (1)

#8

AmbientOcclusion

Posted 16 November 2013 - 04:45 PM

View PostLauFon, on 16 November 2013 - 04:40 PM, said:

Ahh I can launch the game with the x-ray files but while im in-game when I press X or L it doesn't do anything :X
Make sure you have your profile version set properly.
Posted Image

View PostFelix1606, on 16 November 2013 - 04:29 PM, said:

Siiiiiickkk downloading
Assuming you installed it properly, press X ingame to enable XRay, and press L to enable Fullbright.

---------------------------------------------------------------------------
Hmm, I'm working on an auto install script.
It should be ready in a bit.
1.7.2 & 1.7.4 Mods: XRay, Coords, and Fly.
Click here for more information.

#9

Felix1606

Posted 16 November 2013 - 04:45 PM

thanks!

#10

dark_hunter
  • Location: Auckland, New Zealand
  • Minecraft: dh47
  • Xbox:DH4774

Posted 16 November 2013 - 06:29 PM

Wow thank you sir.

#11

Shreddintyres

Posted 16 November 2013 - 07:07 PM

If you use mcpatcher (beta5 for 1.7.2) just:
  • launch mcpatcher
  • click the plus button
  • navigate to the directory you downloaded the zip.
  • click open.
  • click patch.
  • Then open the minecraft launcher,
  • edit profile to use MCPatcher underversion (1.7.2-Mcpatcher)
  • Launch minecraft
  • Profit
- Cheers

#12

AmbientOcclusion

Posted 16 November 2013 - 10:00 PM

* Created auto installer.
1.7.2 & 1.7.4 Mods: XRay, Coords, and Fly.
Click here for more information.

#13

Icey401
    Icey401

    Carpenter

  • Members
  • 69 posts
  • Location: On earth.
  • Minecraft: Icey401

Posted 17 November 2013 - 05:40 AM

WOOO! If possible, can you post to topic? :')
[url="https://www.youtube.com/watch?v=gK3nhfYtkoM"]https://www.youtube....K3nhfYtkoM[/url]
Posted Image

#14

siriussr
    siriussr

    Out of the Water

  • Members
  • 5 posts

Posted 19 November 2013 - 04:44 AM

I can't get it to work on my mac. I get a error code similar to the one posted above. any ideas?

#15

Forster46

Posted 19 November 2013 - 05:23 AM

Auto installer worked for me. Works with my texture pack and everything.

#16

Euryleia
  • Minecraft: Euryleia

Posted 19 November 2013 - 06:24 AM

View Postsiriussr, on 19 November 2013 - 04:44 AM, said:

I can't get it to work on my mac. I get a error code similar to the one posted above. any ideas?

Doesn't work under Windows 7 either.  Same error as posted above.  This is with the .ZIP version.  Apparently only the autoinstaller version works (at least that's what I gather from the posts from people that got it working above), but that won't help you on a Mac.

#17

Forster46

Posted 19 November 2013 - 08:49 AM

View PostEuryleia, on 19 November 2013 - 06:24 AM, said:

Doesn't work under Windows 7 either.  Same error as posted above.  This is with the .ZIP version.  Apparently only the autoinstaller version works (at least that's what I gather from the posts from people that got it working above), but that won't help you on a Mac.

I did the normal version first on my windows 7 and it didn't work, but I figured I probably did it wrong. The auto installer worked fine, from clicking download I was playing in less then 60 seconds with it working.

#18

AmbientOcclusion

Posted 19 November 2013 - 01:16 PM

I updated everything to fix the Unsupported major.minor version 51.0 error.

Anyone who was getting this error should try redownloading and installing the mod. It should be fixed.
1.7.2 & 1.7.4 Mods: XRay, Coords, and Fly.
Click here for more information.

#19

Sweetblacksoul

Posted 19 November 2013 - 03:12 PM

Get same error as posted above with zip and with autoinstaller. Already downloaded again, but problem is still the same...

#20

AmbientOcclusion

Posted 19 November 2013 - 03:30 PM

View PostSweetblacksoul, on 19 November 2013 - 03:12 PM, said:

Get same error as posted above with zip and with autoinstaller. Already downloaded again, but problem is still the same...
Try redownloading one more time.
I think I uploaded the wrong file.
1.7.2 & 1.7.4 Mods: XRay, Coords, and Fly.
Click here for more information.