Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

internal exception: io.netty.handler.timeout.readtimeoutexception


  • Please log in to reply
9 replies to this topic

#1

jacobfrizzle
    jacobfrizzle

    The Meaning of Life, the Universe, and Everything...

  • Members
  • 42 posts

Posted 15 November 2013 - 11:47 PM

This has happened to me just a little bit ago and wondering what it means and how I can fix it I have no idea why its happening and it happens after a bit on a server. Please help.

Register or log in to remove.

#2

Techdolphin
  • Location: Dublin, Ireland
  • Minecraft: cmptrguy436
  • Xbox:cmptrguy436

Posted 15 November 2013 - 11:49 PM

Does this happen on ALL servers?
I'm back from the dead!
Sometimes I stream here
I speedrun Super Mario 64

#3

jacobfrizzle
    jacobfrizzle

    The Meaning of Life, the Universe, and Everything...

  • Members
  • 42 posts

Posted 15 November 2013 - 11:53 PM

View PostTechdolphin, on 15 November 2013 - 11:49 PM, said:

Does this happen on ALL servers?
Yea.

#4

Techdolphin
  • Location: Dublin, Ireland
  • Minecraft: cmptrguy436
  • Xbox:cmptrguy436

Posted 15 November 2013 - 11:58 PM

There is no current fix for this bug.

It is on the server side so nothing is wrong with your client.

The current bug report for this bug: https://mojang.atlas...browse/MC-34947

Just hold on for awhile.
I'm back from the dead!
Sometimes I stream here
I speedrun Super Mario 64

#5

Awesomeishere787

Posted 20 November 2013 - 04:05 AM

This happens to me too it started off about every 1 to 2 hours and now i cant be on a server for more than 5 min.

#6

up2zero
    up2zero

    Tree Puncher

  • Members
  • 13 posts

Posted 20 November 2013 - 10:32 AM

I'm getting the same error.  I play with my son on a direct connect server (because we are on two PCs right next to each other)  
I started out with a weird rubberbanding, he would move but it looked to me like he was in the same place, he said it looked like I was teleporting like and enderman.  He left the game, I restarted the server and our game and there were hundreds of creepers and skeletons on fire, none were hostile.  Some of the creepers were spawning with their feet in the ground.  the amount of mobs slowed my game to a crawl.  I exited and restarted and get the same error message in the thread title.  
My log looks interesting:

[19:48:39] [Server thread/INFO]: Starting minecraft server version 1.7.2
[19:48:39] [Server console handler/ERROR]: Exception handling console input
java.io.IOException: The handle is invalid
at java.io.FileInputStream.readBytes(Native Method) ~[?:1.7.0_45]
at java.io.FileInputStream.read(Unknown Source) ~[?:1.7.0_45]
at java.io.BufferedInputStream.read1(Unknown Source) ~[?:1.7.0_45]
at java.io.BufferedInputStream.read(Unknown Source) ~[?:1.7.0_45]
at sun.nio.cs.StreamDecoder.readBytes(Unknown Source) ~[?:1.7.0_45]
at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.7.0_45]
at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:1.7.0_45]
at java.io.InputStreamReader.read(Unknown Source) ~[?:1.7.0_45]
at java.io.BufferedReader.fill(Unknown Source) ~[?:1.7.0_45]
at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.7.0_45]
at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.7.0_45]
at ll.run(SourceFile:78) [minecraft_server.1.7.2.exe:?]
[19:48:39] [Server thread/INFO]: Loading properties
[19:48:39] [Server thread/INFO]: Default game type: ADVENTURE
[19:48:39] [Server thread/INFO]: Generating keypair
[19:48:39] [Server thread/INFO]: Starting Minecraft server on *:25565
[19:48:39] [Server thread/INFO]: Preparing level "world"
[19:48:40] [Server thread/INFO]: Preparing start region for level 0
[19:48:41] [Server thread/INFO]: Done (1.339s)! For help, type "help" or "?"
[19:49:00] [User Authenticator #1/INFO]: UUID of player up2zero is e842a8a8cf32xxxxxxxxxxxxxxxxxxxxx
[19:49:00] [Server thread/INFO]: up2zero[/127.0.xxxxxxxxx] logged in with entity id 295 at (-40.31248641494192, 65.0, 381.0683003957583)
[19:49:00] [Server thread/INFO]: up2zero joined the game
[19:49:00] [Server thread/ERROR]: Chunk file at -11,30 is in the wrong location; relocating. (Expected -11, 30, got -9, 26)
[19:49:00] [Server thread/ERROR]: Chunk file at -8,27 is in the wrong location; relocating. (Expected -8, 27, got -3, 21)
[19:49:00] [Server thread/ERROR]: Chunk file at -5,30 is in the wrong location; relocating. (Expected -5, 30, got -2, 23)
[19:49:00] [Server thread/ERROR]: Chunk file at -4,21 is in the wrong location; relocating. (Expected -4, 21, got -9, 29)
[19:49:00] [Server thread/ERROR]: Chunk file at -3,20 is in the wrong location; relocating. (Expected -3, 20, got -6, 22)
[19:49:01] [Server thread/ERROR]: Wrong location! wl['Creeper'/1573, l='world', x=-0.03, y=62.55, z=360.70]
[19:49:01] [Server thread/ERROR]: Wrong location! wl['Creeper'/1574, l='world', x=-0.08, y=61.99, z=368.00]
[19:49:01] [Server thread/ERROR]: Wrong location! wl['Creeper'/1575, l='world', x=-2.93, y=62.00, z=364.30]
[19:49:01] [Server thread/ERROR]: Wrong location! wl['Creeper'/1576, l='world', x=-2.28, y=62.00, z=365.70]
[19:49:01] [Server thread/ERROR]: Wrong location! wl['Creeper'/1577, l='world', x=-3.43, y=62.00, z=367.10]
[19:49:01] [Server thread/ERROR]: Wrong location! wl['Creeper'/1578, l='world', x=-9.20, y=62.00, z=364.30]
[19:49:01] [Server thread/ERROR]: Wrong location! wl['Creeper'/1579, l='world', x=-12.68, y=62.00, z=367.41]
[19:49:01] [Server thread/ERROR]: Wrong location! wl['Creeper'/1580, l='world', x=-7.91, y=62.00, z=364.30]
[19:49:01] [Server thread/ERROR]: Wrong location! wl['Creeper'/1581, l='world', x=-12.28, y=62.00, z=366.00]
[19:49:01] [Server thread/ERROR]: Wrong location! wl['Creeper'/1582, l='world', x=-5.96, y=62.00, z=364.30]
[19:49:01] [Server thread/ERROR]: Wrong location! wl['Creeper'/1583, l='world', x=-10.02, y=62.00, z=366.27]
[19:49:01] [Server thread/ERROR]: Wrong location! wx['Skeleton'/1584, l='world', x=-0.70, y=63.00, z=353.30]

this goes on for about a thousand lines and then this:


[20:00:39] [Server thread/INFO]: /debug <start|stop>
[20:00:39] [Server thread/INFO]: /defaultgamemode <mode>
[20:00:39] [Server thread/INFO]: Started debug profiling
[20:00:39] [Server thread/INFO]: Started debug profiling
[20:00:40] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.entities.remove' took aprox 913.277971 ms
[20:00:40] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.entities.regular' took aprox 144.757273 ms
[20:00:40] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.entities' took aprox 1058.440645 ms
[20:00:40] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick' took aprox 1108.651646 ms
[20:00:40] [Server thread/WARN]: Something's taking too long! 'root.levels.world' took aprox 1114.557863 ms
[20:00:40] [Server thread/WARN]: Something's taking too long! 'root.levels' took aprox 1114.79392 ms
[20:00:40] [Server thread/WARN]: Something's taking too long! 'root' took aprox 1114.880252 ms
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/16663, l='world', x=-47.70, y=69.41, z=334.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/16672, l='world', x=-47.70, y=69.41, z=334.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/16681, l='world', x=-47.70, y=69.41, z=334.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/16692, l='world', x=-47.70, y=69.41, z=334.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/16704, l='world', x=-47.70, y=69.41, z=334.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/16716, l='world', x=-47.70, y=69.41, z=334.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/16724, l='world', x=-47.70, y=69.41, z=334.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/17320, l='world', x=-48.91, y=69.41, z=340.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/17440, l='world', x=-49.19, y=69.41, z=340.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/17559, l='world', x=-48.80, y=69.41, z=340.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/17675, l='world', x=-48.60, y=69.41, z=340.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/17789, l='world', x=-48.73, y=69.41, z=340.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/17889, l='world', x=-48.98, y=69.41, z=340.30]
[20:00:41] [Server thread/ERROR]: Wrong location! wx['Skeleton'/17949, l='world', x=-48.98, y=69.41, z=340.30]
[20:00:41] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.entities.regular' took aprox 225.442981 ms
[20:00:41] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.entities' took aprox 314.312149 ms
[20:00:41] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick' took aprox 334.269707 ms
[20:00:41] [Server thread/WARN]: Something's taking too long! 'root.levels.world' took aprox 339.516056 ms
[20:00:41] [Server thread/WARN]: Something's taking too long! 'root.levels' took aprox 339.732189 ms
[20:00:41] [Server thread/WARN]: Something's taking too long! 'root' took aprox 339.7826 ms
[20:00:41] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.chunkSource' took aprox 140.639886 ms
[20:00:45] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.entities.remove' took aprox 4061.141699 ms
[20:00:45] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.entities' took aprox 4074.799414 ms
[20:00:45] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick' took aprox 4227.01266 ms
[20:00:45] [Server thread/WARN]: Something's taking too long! 'root.levels.world' took aprox 4229.777709 ms
[20:00:45] [Server thread/WARN]: Something's taking too long! 'root.levels' took aprox 4229.930753 ms
[20:00:45] [Server thread/WARN]: Something's taking too long! 'root' took aprox 4229.981466 ms
[20:00:45] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.chunkSource' took aprox 199.578904 ms
[20:00:45] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.entities' took aprox 100.558745 ms
[20:00:45] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick' took aprox 301.807243 ms
[20:00:45] [Server thread/WARN]: Something's taking too long! 'root.levels.world' took aprox 302.026093 ms
[20:00:45] [Server thread/WARN]: Something's taking too long! 'root.levels' took aprox 302.154987 ms
[20:00:45] [Server thread/WARN]: Something's taking too long! 'root' took aprox 302.213549 ms
[20:00:46] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.entities.regular.tick' took aprox 122.034364 ms
[20:00:46] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.entities.regular' took aprox 129.701037 ms
[20:00:46] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick.entities' took aprox 129.789482 ms
[20:00:46] [Server thread/WARN]: Something's taking too long! 'root.levels.world.tick' took aprox 130.249519 ms
[20:00:46] [Server thread/WARN]: Something's taking too long! 'root.levels.world' took aprox 130.460821 ms
[20:00:46] [Server thread/WARN]: Something's taking too long! 'root.levels' took aprox 130.579755 ms
[20:00:46] [Server thread/WARN]: Something's taking too long! 'root' took aprox 130.627449 ms
[20:00:46] [Server thread/INFO]: Stopping server
[20:00:46] [Server thread/INFO]: Saving players
[20:00:46] [Server thread/INFO]: Saving worlds
[20:00:46] [Server thread/INFO]: Saving chunks for level 'world'/Overworld
[20:00:46] [Server thread/INFO]: Saving chunks for level 'world'/Nether
[20:00:46] [Server thread/INFO]: Saving chunks for level 'world'/The End
[20:00:47] [Server Shutdown Thread/INFO]: Stopping server
[20:00:47] [Server Shutdown Thread/INFO]: Saving players
[20:00:47] [Server Shutdown Thread/INFO]: Saving worlds
[20:00:47] [Server Shutdown Thread/INFO]: Saving chunks for level 'world'/Overworld


I hope to get a fix because we have worked so hard at getting where we are now.  
Does anyone have any suggestions as to what I can so with my server folder to resolve this but not lose our progress?

#7

CloudMiner

Posted 13 December 2013 - 07:49 PM

This happens all the time on my server every time i go on my server and i am on it for about 30 mins everything stops apart from you and when i try the server cmd it wont let me write is the ANY way to fix it. I think i need a better computer however timeout and readtimout i know what it means

You know when your server says Internal Exception: io.netty.handler.timout.readtimoutexeption it means that your server has crashed and it isn't responding.

I don't think there is anything out there to help thing sorry

TheCloudMiner...

PS can you reply to this i need this fixing as well

#8

matt6090
    matt6090

    Out of the Water

  • Members
  • 7 posts
  • Minecraft: WitherFire

Posted 21 December 2013 - 01:49 PM

I've been having the same problem. I thought I could come on MinecraftForums for an answer, but all I find is something along the lines of "Sit tight until they update it on Bukkit."

#9

Deathwizard3589

Posted 12 January 2014 - 10:17 PM

i cant be on for only 45 seconds its been happening for a week now can someone help me please i beg

#10

reececarhart

Posted 22 February 2014 - 12:07 AM

I think i have a solution, it keeps happening to me too, but i have been looking around the web and i thought it might be something to do with the region that your in, it might be corrupt, try removing worldedit/worldguard and check again or on the other hand the admins internet is rubbish or yours is :D if so there is a command you can put into cmd to speed it ip Posted Image Posted Image