Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

"End of stream" Error


  • Please log in to reply
25 replies to this topic

#1

DrTirde
    DrTirde

    Newly Spawned

  • Members
  • 1 posts

Posted 04 August 2010 - 07:32 PM

When I join a server (ANY server), my messages wont appear and the map wont load fully (just a small bit or nothing, I just keep falling) and after a moment i get disconnected with "End of stream" error.
What could be causing this?  :P

I tried again after deleting my minecraft files and this time it gave this error: "internal exception: java.net.SocketException: Software caused connection abort: socket write error"

And now it gave me: "internal exception: java.net.SocketException: Software caused connection abort: recv failed"

Register or log in to remove.

#2

velox
    velox

    Out of the Water

  • Members
  • 7 posts

Posted 05 August 2010 - 12:16 AM

Same thing is happening to me. I've tried a dozen servers, and some of those servers several times, and most of the time i just fall until i get the end of stream error.
When chunks do load, and i break something, nothing drops, and the block comes back after a while. It tends to take longer before it gives me an error again. I even had one server actually load everything, and i was able to stay on it for a couple of minutes.
~Ôo
Posted Image

#3

JDDeal
    JDDeal

    Tree Puncher

  • Members
  • 16 posts

Posted 05 August 2010 - 12:44 AM

Same here, big pain, keepin me from playing because I dont like rejoining every 2-3 minutes, only the first minute of it actually working :/

#4

CoCheese
    CoCheese

    Tree Puncher

  • Members
  • 34 posts

Posted 10 August 2010 - 02:54 AM

Tried web client, worked for 20 min solid, then the good old "end of stream" punt!

#5

supa1337killa
  • Location: SWAG
  • Minecraft: SWAG

Posted 13 August 2010 - 04:37 AM

i connected to this server just fine but right when i moved to another the same thing happened to me KEEP THIS THREAD ALIVE
Posted Image

#6

HarryBard

Posted 13 August 2010 - 05:33 AM

Same thing happens to me. I can never play smp, I always fall and noone can see what i'm typing.

#7

Jstratter
  • Location: That place between rage and serenity

Posted 13 August 2010 - 09:22 PM

All I get is the java socket exception error. It's so annoying!

#8

Mackinstyle

Posted 13 August 2010 - 09:59 PM

When I try to connect to my own server (that worked before the latest client update), I get the End of Stream error.

On the server side I get this:

java.io.IOException: Bad packet id 2
at ha.b(SourceFile:75)
at aw.f(SourceFile:147)
at aw.c(SourceFile:9)
at gy.run(SourceFile:57)
2010-08-13 17:55:59 [INFO] /192.168.2.2:50028 lost connection

#9

Jstratter
  • Location: That place between rage and serenity

Posted 11 September 2010 - 02:43 AM

Hmmm I started getting the end of stream error recently. It's pretty bad. (once every 35 seconds or so)

#10

Thekraken

Posted 11 September 2010 - 02:55 AM

I have a very similar problem. When I join any server I can play fine until I start mining. I can mine away about 10 blocks fine then blocks start re-appearing, I cant talk and eventually I get a "Lost Connection: End of Stream". I would really like to see this resolved. The game worked fine for the first 2 days but a month down the track I'm still having these problems :Skeleton:

#11

bergotronic

Posted 11 September 2010 - 03:17 AM

Thekraken said:

I have a very similar problem. When I join any server I can play fine until I start mining. I can mine away about 10 blocks fine then blocks start re-appearing, I cant talk and eventually I get a "Lost Connection: End of Stream". I would really like to see this resolved. The game worked fine for the first 2 days but a month down the track I'm still having these problems :iapprove:


Exact same problem here.  :D

#12

Thekraken

Posted 11 September 2010 - 03:23 AM

Well I just got at least 15 minutes game time just then before I started lagging and got the error
"Internal exception: java.net.SocketException: Connection reset by peer: socket write error"

@Bergo I'm glad I am not the only one with this problem. Hang in there -_-

edit:
Here is the other error I am getting.

"Internal exception: java.net.SocketException: Read timed out"

#13

Jstratter
  • Location: That place between rage and serenity

Posted 11 September 2010 - 10:26 PM

I only get the error when I edit blocks, but I can't play minecraft very well without editing blocks.

#14

drax
    drax

    Out of the Water

  • Members
  • 6 posts

Posted 12 September 2010 - 09:36 AM

Yeah I just got minecraft today and haven't been able to play it because of this. Only part of the map is rendered OR I spawn and fall through the map. Notch.. HELP US!

#15

Szkieletor

Posted 14 September 2010 - 06:06 PM

Anyone know what is the problem? I can't connect to SMP and it's only way I play Minecraft.

View Postnalfz, on 22 October 2011 - 10:36 PM, said:

The first person to say herobrine will be shot

#16

Xevo
    Xevo

    Out of the Water

  • Members
  • 6 posts

Posted 15 September 2010 - 09:14 AM

There's a much bigger thread about it here -- viewtopic.php?f=1013&t=34648 and a solution on Page 4 for people with Atheros NICs.

#17

Szkieletor

Posted 15 September 2010 - 12:10 PM

It's not even error that is posted in that thread. Game WORKS, but when I try to connect to an SMP server it connects, says Logging in... and after some time Connection lost. End of Stream.

View Postnalfz, on 22 October 2011 - 10:36 PM, said:

The first person to say herobrine will be shot

#18

F_Synchro
  • Minecraft: F_Synchro

Posted 15 September 2010 - 12:22 PM

Bad network card compatability most likely.
I solved this problem for myself by changing the way my computer connects to the internet.
Instead of using an onboard lan, I'm using a PCI-E wireless network card, solved everything for me.

#19

CoCheese
    CoCheese

    Tree Puncher

  • Members
  • 34 posts

Posted 15 September 2010 - 02:48 PM

Xevo said:

There's a much bigger thread about it here -- viewtopic.php?f=1013&t=34648 and a solution on Page 4 for people with Atheros NICs.

Buying new hardware is a workaround, hopefully Notch can address this soon.

#20

Szkieletor

Posted 15 September 2010 - 03:50 PM

Xevo said:

There's a much bigger thread about it here -- viewtopic.php?f=1013&t=34648 and a solution on Page 4 for people with Atheros NICs.

Problem is, I am using USB wireless adapter connecting with Sagem Livebox. Direct connection cable is too short for me to connect my computer to.

View Postnalfz, on 22 October 2011 - 10:36 PM, said:

The first person to say herobrine will be shot