Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Minecraft Forge, won't work with 1.7.2?


  • Please log in to reply
139 replies to this topic

#1

sarahanne

Posted 27 October 2013 - 01:25 AM

I have Minecraft Forge downloaded, as well as a handful of mods that need Forge to run. I was super excited for the new Minecraft update, but I can't seem to find anywhere to download Forge 1.7.2, so I'm assuming it hasn't been updated yet. If it hasn't, is there any way for me to still play Minecraft 1.7.2 and still use Forge with all my mods??

Register or log in to remove.

#2

wayward_lore
  • Location: Up in the sky, in my mind
  • Minecraft: vreeper

Posted 27 October 2013 - 02:26 AM

View Postsarahanne, on 27 October 2013 - 01:25 AM, said:

I have Minecraft Forge downloaded, as well as a handful of mods that need Forge to run. I was super excited for the new Minecraft update, but I can't seem to find anywhere to download Forge 1.7.2, so I'm assuming it hasn't been updated yet. If it hasn't, is there any way for me to still play Minecraft 1.7.2 and still use Forge with all my mods??
No. And even after forge updates to 1.7.2 (which is going to take a while), you're going to have to wait for the mods you're using to update too (which is going to take even longer).

Sorry, you're just going to have to wait like the rest of us. :(

#3

Sethre
    Sethre

    Tree Puncher

  • Members
  • 28 posts

Posted 27 October 2013 - 02:37 AM

As wayward_lore said, it is going to take some time for the creators of Minecraft Forge to update the mod to 1.7.2. This is because the code has just recently been released so now they will have to look at it and see what's changed and then adapt their mod to work with the new code. This same thing goes for all the creators of the other mods that you use. So all in all it could be a little bit before you can use the mods again.

#4

sarahanne

Posted 27 October 2013 - 02:56 AM

Boooooo! Thanks for responding though!

#5

BurgerChamp
  • Location: 7000 ISLAS
  • Minecraft: BurgerChamp

Posted 27 October 2013 - 03:16 AM

nope, works fine for me...

Posted Image

The OTters

Posted Image

#6

sarahanne

Posted 27 October 2013 - 04:40 AM

What works fine for you? Forge & 1.7.2?? Cause I can still use Forge and all my mods, but it just stays on 1.6.2. If I change the version to 1.7.2. or latest version, none of my mods are there.

#7

PillowTalk

Posted 27 October 2013 - 06:55 AM

Are the changes from 1.7.2 *that* different for the structure of mods? Serious question, because on the surface, it doesn't seem like certain things, like Forge, would need to be all that much different, if at all. You know, some new blocks, a slightly different world gen structure for the new biomes, etc. Looking at it that way, it's hard to see why something like Forge would even need an update.

Unless mods like Forge rely on hex offsets, in which case, nevermind. XD
The Cool Side of the Pillow

#8

bilde2910
    bilde2910

    Diamond Miner

  • Curse Premium
  • Curse Premium
  • 827 posts
  • Location: Stavern, Norway
  • Minecraft: bilde2910

Posted 27 October 2013 - 08:11 AM

Forge mods need Forge to update. Forge in turn needs MCP to be updated, afaik. And MCP hasn't come out yet. Pretty much all mods need MCP to update, as that is the software that converts the meaningless classes like dx.class, acd.class etc. to actual names and makes sense of them (a process known as deobfuscation). There will be exceptions once in a blue moon, but you need to look around quite a bit before they're to be seen.

1.7 is an unusually big update, MCP normally takes just a few hours to update, but it's already been almost 2 days without a word from Searge and his team on their website. Also, I read in another update that critical parts of Forge no longer work after the update to 1.7, and quite a bit has to be rewritten - we should expect the bigger mods for Forge to be released some time in December. [citation needed]

ChatLog is a mod updated for Minecraft 1.7.8.

Click here to check it out: http://bit.ly/clmcmod


(PS. Are you an IRC chatter? You'll love this.)


#9

Airwick_Eric
  • Location: Australia, Victoria, Melbourne
  • Minecraft: erics2001

Posted 27 October 2013 - 10:00 AM

There is a huge change to minecraft 1.7. Over 15,000 lines of code were changed plus all the migration from ids to minecraft:name of item. I am a modder and I understand why its taking then so long.

Also the sound system and graphics system have been rewritten from scratch.
That's a lot of code.

~ Airwick_Eric

Check Out My Two Mods Here

Coloured Lamps

Rotten Flesh to Leather Mod


#10

XHEROBRINEH4X

Posted 28 October 2013 - 12:07 AM

At least you can play your mods on a older version on a private server or single player...

#11

supergeeky1121

Posted 28 October 2013 - 02:24 AM

I know it's hard to wait, trust me. But I am sure all the mod creators are working like mad to get the new version out. In the mean time we can run around collecting flowers and new blocks and checking out the new biomes. That's at least what I am doing. I now I will have my mods in 1.7.2 in no time.

#12

Fir3will
    Fir3will

    Zombie Killer

  • Members
  • 162 posts
  • Location: Welcome to New York City!
  • Minecraft: CribRobber
  • Xbox:Fir3will

Posted 29 October 2013 - 02:47 AM

Your mod depends on FML
FML depends on Forge
Forge depends on MCP
MCP depends on Minecraft releasing de-obf classes

You see where i'm going with this?

Posted ImagePosted Image


If the pen is mightier than the sword, How can actions speak louder than words?  


#13

thomassu
    thomassu

    Mathematical Dessert

  • Members
  • 314 posts
  • Location: The Netherlands
  • Minecraft: Ringco01

Posted 29 October 2013 - 06:30 AM

I have the same waiting problem

Posted Image


#14

delease
    delease

    Tree Puncher

  • Members
  • 26 posts

Posted 29 October 2013 - 12:36 PM

Dont know why i thought this but was under the impression the move from 1.6.4 to 1.7 was supposed to HELP modders update their mods fairly quick

#15

bilde2910
    bilde2910

    Diamond Miner

  • Curse Premium
  • Curse Premium
  • 827 posts
  • Location: Stavern, Norway
  • Minecraft: bilde2910

Posted 29 October 2013 - 04:11 PM

View Postdelease, on 29 October 2013 - 12:36 PM, said:

Dont know why i thought this but was under the impression the move from 1.6.4 to 1.7 was supposed to HELP modders update their mods fairly quick
It has a lot of preparations for the Plugin API, but it hasn't been implemented yet. That'll come in a future update :)

ChatLog is a mod updated for Minecraft 1.7.8.

Click here to check it out: http://bit.ly/clmcmod


(PS. Are you an IRC chatter? You'll love this.)


#16

Konork
    Konork

    Zombie Killer

  • Members
  • 162 posts

Posted 29 October 2013 - 04:24 PM

View Postdelease, on 29 October 2013 - 12:36 PM, said:

Dont know why i thought this but was under the impression the move from 1.6.4 to 1.7 was supposed to HELP modders update their mods fairly quick
And in order to do that, they had to tear up the framework that most modders used. It'll take a while for things to get working with the new framework, but once everything's working again, it'll be smoother for future updates.

#17

chylex
    chylex

    Lapis Lazuli Collector

  • Curse Premium
  • Curse Premium
  • 901 posts
  • Location: Czech Republic
  • Minecraft: chylex

Posted 29 October 2013 - 06:07 PM

View PostFir3will, on 29 October 2013 - 02:47 AM, said:

Your mod depends on FML
FML depends on Forge
Forge depends on MCP
MCP depends on Minecraft releasing de-obf classes

You see where i'm going with this?

MCP doesn't depend on Minecraft releasing de-obfuscated classes, Mojang never released the source code to anybody - not even privately. MCP devs with help of other developers are there to figure out what obfuscated fields and methods mean.
Posted Image
Posted Image

#18

Nieko91
    Nieko91

    Out of the Water

  • Members
  • 3 posts

Posted 29 October 2013 - 07:45 PM

the answer to your question is no the forge has to be updated to match the new code and then the mods you want to use have to be updated as well but there is some hope for you alot of your servers are currently running 1.6.4 and1.7.2 servers like shotbow so not all of your servers are im sure but at least a few(if you have alot like i do) might be running compatibility with both versions so you can just play 1.6.4 for mods and wait till things are updated for 1.7.2

#19

Fir3will
    Fir3will

    Zombie Killer

  • Members
  • 162 posts
  • Location: Welcome to New York City!
  • Minecraft: CribRobber
  • Xbox:Fir3will

Posted 29 October 2013 - 08:47 PM

View Postchylex, on 29 October 2013 - 06:07 PM, said:

MCP doesn't depend on Minecraft releasing de-obfuscated classes, Mojang never released the source code to anybody - not even privately. MCP devs with help of other developers are there to figure out what obfuscated fields and methods mean.

You are 100% Right!

and By the way, love your End Mod! looks amazing!

I'm having a Modgasm! LOL

Posted ImagePosted Image


If the pen is mightier than the sword, How can actions speak louder than words?  


#20

bilde2910
    bilde2910

    Diamond Miner

  • Curse Premium
  • Curse Premium
  • 827 posts
  • Location: Stavern, Norway
  • Minecraft: bilde2910

Posted 29 October 2013 - 09:51 PM

View Postchylex, on 29 October 2013 - 06:07 PM, said:

MCP doesn't depend on Minecraft releasing de-obfuscated classes, Mojang never released the source code to anybody - not even privately. MCP devs with help of other developers are there to figure out what obfuscated fields and methods mean.
True enough - however, they do provide the obfuscation logs, if we're to believe Searge:

Searge (#mcp on EsperNet), on 27 October 2013 - 10:35 AM, said:

12:25 | <Searge> I get obfusction logs from mojang, so I got that covered ;) but thanks for the offer
It helps update faster. It's a good thing.

ChatLog is a mod updated for Minecraft 1.7.8.

Click here to check it out: http://bit.ly/clmcmod


(PS. Are you an IRC chatter? You'll love this.)