Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Unable to install forge


  • Please log in to reply
17 replies to this topic

#1

derek_s
    derek_s

    Tree Puncher

  • Members
  • 27 posts

Posted 18 September 2013 - 06:48 AM

Hello Im trying to download forge and am getting this error message: "These libraries failed to download. Try again. org.scala-lang:scala-library:2.10.2, org.scala-lang:scala-compiler:2.10.2"

I am starting with a vanilla, untouched minecraft folder.  I am attempting to install forge 1.6.2-9.10.0.837, because this is the recommended version for terrafirmacraft (the reason I want forge).

Im downloading this version of forge from here: http://adf.ly/673885...0.0.837.jar.bcf

The download completes and I click the jar when its finished.  cpw.mods.fml.installer.SimpleInstaller launches.  This is the Simple Forge Installer.  Im asked whether I want to install client, install server, or extract.  I choose install client.  The default file location at  /Library/Application Support/minecraft (Im on mac) is correct.

The download begins, the unpacking begins, then I get the error message.  I have checked and both the library and compiler are present in the minecraft folder.

Any help?

Register or log in to remove.

#2

iFicS
    iFicS

    Zombie Killer

  • Members
  • 168 posts
  • Location: Cyberspace

Posted 18 September 2013 - 12:11 PM

View PostRmor85, on 30 July 2013 - 11:54 PM, said:

If anyone is still having problems, this does work. Just download the 2 files maxvick11 posted above.

http://repo1.maven.o...-2.10.2-RC2.jar

http://mvnrepository...rary/2.10.2-RC2

The second link will open to a webpage. Just click on the Download (Jar)

Rename both files. (Just take off the -RC2 at the end of both files)

Click your start button and type %appdata% into search. Open the .minecraft file. Open libraries file. Open org file. Open scala-lang file. So now you should be at file location  AppData\Roaming\.minecraft\libraries\org\scala-lang. Open scala-compiler and then 2.10.2. Copy your renamed compiler file (scala-compiler-2.10.2) to this location. Now back-up twice to the scala-lang file and open
scala-library and 2.10.2. Same thing here. Copy the renamed library file that you downloaded (scala-library-2.10.2) to this location.

Hopefully still the same solution.

Quote

mDiyo: That is my goal. Make a Bacon Mushroom Burger!

#3

derek_s
    derek_s

    Tree Puncher

  • Members
  • 27 posts

Posted 18 September 2013 - 01:54 PM

This is the solution for if my files are missing.  I have those exact 2 files in those exact 2 locations.  I will download anyways and replace my existing files since I have not yet tried that.

Thank you, Ill update my results.


edit: Ive replaced my vanilla .jar's with the downloaded ones and I recieve the same error.

#4

quickfingers307

Posted 18 September 2013 - 02:42 PM

View Postderek_s, on 18 September 2013 - 01:54 PM, said:

This is the solution for if my files are missing.  I have those exact 2 files in those exact 2 locations.  I will download anyways and replace my existing files since I have not yet tried that.

Thank you, Ill update my results.


edit: Ive replaced my vanilla .jar's with the downloaded ones and I recieve the same error.

I am sorry to say but forge installer merely seems to be broke currently. What you posted for how you installed it is exactly how I did it before and it worked... I just now got a new 1.6.2 minecraft and downloaded the installer and it gives me the same error. The installer is just currently broke probably.

Edit: P.S. I'm on mac too so it's the same.
Posted Image

#5

Jon_Decagon
  • Minecraft: Jon_Decagon

Posted 18 September 2013 - 03:22 PM

dont worry! I think the problem is that now you can downlad the client which will install for you! In 1.6.2

#6

madsmile23

Posted 25 September 2013 - 02:06 AM

I have a mac and was running into the same problem, luckily I figured it out.
  • Install the latest java JDK, here is the link. install the macOSX version
  • Save the forge installer to your desktop and rename it to "Forge.jar".
  • open up the terminal.
  • In the terminal type "cd /Users/YOUR_USER_NAME/Desktop" and press enter, YOUR_USER_NAME should be the username of the account your logged into.
  • Then Type "/Library/Java/JavaVirtualMachines/jdk1.7.0_40.jdk/Contents/Home/bin/java -Xmx1G -jar Forge.jar" into the terminal and press enter.
  • Let the installer run and it should install forge corectly without the error.
  • The final step is to enjoy modding the crap out of your minecraft. :D
If you have any problems or questions leave a reply, and i'll try to help.

#7

fezgig
    fezgig

    Out of the Water

  • Members
  • 4 posts

Posted 27 September 2013 - 01:49 AM

Madsmile23, thanks for the steps.

I have followed the steps and am getting the following in my terminal:  internal checksums checksums.sha1 failed validation

I get that message four times and then am presented with the pop-up window:  "These libraries failed to download. Try again. org.scala-lang:scala-library:2.10.2, org.scala-lang:scala-compiler:2.10.2"

Thanks in advance for your help.

#8

Zaphod2011

Posted 28 September 2013 - 06:39 AM

I'm on a Windows machine and am receiving the same errors.

I just grabbed the latest build of Forge (828) and it does the same thing...

#9

The Pro Legacy
  • Minecraft: keylan118

Posted 02 October 2013 - 02:43 AM

What about installing the universal version?
Posted Image

Posted Image


#10

Zaphod2011

Posted 03 October 2013 - 07:32 PM

This latest version (916) seems to have fixed things (for me, anyway) :)

#11

JungleWoodPlanks

Posted 04 October 2013 - 05:55 AM

View Postderek_s, on 18 September 2013 - 06:48 AM, said:

Hello Im trying to download forge and am getting this error message: "These libraries failed to download. Try again. org.scala-lang:scala-library:2.10.2, org.scala-lang:scala-compiler:2.10.2"

I am starting with a vanilla, untouched minecraft folder.  I am attempting to install forge 1.6.2-9.10.0.837, because this is the recommended version for terrafirmacraft (the reason I want forge).

Im downloading this version of forge from here: http://adf.ly/673885...0.0.837.jar.bcf

The download completes and I click the jar when its finished.  cpw.mods.fml.installer.SimpleInstaller launches.  This is the Simple Forge Installer.  Im asked whether I want to install client, install server, or extract.  I choose install client.  The default file location at  /Library/Application Support/minecraft (Im on mac) is correct.

The download begins, the unpacking begins, then I get the error message.  I have checked and both the library and compiler are present in the minecraft folder.

Any help?
Go search forge in your browser and find the forge main page with all the downloads.
Then find the version you want to install forge on to and select the "Installer" and download that.
Now run the installer and forge will be installed.

#12

TurtleSoupSucks
  • Minecraft: rikoban

Posted 29 October 2013 - 09:31 AM

I'm getting a problem too, it just... stays.... Stuck... Unpacking scala xz.. Forver...
All my hopes, dreams, inpired thoughts.... PERISHED.
Posted Image
Help him grow! But don't kill him!
Posted Image
Help him, too!

#13

DigDaBlock

Posted 31 October 2013 - 02:59 AM



Helped me on Win7, read the description.

#14

hazysrainboom

Posted 24 November 2013 - 02:28 AM

View PostJungleWoodPlanks, on 04 October 2013 - 05:55 AM, said:

Go search forge in your browser and find the forge main page with all the downloads.
Then find the version you want to install forge on to and select the "Installer" and download that.
Now run the installer and forge will be installed.

Um, NO, I used the installer. It's not the answer to everything. The same thing happened.

#15

MO-SWAG760

Posted 13 December 2013 - 01:07 AM

Can someone help me forge stops at unpacking packages and stops!

#16

Flamecraftsaber

Posted 22 December 2013 - 06:13 PM

I'm on windows, i got a message saying that forge was installed correctly. But When i check the .minecraft files... theres nothing :o
Forge probably Is broken or something... (the installer) However i figured to solve it Posted Image Posted Image Posted Image Posted Image Posted Image Posted Image  This link to the download should help: Posted Image DOWNLOADPosted Image                    

                                                            If you DO get it installed :D some mods may require a version of forge higher then 9.10.0.837
Posted Image                       :D :D :D : D

                             If it does/the link between the /LOL/ notch faces, WILL help :DPosted Image

#17

IthinkIneedhelp

Posted 18 January 2014 - 11:49 AM

View Postmadsmile23, on 25 September 2013 - 02:06 AM, said:

I have a mac and was running into the same problem, luckily I figured it out.
  • Install the latest java JDK, here is the link. install the macOSX version

  • Save the forge installer to your desktop and rename it to "Forge.jar".

  • open up the terminal.

  • In the terminal type "cd /Users/YOUR_USER_NAME/Desktop" and press enter, YOUR_USER_NAME should be the username of the account your logged into.

  • Then Type "/Library/Java/JavaVirtualMachines/jdk1.7.0_40.jdk/Contents/Home/bin/java -Xmx1G -jar Forge.jar" into the terminal and press enter.

  • Let the installer run and it should install forge corectly without the error.

  • The final step is to enjoy modding the crap out of your minecraft. Posted Image
If you have any problems or questions leave a reply, and i'll try to help.

What do you mean by terminal? If it is something for mac, can you please tell me in windows 7 words.

#18

melodytamer

Posted 11 February 2014 - 05:03 AM

i also have this problem except i have windows 7. i already downloaded it but i accidentally deleted. i tried to re-download it but it says "you need to run 1.6.2 manually at least once". i did that but i still got the same problem. can someone help one me please!!