Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Biomes O' Plenty Fails to Generate Biomes on Multiplayer Server


  • Please log in to reply
15 replies to this topic

#1

LeoOfVinci
  • Minecraft: LeoDerVinci

Posted 03 September 2013 - 10:23 PM

Hello

Okay, I've seen a lot of posts with this error, but I can never find any solutions. I can't seem to get Biomes O' Plenty to work on a server at all. It works fine in single player, but in multiplayer, none of the biomes generate, as it just generates vanilla biomes, and when I try to spawn mod items in creative, they don't work and disappear. I have done every single thing that it has said to do. I've changed level-type to BIOMESOP, set add biomes to default world to true, added the forge files to Minecraft.jar, but nothing has worked. I am on a mac, using the latest version of Biomes O' Plenty, and currently using Minecraft forge 0.842. My server properties are listed below:

#Minecraft server properties
#Sun Aug 25 12:57:38 CDT 2013
generator-settings=
op-permission-level=4
allow-nether=true
level-name=world
enable-query=false
allow-flight=false
server-port=25567
level-type=BIOMESOP
enable-rcon=false
force-gamemode=false
level-seed=
server-ip=*************
max-build-height=256
spawn-npcs=true
white-list=false
spawn-animals=true
hardcore=false
snooper-enabled=true
texture-pack=
online-mode=true
pvp=true
difficulty=1
gamemode=0
max-players=20
spawn-monsters=true
view-distance=10
generate-structures=true
spawn-protection=16
motd=A Minecraft Server

Is there something that I'm not doing? Please post any solutions and I thank you for any help.

Register or log in to remove.

#2

Herdo
    Herdo

    Tree Puncher

  • Members
  • 30 posts

Posted 04 September 2013 - 12:37 AM

Try deleting the "world" folder and regenerating the world.  This happens a lot to me and it's because I usually generate the server at least once before actually getting the mod installed.

Leave everything else, just delete the world folder.  Assuming you are starting a fresh server that is.  If that doesn't work, set add biomes to default world to false and delete the world folder and regenerate the world again.

#3

LeoOfVinci
  • Minecraft: LeoDerVinci

Posted 04 September 2013 - 01:13 AM

View PostHerdo, on 04 September 2013 - 12:37 AM, said:

Try deleting the "world" folder and regenerating the world.  This happens a lot to me and it's because I usually generate the server at least once before actually getting the mod installed.

Leave everything else, just delete the world folder.  Assuming you are starting a fresh server that is.  If that doesn't work, set add biomes to default world to false and delete the world folder and regenerate the world again.
I tried doing all of that and still no luck :(

#4

Herdo
    Herdo

    Tree Puncher

  • Members
  • 30 posts

Posted 04 September 2013 - 02:19 AM

Hmm.  You have Biomes O Plenty installed server side as well, right?  Are you running a mod pack like FTB?

#5

LeoOfVinci
  • Minecraft: LeoDerVinci

Posted 04 September 2013 - 09:49 PM

View PostHerdo, on 04 September 2013 - 02:19 AM, said:

Hmm.  You have Biomes O Plenty installed server side as well, right?  Are you running a mod pack like FTB?
By server side, do you mean like a folder named mods in my server folder with Biomes O' Plenty in it? Also, I'm not currently running FTB.

#6

Flenix
    Flenix

    Lapis Lazuli Collector

  • Curse Premium
  • Curse Premium
  • 1075 posts
  • Location: Northampton, UK
  • Minecraft: Flenix
  • Xbox:Flenix

Posted 05 September 2013 - 11:59 AM

View PostLeoOfVinci, on 04 September 2013 - 09:49 PM, said:

By server side, do you mean like a folder named mods in my server folder with Biomes O' Plenty in it? Also, I'm not currently running FTB.

That's what he means, yes. Can you launch the server and post your startup log please?

Posted Image
Posted Image Posted Image Paving the way to a better world! Posted Image Posted Image


#7

LeoOfVinci
  • Minecraft: LeoDerVinci

Posted 06 September 2013 - 12:24 AM

Ok, I created a folder named mods and put Biomes O' Plenty in it. I deleted the world and generated a new one, started the server, and it didn't work. Here's the Multiplayer Server log:

Posted Image

Is there anything specific that I had to do?

#8

RustyXXL
    RustyXXL

    Obsidian Miner

  • Members
  • 1262 posts
  • Location: Germany
  • Minecraft: RustyXXL

Posted 06 September 2013 - 08:55 PM

depending on your bop version you might have to set
B:"Add Biomes To Default World"=true
in your servers bop config (and then recreate the world...)

#9

Ouack23
    Ouack23

    Carpenter

  • Members
  • 59 posts

Posted 06 September 2013 - 08:58 PM

If you want to use mods on your server, you for sure should use MCPC+ or BukkitForge (I recommend MCPC).
There will be a mods folder in your server, copy and paste whatever you want, all done :)

#10

LeoOfVinci
  • Minecraft: LeoDerVinci

Posted 06 September 2013 - 09:32 PM

View PostRustyXXL, on 06 September 2013 - 08:55 PM, said:

depending on your bop version you might have to set
B:"Add Biomes To Default World"=true
in your servers bop config (and then recreate the world...)
Where do I find the config for BoP in the server folder? I know where it is in the minecraft folder.

#11

RustyXXL
    RustyXXL

    Obsidian Miner

  • Members
  • 1262 posts
  • Location: Germany
  • Minecraft: RustyXXL

Posted 07 September 2013 - 08:09 AM

If you installed everything correctly you should have a configs directory with said config in it...

#12

Csipesz
    Csipesz

    Out of the Water

  • Members
  • 3 posts

Posted 29 September 2013 - 05:29 PM

OR ACTUALLY is there a server-side BoP thing that I need to install or what?

#13

Normalius
  • Location: EU, HUN
  • Minecraft: Normal69

Posted 01 November 2013 - 02:30 PM

View PostLeoOfVinci, on 06 September 2013 - 09:32 PM, said:

Where do I find the config for BoP in the server folder? I know where it is in the minecraft folder.

Server/config/biomesoplenty/terraingen.cfg - if you are in trouble, use search. :D

#14

GusarTranzit

Posted 01 November 2013 - 02:50 PM

I think you are launching vanilla server actually

try launching that other .jar named

MinecraftForge-universal-..............jar

Given you actualy installed forge on server too. And mods ofcourse...
There was a link here pointing to a certain topic on this forum
about testing a proof of concept
mods of the forum told me that is against the rules to promote this forums topics
But it is ok to put a link to some other web page

#15

itsaminatahsin1
  • Minecraft: itsaminatahsin1

Posted 01 March 2014 - 03:47 AM

where can I download 1.6.2 cuz there only 1.7.2 in the download link theres no 1.6.x

#16

Zedjones
    Zedjones

    Out of the Water

  • Members
  • 4 posts

Posted 17 March 2014 - 01:24 AM

Change generator-settings to BIOMESOP