Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Minecraft Server "You need to log in!"


  • Please log in to reply
27 replies to this topic

#1

koufu
    koufu

    Carpenter

  • Members
  • 44 posts

Posted 20 September 2009 - 10:37 PM

Hello everyone.

I'm having a problem setting up my minecraft server. Every time I try to join my own server,
I get the error "Connection lost You need to log in!" I have seen others successfully join (via the
console), but cannot join myself. (Others on my network cannot either.)

Ports are forwarded correctly, and with the same setup it used to work (about 2-3 weeks ago I think.)
My operating system is Windows Vista, with a dlink 802.11g router. Tried firewall on and off, and even
tried using it without the router in between, and still had the same error. Tried changing verify names to false,
changing the port number multiple times, and changing server name. Tried downloading the latest minecraft-server
off of minecraft.net to see if perhaps something changed. I still have the same error.

Does anyone know how to fix this?

Thanks.

Register or log in to remove.

#2

Skittles

Posted 20 September 2009 - 10:48 PM

Are you logged in?
Riveting Tale, Chap

#3

citricsquid
  • Location: Stafford, England
  • Minecraft: citricsquid
  • Xbox:citricsquid

Posted 20 September 2009 - 10:55 PM

Minecraft login is verified via cookies, the username and password are embeded in the HTML for the applet the applet then verifies they're correct. If you don't have the parameters passed to minecraft then you can't play, I assume by downloading the game the parameters are not being passed therefore it assumes no login.

#4

koufu
    koufu

    Carpenter

  • Members
  • 44 posts

Posted 21 September 2009 - 12:49 AM

I've tried it both with a downloaded client and the one on minecraft.net.

#5

LG_Legacy
    LG_Legacy

    Glowstone Miner

  • Members
  • 3718 posts

Posted 21 September 2009 - 07:30 AM

Have you tried all clients? They should work, if not i don't think your java is working correctly. Try reinstalling?
#Minecraft ChanOp
#MinecraftHelp ChanOp
#SMP Channel Founder/Owner
#Archives ChanOp

#6

ewingod
    ewingod

    Newly Spawned

  • Members
  • 1 posts

Posted 25 September 2010 - 06:35 PM

Did you figure out what happened?

I installed server on a mac, was able to connect via the download client.  Installed server on a Windows Vista, tried the same thing and now my mac won't connect. Server logs say I'm not logged in.  Mac fights Windows.. boo

#7

xhaque
    xhaque

    Out of the Water

  • Members
  • 4 posts

Posted 26 September 2010 - 09:35 PM

I am having this same problem. Hosted server, people can connect from outside my ip, but when I try to connect the console reads: Kicking /myip: You need to log in!

#8

Fushnigeddy

Posted 16 October 2010 - 03:59 PM

Seems like Vista may be the common element here, I'm having the same issue. Tried right-clicking on the .exe and running it as Administrator too, same result :P

#9

RAW-BERRY

Posted 16 October 2010 - 04:18 PM

Having the same issue. Also on Vista. I think we've found or common denominator.

However, I can connect via the web version.

#10

RAW-BERRY

Posted 16 October 2010 - 04:48 PM

http://minecraft.net/download.jsp
Found out we need different software. Go there and download the software at the bottom of the page. Worked for me.

#11

S0M3ONE
    S0M3ONE

    Carpenter

  • Members
  • 67 posts
  • Location: USA
  • Minecraft: S0M3ONE

Posted 17 November 2010 - 02:27 AM

I need help with this too! Please help!

Posted Image

Unknown said:

Potatoes are like humans. When you eat them they die.

#12

TyrannosaurusHax

Posted 29 January 2011 - 07:43 AM

RAW-BERRY said:

http://minecraft.net/download.jsp
Found out we need different software. Go there and download the software at the bottom of the page. Worked for me.

I had the same problem with minecraft-server.jar, both local and remote connections crashing the game client and spitting out "Kicking /(IP): You need to log in!"

So I got things going with Minecraft_Server.exe and had no problems...until I got others to connect.
Every time they do my ROUTER CRASHES. I've wasted more time than I care to admit trying to figure out why or what I can do about it. Anyone else have this problem / know a solution?
Thanks

#13

capnjax
    capnjax

    Out of the Water

  • Members
  • 5 posts

Posted 30 March 2011 - 04:31 AM

Hey, I am having this trouble as well. I am running Windows 7. I have tried everything. No matter what I do every time I try to connect to my own server it gives me this message "You need to log in!" and kicks me out, which crashes Minecraft. It happens whether I try to run it as the .exe or through the browser. I've seen this issue on a lot of random forums, including other Minecraft forums, but there never seems to be any conclusive solution to the problem. Has anyone who posted here previous had this problem fixed? Any info would be greatly appreciate.

#14

capnjax
    capnjax

    Out of the Water

  • Members
  • 5 posts

Posted 30 March 2011 - 02:29 PM

Please, someone help me with this. I'm trying to set up a private server for me and my friends, but I can't even log in to it. They're waiting to make sure we can play together before they purchase the game, so it would be really great if I could get this working. Thanks.

#15

capnjax
    capnjax

    Out of the Water

  • Members
  • 5 posts

Posted 31 March 2011 - 04:04 AM

Please. Look at the number of people that have VIEWED this topic. Obviously it's a huge issue. And still no solution? Please, someone has to know how to fix this problem.

#16

soapboxher0

Posted 31 March 2011 - 10:58 PM

Let me jump on the bandwagon of unable to log in to my localhost game. I am on win 7 also.  A buddy had no problem but he was running windows 2000.

#17

tman3806
    tman3806

    Out of the Water

  • Members
  • 9 posts

Posted 02 April 2011 - 06:41 PM

I'm on Windows 7 having this problem, my friend on XP can run the server software though.
Posted ImagePosted ImagePosted ImagePosted ImagePosted Image

#18

PsychoEmu

Posted 07 April 2011 - 05:30 PM

Is the common theme here that we are all using mods??? maybe we need to do it on an un-modded minecraft for it to run (just what a friend said today)


Just tried this, complete reinstall, and the answer is nope, and friends are not able to connect either, we all get as far as "logging in" before out clients crash. anybody any ideas as to what do>?

#19

Gurkmajonaise

Posted 09 April 2011 - 11:39 AM

what is html??

#20

sowel
    sowel

    Zombie Killer

  • Members
  • 205 posts

Posted 09 April 2011 - 12:25 PM

have you tryed running server in off line mode?
people can still connect but it dont try to authenticate there minecraft account.