Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Problems with 1.6.2 Magic Launcher and Forge


  • Please log in to reply
20 replies to this topic

#1

JLC5087
    JLC5087

    Diamond Miner

  • Members
  • 819 posts
  • Minecraft: JLC5087

Posted 14 July 2013 - 09:04 PM

I received this error log when I started minecraft through Magic Launcher. It started before without the More Swords Mod but I just really don't get how to get mods. 1.6.2 really p***es me off and I REALLY need help with this. So, the mods I'm using is Minecraft Forge, Optifine, TooManyItems, Rei's Minimap and the MoreSwords. I really don't know how to get this configured and it's really stressing me out. So, if anyone could tell me how I could fix this, I'd really appreciate it.

---- Minecraft Crash Report ----
// I blame Dinnerbone.

Time: 7/14/13 4:55 PM
Description: Exception in server tick loop

java.lang.NullPointerException
at net.minecraft.server.MinecraftServer.c(SourceFile:800)
at bkw.a(IntegratedServer.java:115)
at bkw.d(IntegratedServer.java:139)
at net.minecraft.server.MinecraftServer.run(SourceFile:314)
at hh.run(SourceFile:582)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- System Details --
Details:
Minecraft Version: 1.6.2
Operating System: Windows 7 (amd64) version 6.1
Java Version: 1.7.0_09, Oracle Corporation
Java VM Version: Java HotSpot™ 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 422157144 bytes (402 MB) / 465764352 bytes (444 MB) up to 477233152 bytes (455 MB)
JVM Flags: 2 total; -Xms512m -Xmx512m
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
Suspicious classes: IWrUpdater, Config, WrUpdaterSmooth, ...[cpw.mods.fml.client.FMLClientHandler, CustomModLoadingErrorDisplayException, GuiWrongMinecraft, ...], [cpw.mods.fml.client.registry.ISimpleBlockRenderingHandler, RenderingRegistry], [cpw.mods.fml.common.LoaderException, FMLCommonHandler, TickType, ...], [cpw.mods.fml.common.modloader.BaseModProxy], [cpw.mods.fml.common.network.FMLPacket, ModMissingPacket, EntitySpawnPacket, ...], [cpw.mods.fml.common.registry.EntityRegistration], [cpw.mods.fml.common.toposort.ModSortingException], [cpw.mods.fml.relauncher.Side], [net.minecraftforge.client.ForgeHooksClient, ItemRenderType, IItemRenderer, ...], [net.minecraftforge.client.event.DrawBlockHighlightEvent, RenderWorldLastEvent, TextureStitchEvent, ...], [net.minecraftforge.common.MinecraftForge, ForgeInternalHandler, ForgeHooks, ...], [net.minecraftforge.event.EventBus, IEventListener, ListenerList, ...], [net.minecraftforge.event.entity.EntityEvent], [net.minecraftforge.event.entity.item.ItemEvent, ItemTossEvent], [net.minecraftforge.event.entity.living.LivingEvent, LivingHurtEvent, LivingFallEvent, ...], [net.minecraftforge.event.world.WorldEvent, Load, Unload, ...], [net.minecraftforge.fluids.FluidRegistry, FluidRegisterEvent, Fluid, ...], [reifnsk.minimap.ReiMinimap, WaypointEntity, MinimapException, ...]
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
Profiler Position: N/A (disabled)
Player Count: 0 / 8; []
Type: Integrated Server (map_client.txt)
Is Modded: Very likely; Jar signature invalidated
Posted Image

Register or log in to remove.

#2

drakola15975342456545

Posted 15 July 2013 - 06:14 PM

Where did you get more swords mod for 1.6.2 it's not updated yet.

#3

JLC5087
    JLC5087

    Diamond Miner

  • Members
  • 819 posts
  • Minecraft: JLC5087

Posted 15 July 2013 - 06:40 PM

View Postdrakola15975342456545, on 15 July 2013 - 06:14 PM, said:

Where did you get more swords mod for 1.6.2 it's not updated yet.
O.O What do you mean... it is. I got it straight from the forums, well technically a link lead me to his website where he had the downloads.
Posted Image

#4

novafan678

Posted 16 July 2013 - 02:04 AM

the reason its not working is because u have optifine with forge forge is not compatible with optifine

#5

JLC5087
    JLC5087

    Diamond Miner

  • Members
  • 819 posts
  • Minecraft: JLC5087

Posted 16 July 2013 - 12:34 PM

View Postnovafan678, on 16 July 2013 - 02:04 AM, said:

the reason its not working is because u have optifine with forge forge is not compatible with optifine
OH! Well actually it's working now. I don't know, I must have REALLY messed something up in my folders or something. Either way, I got Optifine and Forge.
Posted Image

#6

SteveGad
  • Location: Mansfield UK
  • Minecraft: SteveGad

Posted 17 July 2013 - 08:43 PM

View Postnovafan678, on 16 July 2013 - 02:04 AM, said:

the reason its not working is because u have optifine with forge forge is not compatible with optifine

I've run forge with Optifine, in fact a thread somewhere advises putting forge at the top and Optifine at the bottom. No Matter. I too am having MASSIVE probs with magic Launcher and Forge. No Mods folder (yes I made one, no joy) and Mods not working. I'm normally the type who figures stuff out and have never had problems before 1.61 but I am seriously (since day 1.6 came out) fed up of tweaking, reinstalling and tinkering, in fact half an inch from just saying to hell with Minecraft. Yes, I really AM that angry with stuff not working.

#7

JLC5087
    JLC5087

    Diamond Miner

  • Members
  • 819 posts
  • Minecraft: JLC5087

Posted 18 July 2013 - 01:31 AM

View PostSteveGad, on 17 July 2013 - 08:43 PM, said:

I've run forge with Optifine, in fact a thread somewhere advises putting forge at the top and Optifine at the bottom. No Matter. I too am having MASSIVE probs with magic Launcher and Forge. No Mods folder (yes I made one, no joy) and Mods not working. I'm normally the type who figures stuff out and have never had problems before 1.61 but I am seriously (since day 1.6 came out) fed up of tweaking, reinstalling and tinkering, in fact half an inch from just saying to hell with Minecraft. Yes, I really AM that angry with stuff not working.
Well hey, I got the modded version working. I will say though that it won't be the same with Magic Launcher. With 1.2.5 I was able to have 25 MODS! With a bit of complications, but that was later when I kept tinkering around, but before it, it ran fine. With 1.3.2 I was limited to like 4. With 1.5.2 I thought I could get quite a few mods too, I had about 6 but two different configurations thanks to the Magic Launcher update. Now I'm not sure if I can get those 5-6 mods again. I'm also not sure which mod authors can GET their mods updated. -sigh- I think this change was a little too much but I'm slowly getting used to it.
Posted Image

#8

ZacIsCool67456
  • Location: Y=-1235 with Bartex2x cubic chunks mod

Posted 25 July 2013 - 06:57 PM

View PostSteveGad, on 17 July 2013 - 08:43 PM, said:

I've run forge with Optifine, in fact a thread somewhere advises putting forge at the top and Optifine at the bottom. No Matter. I too am having MASSIVE probs with magic Launcher and Forge. No Mods folder (yes I made one, no joy) and Mods not working. I'm normally the type who figures stuff out and have never had problems before 1.61 but I am seriously (since day 1.6 came out) fed up of tweaking, reinstalling and tinkering, in fact half an inch from just saying to hell with Minecraft. Yes, I really AM that angry with stuff not working.
God Im exactly the same! This is like the first time I couldn't fix a mod problem. Magic launcher is great, but it seams to not really work right for 1.6.2. As of now Im afraid the old ways might be best.

Posted Image


#9

ZacIsCool67456
  • Location: Y=-1235 with Bartex2x cubic chunks mod

Posted 25 July 2013 - 07:03 PM

View PostJLC5087, on 18 July 2013 - 01:31 AM, said:

Well hey, I got the modded version working. I will say though that it won't be the same with Magic Launcher. With 1.2.5 I was able to have 25 MODS! With a bit of complications, but that was later when I kept tinkering around, but before it, it ran fine. With 1.3.2 I was limited to like 4. With 1.5.2 I thought I could get quite a few mods too, I had about 6 but two different configurations thanks to the Magic Launcher update. Now I'm not sure if I can get those 5-6 mods again. I'm also not sure which mod authors can GET their mods updated. -sigh- I think this change was a little too much but I'm slowly getting used to it.
Thats like nothing. With i.2.5 I got like 50 mods, I never used 1.3 'cause its crap and there weren't enough mods updated. With 1.4.7 I got like 40, 1.5.2 I stopped playing for a bit and than caught up with about 20 mods, but now I can get like one. In early 1.2.5 I couldn't get very many because forge was just merging in mod loader and was very glitchy, so like no forge mods were compatible. But than forge got better, as did my problem solving skills, and I had more mods than like anyone. I swear there is no mod I have never heard of that was made 1.2.5 or earlier. I have totally mastered installing them via magic launcher, until now.

Posted Image


#10

BadLeo_
    BadLeo_

    Tree Puncher

  • Members
  • 17 posts

Posted 01 August 2013 - 03:00 AM

Same to me... In 1.4.7 I had a bunch of mods running smoothly with forge and optifine through magiclauncher (not without some effort to make things work nicely). Now, with 1.6.2, my magiclauncher dont seem to load anyone of the mods, even though the setup screen is still ok. I guess I'll try to put the mods inside minecraft.jar or maybe I'll change back to the 1.4.7 until magiclauncher is working fine with the new version of the game...
Damn you, Minecraft. Now I look at real buildings and wander how many blocks it took to be built...

#11

BadLeo_
    BadLeo_

    Tree Puncher

  • Members
  • 17 posts

Posted 01 August 2013 - 02:24 PM

Found a solution! http://www.planetmin...ctions-working/

"START here to REBUILD the ENTIRE DIRECTORY-
1. cut/paste '.minecraft' folder to "C:" for backup

2. downloaded Magic Launcher 1.1.7

3. run magic launcher once from the download folder and it will create a new  '.minecraft' folder in the %appdata% directory. close program. the ".minecraft" folder now has been re-created and only contains a 'magic' folder. the magic folder is empty.

4. copy the "lastlogin" file from your ".minecraft" folder backup and place it into your new %appdata% '.minecraft' folder. copy minecraft.exe from your ."minecraft" folder backup and place it in your new %appdata% '.minecraft' folder and run it.

5. Force update. your login information will already be filled in. launch the game client Minecraft.exe that came with the force update. not the official launcher.

On my machine the mojang screen hangs and never loads. this is ok. we are just making prgram files. you only need to see the Mojang title screen then force close if it hangs.
    -(ctrl+alt+delete)
     -in task manager click 'processes' tab and EndTask the java process thats using about 3-600mb memory.

6. open the 'MineCraft.exe' from the %appdata% folder and download the new official game launcher and replace your game client with it. the new minecraft client file should be about 400kb and the old one your replacing is about 250kb.

7. Run the new 'minecraft.exe' from the %appdata% folder and you will get the console to load up. On my system a loading bar apears at the bottom of the console and takes about a min. I let it load then I loaded the game once.
version 1.6.2 loads up. close program.

8. Run 'magic launcher1.1.7' and click the 'Setup' tab and at the top of the magic launcher under 'envronment' you can now choose to use v1.6.2 MC

9. now click the 'advanced' tab next to the 'Mods' tab and change your memory size from 512mb to 1024mb.
NOTE: unless you know better for yourself, you do not need more then 1024mb memory here unless you use beyond normal view distances or texture packs larger then 128x.

*choose to high a memory size, the game will leg.
*choose to high a memory size, the game will crash.
   -recomended sizes for you:
*if you have 3gb ram choose 1024mb
*if you have 4gb ram choose 1024mb-1536mb
*if you have 6gb+ ram choose 2048mb-4096mb

((Now I am going to attempt to install forge/optifine and some mods.))

10. Download Forge
http://files.minecraftforge.net/

11. Run the minecraftforge-installer-1.6.2-9.10.0.***.jar by clicking on it. (latest version)
choose client install. the directory provided is your default %appdata% .minecraft folder path and does not need to be edited.

12. run the official game client once and choose the forge profile. click on edit profile and change the settings to your liking. leave the 'JVM' box unchecked and launch the game once. close minecraft. forge should have loaded up correctly with 3 mods loaded.

    ((now we need Optifine- methed uses magic launcher))
No magic launcher? Get it regardless. your going to need it to load mods on a forge profile. you can not edit the forge modified JAR file anymore. Mods have to be loaded externally when using forge.

13. Downloaded OptiFine_1.6.2_HD_U_A1.zip or A2. copy to the 'Magic folder' (or latest version)

14. Run the magic launcher and click on the 'Setup' TAB. under 'Environment' at the top choose the forge environment.

15. Add optifine by clicking on the 'ADD' tab

16. Click on the 'advanced' TAB and in the 'parameters' box type in this-
“-Dfml.ignorePatchDiscrepancies=true”

17. Run the game.
    -forge will load up with minecraft showing 3 active mods and optifine A1 or A2 Launched with Magic Launcher

....to add future mods, add forge mods to the mods folder. If the mod does not require forge but wants modloader, you can add it to the magic folder and add it in the magic launcher.

NOTE: A mod added with magic launcher that requires ModLoader will caution you in red lettering "No ModLoader". Ignore this. Forge has a built in mod loader and manages the issue automatically.
(do not put the same mods in both folders)"
Damn you, Minecraft. Now I look at real buildings and wander how many blocks it took to be built...

#12

cheatfreak25
  • Location: In a room, sitting in a chair, looking at my computer

Posted 02 August 2013 - 02:22 AM

You guys are lucky. I cant even get a crash report when I tried to use Forge and Magic Launcher. In fact, I cant even get into my worlds because it stops on 'Converting World' and doesnt do anything else.

#13

vinster7
  • Location: Cheeseburger
  • Minecraft: vinnie8

Posted 03 August 2013 - 08:11 PM

Forge and magic launcher stopped working for me randomly in 1.5.2 and 1.6.2. 1.5.2 worked, but now NOTHING works actually.
I live on Mars.

#14

JLC5087
    JLC5087

    Diamond Miner

  • Members
  • 819 posts
  • Minecraft: JLC5087

Posted 03 August 2013 - 11:54 PM

Hmmm... Well my 1.6.2 is running fine now, I think it wasn't working because I screwed up with the .jar files because at first it wasn't working, no idea why but it's all good for me. I know how to install it properly now! :D
Posted Image

#15

HeliosJack

Posted 04 August 2013 - 04:10 AM

4. copy the "lastlogin" file from your ".minecraft" folder backup and place it into your new %appdata% '.minecraft' folder. copy minecraft.exe from your ."minecraft" folder backup and place it in your new %appdata% '.minecraft' folder and run it.

//end quote

I have no minecraft.exe in my .minecraft folder

#16

BadLeo_
    BadLeo_

    Tree Puncher

  • Members
  • 17 posts

Posted 04 August 2013 - 01:23 PM

View PostHeliosJack, on 04 August 2013 - 04:10 AM, said:

4. copy the "lastlogin" file from your ".minecraft" folder backup and place it into your new %appdata% '.minecraft' folder. copy minecraft.exe from your ."minecraft" folder backup and place it in your new %appdata% '.minecraft' folder and run it.

//end quote

I have no minecraft.exe in my .minecraft folder

minecraft.exe is on "minecraft launcher" folder.
Damn you, Minecraft. Now I look at real buildings and wander how many blocks it took to be built...

#17

craftwe33

Posted 11 August 2013 - 11:43 PM

hey i was  haveing a good time tell magic launcher stoped working but when i went to my friends house with my computer it started to work i got back home then it stoped working WTF

#18

PhilliesFanatic

Posted 14 August 2013 - 02:50 PM

my forge doesnt even run it says ok in it but it never runs

#19

JLC5087
    JLC5087

    Diamond Miner

  • Members
  • 819 posts
  • Minecraft: JLC5087

Posted 15 August 2013 - 01:29 AM

View PostPhilliesFanatic, on 14 August 2013 - 02:50 PM, said:

my forge doesnt even run it says ok in it but it never runs
Did you install the Forge Installer? If not, you need to...
Posted Image

#20

phuongmychi

Posted 16 August 2013 - 01:31 AM

http://www.9minecraf...-launcher-tool/