Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

"Could not find the main class."


  • Please log in to reply
9 replies to this topic

#1

PhantomSkyfire

Posted 01 March 2011 - 07:59 AM

First post on the forums, and surprise surprise: it's a "lol eet doesnt wurk!" thread! I'd use search, but...

Posted Image

Well, y'know.

Every now and then when I try to launch Minecraft I get this nonsense: "Could not find the main class. net.minecraft.launcherframe The application will now close," or something to that effect. Had to recreate it from memory since the thing decided it'd be a fun prank to work right when I'm trying to get help. Sometimes the program works absolutely peachy, and when I do run into the error trying two or three more times makes it shape up and behave.

Google tells me this problem is somewhat confined to Linux systems, so I'm supposing that I couldn't be getting this on Windows 7? I have the latest Java.

LAST SECOND ADDITION: Here's the error.

Posted Image

Register or log in to remove.

#2

okal
    okal

    Glowstone Miner

  • Curse Premium
  • Curse Premium
  • 3497 posts
  • Location: UK

Posted 01 March 2011 - 09:08 AM

The search error is because you have to be logged in to search, not great :|

You get that on Linux systems when the path is incorrect and/or it can't find the correct .jar file.
If it is intermittent it is probably your Anti-virus scanning the file when the launcher is trying to open it, so add an exception for it. (The minecraft files are in %appdata%\.minecraft)

#3

PhantomSkyfire

Posted 01 March 2011 - 04:00 PM

epikal said:

You get that on Linux systems when
Like I said, I have Windows 7.

epikal said:

If it is intermittent it is probably your Anti-virus scanning the file when the launcher is trying to open it, so add an exception for it.
I have no formal antivirus. Closest thing I have are the "Microsoft Security Essentials" and turning them off didn't change the situation.

#4

d1miguel
    d1miguel

    Newly Spawned

  • Members
  • 1 posts

Posted 02 March 2011 - 04:05 AM

This SAME exact problem happens to me. I figure it's because I ran the Minecraft launcher from a .RAR file the very first time I launched it. Whenever I run it from the original RAR file I launch it in, the error doesn't appear. I'm not sure how to get it to go away, but thankfully it starts working after a few clicks. That's the weird part. Any thoughts?

#5

Strata101

Posted 02 March 2011 - 08:57 AM

According to haspaid neither you or d1miguel have bought the game...

http://www.minecraft...p?user=d1miguel
http://www.minecraft...=PhantomSkyfire

This being the case it would be because you are running pirated versions of the game.

#6

Shadowsedge

Posted 06 April 2011 - 02:36 AM

what about me?  I got a "true" when I put my name in but I get the same message when I try to start minecraft.  also, my name to the left, that is not my log in but it is my name on these forums.  maybe the previous 2 paid for minecraft but have a different forum name, like I do?  so please do not yell "pirate" before you have all the facts.

back to the question, why does it happen?  every time I click on minecraft, it pops up on the 1st try but on the 2nd try, minecraft works.  annoying but still, why?  I would like to get rid of the message all together.  I click on it from my desktop btw.

#7

tiddlytoes

Posted 21 October 2011 - 01:53 PM

i am having the same plroblem and you can check my name to see i am no pirate,

i am running windows 7 64 bit and i thought i had figured it out but now im getting this when i try to run it.


please help

#8

Dj_777
    Dj_777

    Iron Miner

  • Members
  • 319 posts
  • Location: Riding behind my unstoppable Railcraft Tunnel Bore.
  • Minecraft: Dj_777

Posted 05 March 2012 - 07:04 AM

I now get this error every time I try to open minecraft...  I can't figure out why, I got a 'Saving Chunks' error from pulling out a map in survival island, and then minecraft will not open again...

Edit:

Ran error test:

===Simple Minecraft Error Test===
Starting Minecraft...
'java' is not recognized as an internal or external command,
operable program or batch file.
Finished session

Right click, Select all,
Press Enter (This will copy the output to your clipboard).
Then paste the result on http://www.pastebin.com
===========#Risucraft===========
Press any key to continue . . .

Not sure what it is trying to say, Java is working perfectly for every other non-minecraft thing...
Posted Image

#9

_Ulven_
    _Ulven_

    Out of the Water

  • Members
  • 3 posts

Posted 30 April 2012 - 06:15 PM

Getting the same message as OP when trying to start the game from the minecraft.jar file after downloading the new snapshot from here.

The server one seems to work fine, but I get this message as soon as I double-click the client jar file. Using W7 64-bit.

Anyone know what the cause is?

#10

bolonix
    bolonix

    Out of the Water

  • Members
  • 6 posts
  • Minecraft: Nixsy

Posted 03 November 2012 - 09:41 AM

Are either of you using forge? As I have heard a lot of players are getting errors with custom launchers and forge.(including myself)