Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

NEI not showing

nei plugins null exception

  • Please log in to reply
6 replies to this topic

#1

death12652

Posted 18 June 2013 - 05:29 PM

I am trying to install mods and make a server with all the mods me and my friends like without the ones we don't, after using Big Dig, Technic Classic, and Feed the Beast, there are so many things we like about each one that we want all of the mods we like from them in our own server. Right now I am trying to just make a .minecraft to work on single player. After two days of trial and error and searching for errors and fixing them I finally came accross one that I just can't find much on.

Note : If someone thinks this is in the wrong spot feel free to move it I am new to posting on the forums because I like just searching what other people had trouble with and going from there. So this is my first post and here is my problem:

I have finally got minecraft to load a world but NEI seems to break. When I go to my mods section on the title screen and go to NEI at the bottom it says "No Installed Plugins" yet I have the NEIPlugins 1.0.9.3 from bitbucket.org Now when I went to chicken_bones post here I could not for the life of me find a download link for NEI. So I took it from 9minecraft.net here. Which could have been the problem right there. I downloaded the top link under 1.5.2 section. Here are my versions of everything (That could affect it in my opinion, if you want a full mod list ask)

NEIPlugins V 1.0.9.3 (installed under the mods folder)
NEI V 1.5.2.28 (Installed in coremods)
CodeChickenCore V 0.8.6.12
Forge V *.738
Optifine V 1.5.2 HD D3

Here are screen shots of whats happening to me
Spoiler:

Here is my ForgeModLoader-client-0.log (shortened cause it was to long, if there is a space then there was other code there but removed it because there wasn't any errors. The biggest one that needs to be fixed I think is the last one "NEI error" and such.

Spoiler:


Register or log in to remove.

#2

RustyXXL
    RustyXXL

    Obsidian Miner

  • Members
  • 1262 posts
  • Location: Germany
  • Minecraft: RustyXXL

Posted 18 June 2013 - 05:56 PM

Post a full log on pastebin and give us the link.

#3

death12652

Posted 18 June 2013 - 06:28 PM

Still was to big for pastebin, here is part 1 and 2, part 1 ends and begins on the next line when part 2 begins.

Part 1
Part 2

#4

RustyXXL
    RustyXXL

    Obsidian Miner

  • Members
  • 1262 posts
  • Location: Germany
  • Minecraft: RustyXXL

Posted 18 June 2013 - 06:45 PM

As far as I can tell the NEI problem should come from an api change in IC2. I'm not using it anymore, but I just checked they have newer builds on their jenkins. try updating ic2 first. If that doesn't help pls post a new error log with the new ic2 version.
I also noticed that you also have some exceptions with Logistic Pipes, which seem to be unrelated to your current problem, but you might also check if the version of logistic pipes you are using works with your Buildcraft version and upgrade/downgrade to fitting versions.

#5

death12652

Posted 18 June 2013 - 07:11 PM

Can't test the IC2 fix you said, there was a newer version but the minecraft servers are down at the moment so I will test when its up, anyway, I have BC 3.6.0, and this is where I got it, it says "Recent release: 0.3.7 for BC 3.5.3" should I use that BC, cause I didn't that would be a problem but I could be wrong.

#6

RustyXXL
    RustyXXL

    Obsidian Miner

  • Members
  • 1262 posts
  • Location: Germany
  • Minecraft: RustyXXL

Posted 18 June 2013 - 07:20 PM

Either you use the recent release (0.7.3.7) with buildcraft 3.5.3, or you use the dev builds 448 or higher with Buildcraft 3.6 as it is stated in their thread

#7

death12652

Posted 18 June 2013 - 07:26 PM

Thank you for helping, everything works now I installed the dev one and it works great. Never understood why they posted a dev build until now thank you.