Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

How to fix OPENGL Problems in ATI Drivers


  • Please log in to reply
24 replies to this topic

#1

Coal143
    Coal143

    Tree Puncher

  • Members
  • 15 posts

Posted 27 February 2011 - 02:31 PM

Applicable Products:
This fix applies to the following configuration(s):

    * Hardware
          o ATI Radeon™ HD 5xxx and ATI Radeon Mobility equivalent series of products
          o ATI Radeon HD 4xxx and ATI Radeon Mobility equivalent series of products
          o ATI Radeon HD 3xxx and ATI Radeon Mobility equivalent series of products
          o ATI Radeon HD 2xxx and ATI Radeon Mobility equivalent series of products
          o ATI FirePro™ Professional series of products
    * Software
          o ATI Catalyst Control Center
    * Operating System(s)
          o Windows 7 32-bit Edition
          o Windows 7 64-bit Edition
          o Windows Vista 32-bit Edition
          o Windows Vista 64-bit Edition
          o Windows XP Professional / Home
          o Windows XP Media Center Edition
          o Windows XP 64-bit Edition

This fix is supposed to work for this error:

Bad video card drivers!
-----------------------

Minecraft was unable to start because it failed to find an accelerated OpenGL mode.
This can usually be fixed by updating the video card drivers.


So I had bought minecraft about a month ago but i couldn't start it because of OPENGL Problems, it worked fine on my Desktop Computer which uses NVIDIA so i didn't bother searching for a solution. Yesterday however, i had bought a new game called "Cities in Motion" which also operated with OPENGL. Using my Desktop is a hassle so i decided for search for a solution.

Despite searching days for a fix when i was trying to play minecraft, under 10 minutes i stumbled upon a little piece of heaven. The fix is simple:

1. Download This: http://downloads.gur...nload-2594.html
2. Install It
3. All OpenGL problems should now be fixed, I am now able to run both Minecraft AND Cities in Motion flawlessly on my laptop.

Hope this helps, Coal143.


As Seen to work on: viewtopic.php?f=17&t=199848
Please leave feedback!
ATI Fix for OpenGL: <!-- l --><a class="postlink-local" href="http://www.minecraft...2884548</a><!-- l -->
"To err is human, to forgive, beyond the scope of the Operating System"

Register or log in to remove.

#2

okal
    okal

    Glowstone Miner

  • Curse Premium
  • Curse Premium
  • 3497 posts
  • Location: UK

Posted 27 February 2011 - 06:15 PM

Helpful thread, but can you please expand on what lead you to this particular driver over the current amd.com ones?

You haven't mentioned whether you tried the current amd.com drivers first, so we don't know if this is a just random driver issue that might be better resolved by using the current drivers, ie if you and that other poster had only Windows supplied drivers before and never installed a full Catalyst suite.
I know there is an issue with X series cards resolved by using Cat 7.7 drivers, but it would be nice if you can clarify why to use 10.7 over the current 11.2 ones for more recent HD series cards. A lot of users will understandably be reluctant to go back that far unless they have to.

What exact error is this for? If you can put that in your post it will help people searching to find this thread.
Also which card do you have that you know this works for?

Feedback given! :iapprove:

#3

rocky5656

Posted 27 February 2011 - 06:24 PM

I have the same problems (with OpenGL) and I use Intel.....any help ?

#4

Coal143
    Coal143

    Tree Puncher

  • Members
  • 15 posts

Posted 27 February 2011 - 07:53 PM

epikal said:

Helpful thread, but can you please expand on what lead you to this particular driver over the current amd.com ones?

You haven't mentioned whether you tried the current amd.com drivers first, so we don't know if this is a just random driver issue that might be better resolved by using the current drivers, ie if you and that other poster had only Windows supplied drivers before and never installed a full Catalyst suite.
I know there is an issue with X series cards resolved by using Cat 7.7 drivers, but it would be nice if you can clarify why to use 10.7 over the current 11.2 ones for more recent HD series cards. A lot of users will understandably be reluctant to go back that far unless they have to.

What exact error is this for? If you can put that in your post it will help people searching to find this thread.
Also which card do you have that you know this works for?

Feedback given! :GP:

Thank you for the feedback.
Yes, i have tried the amd.com drivers and many other fix suggestions on this thread. I have also installed a full Catalyst suite with no avail. To be completely honest, i have no idea why this one works. All i know is that when i used the 11.2 ones nothing changed. I cannot confirm this works for the newer ATI Drivers thought.

This is for this error:
Bad video card drivers!
-----------------------

Minecraft was unable to start because it failed to find an accelerated OpenGL mode.
This can usually be fixed by updating the video card drivers.

I have a ATI Mobility Radeon 3400 Series on my laptop.

Quote

I have the same problems (with OpenGL) and I use Intel.....any help ?
Sorry, no
ATI Fix for OpenGL: <!-- l --><a class="postlink-local" href="http://www.minecraft...2884548</a><!-- l -->
"To err is human, to forgive, beyond the scope of the Operating System"

#5

crewmaster

Posted 22 March 2011 - 03:37 PM

Not working for me still got the same problem.

	  Bad video card drivers!	  
	  -----------------------	  

Minecraft was unable to start because it failed to find an accelerated OpenGL mode.
This can usually be fixed by updating the video card drivers.



--- BEGIN ERROR REPORT 7fe0271 --------
Generated 22-3-11 16:35

Minecraft: Minecraft Alpha v1.1.2_01
OS: Windows 7 (x86) version 6.1
Java: 1.6.0_24, Sun Microsystems Inc.
VM: Java HotSpot(TM) Client VM (mixed mode), Sun Microsystems Inc.
LWJGL: 2.4.2
[failed to get system properties (java.lang.NullPointerException)]

org.lwjgl.LWJGLException: Pixel format not accelerated
	at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
	at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
	at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:185)
	at org.lwjgl.opengl.Display.createWindow(Display.java:311)
	at org.lwjgl.opengl.Display.create(Display.java:856)
	at org.lwjgl.opengl.Display.create(Display.java:784)
	at org.lwjgl.opengl.Display.create(Display.java:765)
	at net.minecraft.client.Minecraft.a(SourceFile:196)
	at net.minecraft.client.Minecraft.run(SourceFile:554)
	at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT 495e266c ----------




#6

LeoDuhLiiun
  • Location: New Jersey

Posted 22 March 2011 - 10:25 PM

Wow, I've been trying every method listed in the forums from Updating Windows, Updating Drivers Manually, Updating Java, Reinstalling Drivers (3 times :Diamond:), and even deleting Registry Keys in my Driver folders. This was the only way I got it to work. I've been at it for almost a MONTH to fix my problem, very nice find ! :Diamond: Thanks a bunch

Anyone with an ATI Driver Problem like this should try this first, but you got forgot to mention to uninstall your current driver then install the one you put up in the link.

#7

twannie1997
  • Location: The Netherlands
  • Minecraft: twannie1997

Posted 23 March 2011 - 02:56 PM

Will it work for the Radeon Xpress series?

Zkyo said:

An enderman teleported into my basement at some point, and re-arranged all the "natural" blocks in there.

#8

matija_os

Posted 23 March 2011 - 03:56 PM

What should I do. I have Nvidia GF 6600... i bought the game today :)  :Sheep:

#9

poizone
    poizone

    Out of the Water

  • Members
  • 2 posts

Posted 28 March 2011 - 07:49 PM

I think i've found a fix for the issue without using beta drivers. I went in the "Control Center" and under "Display Options" I set the 3D Refresh Rate to match my monitor's rate. Fixed my graphics problems.

#10

jeniusjj
    jeniusjj

    Tree Puncher

  • Members
  • 12 posts
  • Location: Australia on the Gold Coast
  • Minecraft: jeniusjj

Posted 31 March 2011 - 11:16 AM

OMG OMG OMG OMG OMG OMG OMG OMG OMG OMG OMG OMG OMG OMG OMG OMG

A few easy steps was all it took! Hell I was at wits end trying to figure this out - I was even messing with my OpenGL.dll file for goodness sakes (I was so desperate)!

I have a long way to go to figure out everything I need to know about technical computer stuff. I'm glad I actually went on the Support forums for once - cause this is great! When I saw my driver series pop up in that list I knew I was onto something great!

Thanks dude, and anyone out there who helped create this and find this out!

Cheers, Jenius :cobblestone:

Posted Image

Take the Magic: The Gathering 'What Color Are You?' Quiz.

"Minecraft's a fun game. You will spend hours on Minecraft, doing whatever you want. Anything you want. And then after all those hours are spent, you find out you've done nothing at all." Anonymous


#11

twannie1997
  • Location: The Netherlands
  • Minecraft: twannie1997

Posted 31 March 2011 - 02:13 PM

I found the Catalyst, installed, restarted, played, loved...
It works! :Diamond: :Diamond:

Zkyo said:

An enderman teleported into my basement at some point, and re-arranged all the "natural" blocks in there.

#12

zuze91
    zuze91

    Out of the Water

  • Members
  • 6 posts

Posted 05 April 2011 - 03:24 PM

doesnot work

#13

CasperArGh

Posted 22 April 2011 - 08:36 PM

I find a way to fix the ATI open GL driver problem :

1) download last ATI drivers 11.3 (or other)
2) extract all files
3) go into C:\ATI\Support\11-3_vista64_win7_64_dd_ccc_ocl\Packages\Drivers\Display\W76A_INF\B114839 (if C:\ATI is your default extraction folder)
5) launch a DOS console (cmd)
6) go to your extraction folder via the console (cd C:\ATI\Support\11-3_vista64_win7_64_dd_ccc_ocl\Packages\Drivers\Display\W76A_INF\B114839)
7) execute this : expand atioglxx.dl_ atioglxx.dll
8) copy the atioglxx.dll file into the C:\windows\system32\ folder
9) launch minecraft : it works !

#14

The_Grable
  • Minecraft: The_Grable

Posted 22 April 2011 - 09:14 PM

Uh.. i have one of the ATI cards listed but i don't get an error. Is this supposed to happen with all of them?

#15

jeniusjj
    jeniusjj

    Tree Puncher

  • Members
  • 12 posts
  • Location: Australia on the Gold Coast
  • Minecraft: jeniusjj

Posted 23 April 2011 - 11:37 AM

Do you think being able to fiddle with the new performance settings would make any difference to this?
Anyone with an unsolved case like this willing to test this out? --> Like go into your Appdata file and change the options settings from there.


I can't cause the computer I had died... poor CPU. It's hard to monitor whether or not your thermal paste is thinning out when you think nothing can stop your computer from failing (I guess I've learnt a lesson now, haven't I?!). :(

Posted Image

Take the Magic: The Gathering 'What Color Are You?' Quiz.

"Minecraft's a fun game. You will spend hours on Minecraft, doing whatever you want. Anything you want. And then after all those hours are spent, you find out you've done nothing at all." Anonymous


#16

Skittles0180

Posted 19 May 2011 - 11:57 PM

View PostCoal143, on 27 February 2011 - 02:31 PM, said:

Applicable Products:
This fix applies to the following configuration(s):

    * Hardware
          o ATI Radeon™ HD 5xxx and ATI Radeon Mobility equivalent series of products
          o ATI Radeon HD 4xxx and ATI Radeon Mobility equivalent series of products
          o ATI Radeon HD 3xxx and ATI Radeon Mobility equivalent series of products
          o ATI Radeon HD 2xxx and ATI Radeon Mobility equivalent series of products
          o ATI FirePro™ Professional series of products
    * Software
          o ATI Catalyst Control Center
    * Operating System(s)
          o Windows 7 32-bit Edition
          o Windows 7 64-bit Edition
          o Windows Vista 32-bit Edition
          o Windows Vista 64-bit Edition
          o Windows XP Professional / Home
          o Windows XP Media Center Edition
          o Windows XP 64-bit Edition

This fix is supposed to work for this error:

Bad video card drivers!
-----------------------

Minecraft was unable to start because it failed to find an accelerated OpenGL mode.
This can usually be fixed by updating the video card drivers.


So I had bought minecraft about a month ago but i couldn't start it because of OPENGL Problems, it worked fine on my Desktop Computer which uses NVIDIA so i didn't bother searching for a solution. Yesterday however, i had bought a new game called "Cities in Motion" which also operated with OPENGL. Using my Desktop is a hassle so i decided for search for a solution.

Despite searching days for a fix when i was trying to play minecraft, under 10 minutes i stumbled upon a little piece of heaven. The fix is simple:

1. Download This: http://downloads.gur...nload-2594.html
2. Install It
3. All OpenGL problems should now be fixed, I am now able to run both Minecraft AND Cities in Motion flawlessly on my laptop.

Hope this helps, Coal143.


As Seen to work on: <!-- l --><a class="postlink-local" href="http://www.minecraft...=199848</a><!-- l -->
Please leave feedback!


i suppose tat means it will not work for Radeon x 1300/x1550 series (Microsoft) correct?

#17

GV141
    GV141

    Iron Miner

  • Members
  • 271 posts
  • Minecraft: GhostViruz141

Posted 26 June 2011 - 08:25 PM

You`re a hero! Thank You :)
Posted Image

#18

Peglegswansoon

Posted 17 January 2012 - 05:46 PM

OMG you saved my life!!!! was having big problems with my mobility radeon driver, i fixed everything but then minecraft wouldnt work after :( thought i would have to rebuild my pc but then i followed ur advice and now it is all fine!!! it even fixed CCC. great now i can play again with my friends, no more being social outcast lol :)

#19

jeremydog1

Posted 24 January 2012 - 12:59 AM

hey,

do you know if it will work on ATI Radeon™ HD 6xxx

Thanks

#20

Coal143
    Coal143

    Tree Puncher

  • Members
  • 15 posts

Posted 27 January 2012 - 11:19 AM

Gee, it's been a while, eh?
I'm very happy that this has worked for people, as to answer a few of the above questions...

Quote

Will it work for the Radeon Xpress series?
No Idea, sorry.

Quote

What should I do. I have Nvidia GF 6600... i bought the game today :) :Sheep:
I doubt this fix will work for your card, see the above configurations on my first post

Quote

Thanks dude, and anyone out there who helped create this and find this out!
Thank you, I'm glad this has worked

Quote

I found the Catalyst, installed, restarted, played, loved...
It works!
:D

Quote

Uh.. i have one of the ATI cards listed but i don't get an error. Is this supposed to happen with all of them?
Not at all, only a select few.

Quote

i suppose tat means it will not work for Radeon x 1300/x1550 series (Microsoft) correct?
Correct.

Quote

You`re a hero! Thank You
No, thank you!

Quote

OMG you saved my life!!!! was having big problems with my mobility radeon driver, i fixed everything but then minecraft wouldnt work after :( thought i would have to rebuild my pc but then i followed ur advice and now it is all fine!!! it even fixed CCC. great now i can play again with my friends, no more being social outcast lol :)

xD, you're welcome

Quote

hey,

do you know if it will work on ATI Radeon™ HD 6xxx

Thanks
No idea, sorry. But you can always try and get back to me and tell me if it does or not!
ATI Fix for OpenGL: <!-- l --><a class="postlink-local" href="http://www.minecraft...2884548</a><!-- l -->
"To err is human, to forgive, beyond the scope of the Operating System"