Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Minecraft 1.5.2 RAM allocation problem


  • Please log in to reply
5 replies to this topic

#1

Gurzhag
    Gurzhag

    Tree Puncher

  • Members
  • 19 posts

Posted 10 June 2013 - 11:01 AM

Hi guys, thanks for reading!

I have been trying to fix a problem regarding the low FPS rates (16-20) my Minecraft shows following many tutorials on Youtube, Google and this very Forum:

[Tutorial] Allocate more memory for minecraft - Minecraft Forum - Page 8 - Page 8

I have a 64bits Windows 7 and java 64bits too. I tried to create a bat file with the following text:

"C:\Program Files\Java\jre7\bin\javaw.exe" -Xmx3096m -Xms2048m -jar "C:\Users\Alberto\AppData\Roaming\.minecraft\minecraft launcher\Minecraft Launcher.exe"

I get no problem trying to execute it and my Minecraft Launcher opens as usual. So usual that it won't show more that 910mb despite of having changed the RAM allocated to 3mb!

I have seen that people link it to Minecraft.exe but I can't find that file in my minecraft folder.

Any help please?

Thanks!

Register or log in to remove.

#2

tyteen4a03
    tyteen4a03

    And the duck went moo

  • Retired Staff
  • 291 posts
  • Location: Hong Kong
  • Minecraft: tyteen4a03

Posted 10 June 2013 - 12:04 PM

You can't really force Java to use up all the memory you give it. It is not the only indicator of performance, and in reality a pretty trivial one if you have 64bit Windows. Java will allocate itself a minimum heap size it is comfortable in if you really did set the maximum heap size to 3MB.

I would look into other aspects of your computer, for example CPU speed, storage devices and most importantly, your graphics card.
#minecrafthelp and #scrollshelp Channel Manager, Support Guru, Scrolls Moderator, Owner of FamilyMMOs.com

There are paths of which I must walk alone, for the reward is a companion for the rest of it.


<@Notch> whoa, rude language, behave
<@LG_Legacy> Oh relax notch, I'm never serious >_>
<@Notch> I DON'T CARE!!
@Notch runs away, crying
<@LG_Legacy> I made god cry? o_O"

#3

Gurzhag
    Gurzhag

    Tree Puncher

  • Members
  • 19 posts

Posted 10 June 2013 - 02:06 PM

I have an i7, 6gb ram, geforce 1gb. I can run easily games such as Skyrim or Crysis 3.

Now I have come to a new different problem when I tried to play: a chunk won't load sometimes leaving a 16x16 gap next to my castle... It just happened, I don't know why

#4

chargerjake

Posted 10 June 2013 - 02:47 PM

You need to install OptiFine. You may think that it slows it down more, but you'd be surprised. I have minecraft at 500 Megabytes and it runs 100FPS. I do have a mac, but I don't think that would be contributing much, as they are not meant to be gaming computers
Java Game Developer, Apple Computer Guru, and Big Time Gamer. ~Apple

#5

Tedster
    Tedster

    Blaze Extinguisher

  • Members
  • 4591 posts

Posted 10 June 2013 - 07:55 PM

As long as you have 64-bit Java, you should be fine with as low as 256MB allocated. Much more than 512MB may be the direct cause of performance issues.
I used to be a Support Guru, but then ran out of time. I have more time now, but I'll only make the occasional helpful post.

#6

Gurzhag
    Gurzhag

    Tree Puncher

  • Members
  • 19 posts

Posted 10 June 2013 - 09:23 PM

And what about a chunk disappearing near my castle whenever i get away from it a few steps and coming back when I approach it from a certain direction? that's crazy, isn't it? And I have pasted an old backup of that save and there's no problem with that chunk. So i guess the savegame is corrupted. How could I fix it? I've followed several tutorials and haven't come up with a solution!