Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[1.7.2] Fullscreen Windowed


  • Please log in to reply
139 replies to this topic

#1

Shoukaseikyo
  • Location: Canada
  • Minecraft: ShoukaSeikyo

Posted 21 May 2013 - 05:02 PM

Fullscreen Windowed

Windowed Fullscreen mode in Minecraft.

Useful for dualscreens and Alt-Tab.


Current version : 2014.01.19.1

1.7.2 | Download

1.6.4 | Download

Forge 1.6.4| Download

1.6.2 | Download

Forge 1.6.2| Download


Simply extract inside your minecraft.jar or new launcher equivalent (Delete META-INF too) and press Ctrl+F11 to turn on windowed fullscreen mode.
If you don't want the menu opening when you alt-tab, press Ctrl+Alt+F11.
For help for inside jar mod installation with forge read this post


What this mod do by UnDrac:
Spoiler:

If this mod create conflict with another mod, simply post a comment.


ChangeLog (And old versions links.)

Spoiler:

Copyright

Spoiler:

If you want to know why this mod exists, UnDrac explains it pretty well in this post.



Register or log in to remove.

#2

DaRkMaStEd

Posted 21 May 2013 - 05:15 PM

What does this do?

#3

Shoukaseikyo
  • Location: Canada
  • Minecraft: ShoukaSeikyo

Posted 21 May 2013 - 05:20 PM

View PostDaRkMaStEd, on 21 May 2013 - 05:15 PM, said:

What does this do?

The windowed fullscreen mode is having your game/application at fullscreen resolution but as a window. In Minecraft, you don't have this and when you're in Fullscreen, you cannot alt-tab without disabling the fullscreen. =3

#4

DaRkMaStEd

Posted 21 May 2013 - 05:31 PM

View PostShoukaseikyo, on 21 May 2013 - 05:20 PM, said:

The windowed fullscreen mode is having your game/application at fullscreen resolution but as a window. In Minecraft, you don't have this and when you're in Fullscreen, you cannot alt-tab without disabling the fullscreen. =3
I dont fully understand that i guess i will just try it when i get a chance.

#5

Aurelien_Sama
  • Minecraft: Aurelien_Sama

Posted 21 May 2013 - 06:04 PM

I've been waiting for something like this since a long time, thank you good sir !

#6

EmoKnight
  • Minecraft: zDeathKnightz
  • Xbox:ZzCKYzZ

Posted 21 May 2013 - 06:07 PM

why not just hit F11?
Posted Image
#### ^ Click Image to Download Mod Page ^ ###

#7

UnDrac
    UnDrac

    Tree Puncher

  • Members
  • 35 posts

Posted 21 May 2013 - 06:07 PM

View PostShoukaseikyo, on 21 May 2013 - 05:02 PM, said:

Fullscreen Windowed

Windowed Fullscreen mode in Minecraft.

Useful for dualscreens and Alt-Tab.


1.5.1 | adf.ly - direct

1.5.2 | adf.ly - direct


Simply extract inside your minecraft.jar and press F12 to set the fullscreen windowed mode.


If this mod create conflict with another mod, simply post a comment.


To do :

Forge compatibility


You should receive the "Best thing mojang never did but was really useful" award for making this.

I'd hug you if you can make it forge compatible xD

#8

Shoukaseikyo
  • Location: Canada
  • Minecraft: ShoukaSeikyo

Posted 21 May 2013 - 06:13 PM

View PostEmoKnight, on 21 May 2013 - 06:07 PM, said:

why not just hit F11?
Because we cannot alt-tab without exiting fullscreen in Minecraft. =P

View PostUnDrac, on 21 May 2013 - 06:07 PM, said:

You should receive the "Best thing mojang never did but was really useful" award for making this.

I'd hug you if you can make it forge compatible xD
Guess I'm not the only one who should receive it. =P

#9

supermitch68
  • Location: The Netherlands
  • Minecraft: supermitch6868

Posted 21 May 2013 - 07:11 PM

Or you use the fullscreen option in the settings (Yes, that is different from F11)
Posted Image

#10

Shoukaseikyo
  • Location: Canada
  • Minecraft: ShoukaSeikyo

Posted 21 May 2013 - 07:15 PM

View Postsupermitch68, on 21 May 2013 - 07:11 PM, said:

Or you use the fullscreen option in the settings (Yes, that is different from F11)
It still disable when you alt-tab.

#11

HeroxZ
    HeroxZ

    Stone Miner

  • Members
  • 95 posts
  • Minecraft: HeroxZ

Posted 21 May 2013 - 07:31 PM

I think i love you for making this mod...Posted Image

#12

Shoukaseikyo
  • Location: Canada
  • Minecraft: ShoukaSeikyo

Posted 21 May 2013 - 09:27 PM

View PostUnDrac, on 21 May 2013 - 06:07 PM, said:

I'd hug you if you can make it forge compatible xD
I added a Forge port. =3

View PostHeroxZ, on 21 May 2013 - 07:31 PM, said:

I think i love you for making this mod...Posted Image
<3

#13

PorpoiseBrock
  • Location: CA, USA
  • Minecraft: Im_a_Porpoise
  • Xbox:BrocksGen

Posted 22 May 2013 - 03:22 AM

I love you.

I love you so much. Oh my god. You are fantastic.

P.S. Non-forge link is broken

You can subscrooble above.

Or not.

It's your choice, really.


#14

Shoukaseikyo
  • Location: Canada
  • Minecraft: ShoukaSeikyo

Posted 22 May 2013 - 03:28 AM

View PostPorpoiseBrock, on 22 May 2013 - 03:22 AM, said:

I love you.

I love you so much. Oh my god. You are fantastic.

P.S. Non-forge link is broken
<3
Fixed the links problem, sorry about that.

#15

VashM16
    VashM16

    Gold Miner

  • Members
  • 374 posts
  • Location: Everywhere
  • Minecraft: VashM16

Posted 22 May 2013 - 04:10 AM

Can't you do this already?
Just hit the box in the middle of the x and the -?
"You don't know what you're up against,"
"Yeah I do."     "Oh."

#16

Shoukaseikyo
  • Location: Canada
  • Minecraft: ShoukaSeikyo

Posted 22 May 2013 - 04:15 AM

View PostVashM16, on 22 May 2013 - 04:10 AM, said:

Can't you do this already?
Just hit the box in the middle of the x and the -?
A fullsized window and a windowed fullscreen aren't the same thing. With this mod, as a videomaker, you can alt-tab easily without exiting fullscreen.
For example, if you are recording in fullscreen (1080P) and you forgot to mute Skype, if you alt-tab, Minecraft will exit fullscreen and your video will be screwed up. =3

#17

PorpoiseBrock
  • Location: CA, USA
  • Minecraft: Im_a_Porpoise
  • Xbox:BrocksGen

Posted 22 May 2013 - 04:29 AM

Everything works fine for me, up until joining a server...

I get this crash log:

	 Minecraft has crashed!	
	 ----------------------	
Minecraft has stopped running because it encountered a problem; Ticking entity
A full error report has been saved to C:\Users\Brock\AppData\Roaming\.minecraft\crash-reports\crash-2013-05-21_21.27.58-client.txt - Please include a copy of that file (Not this screen!) if you report this crash to anyone; without it, they will not be able to help fix the crash :(
--- BEGIN ERROR REPORT eafa8f72 --------
Full report at:
C:\Users\Brock\AppData\Roaming\.minecraft\crash-reports\crash-2013-05-21_21.27.58-client.txt
Please show that file to Mojang, NOT just this screen!
Generated 5/21/13 9:27 PM
-- Head --
Stacktrace:
at bfi.a(MovementInputFromOptions.java:39)
at bfj.c(EntityPlayerSP.java:166)
at ng.l_(EntityLiving.java:817)
at sq.l_(SourceFile:203)
at bdv.l_(SourceFile:45)
at aab.a(SourceFile:1336)
at aab.g(SourceFile:1314)
-- Entity being ticked --
Details:
Entity Type: null (bdv)
Entity ID: 4101
Entity Name: Im_a_Porpoise
Entity's Exact location: 8.50, 66.62, 8.50
Entity's Block location: World: (8,66,8), Chunk: (at 8,4,8 in 0,0; contains blocks 0,0,0 to 15,255,15), Region: (0,0; contains chunks 0,0 to 31,31, blocks 0,0,0 to 511,255,511)
Entity's Momentum: 0.00, 0.00, 0.00
Stacktrace:
at aab.h(SourceFile:1221)
-- Affected level --
Details:
Level name: MpServer
All players: 1 total; [bdv['Im_a_Porpoise'/4101, l='MpServer', x=8.50, y=66.62, z=8.50]]
Chunk stats: MultiplayerChunkCache: 0
Level seed: 0
Level generator: ID 00 - default, ver 1. Features enabled: false
Level generator options:
Level spawn location: World: (0,88,0), Chunk: (at 0,5,0 in 0,0; contains blocks 0,0,0 to 15,255,15), Region: (0,0; contains chunks 0,0 to 31,31, blocks 0,0,0 to 511,255,511)
Level time: 68468753 game time, 68631672 day time
Level dimension: 0
Level storage version: 0x00000 - Unknown?
Level weather: Rain time: 0 (now: false), thunder time: 0 (now: false)
Level game mode: Game mode: adventure (ID 2). Hardcore: false. Cheats: false
Forced entities: 1 total; [bdv['Im_a_Porpoise'/4101, l='MpServer', x=8.50, y=66.62, z=8.50]]
Retry entities: 0 total; []
Stacktrace:
at bds.a(SourceFile:282)
at net.minecraft.client.Minecraft.b(Minecraft.java:2534)
at net.minecraft.client.Minecraft.run(Minecraft.java:771)
at java.lang.Thread.run(Unknown Source)
-- System Details --
Details:
Minecraft Version: 1.5.2
Operating System: Windows 7 (amd64) version 6.1
Java Version: 1.7.0_21, Oracle Corporation
Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 2928870296 bytes (2793 MB) / 3014656000 bytes (2875 MB) up to 3014656000 bytes (2875 MB)
JVM Flags: 2 total; -Xms3000m -Xmx3000m
AABB Pool Size: 22 (1232 bytes; 0 MB) allocated, 5 (280 bytes; 0 MB) used
Suspicious classes: IWrUpdater, Config, WrUpdaterSmooth, ...]
IntCache: cache: 0, tcache: 0, allocated: 3, tallocated: 63
LWJGL: 2.4.2
OpenGL: GeForce GTX 560 Ti/PCIe/SSE2 GL version 4.3.0, NVIDIA Corporation
Is Modded: Very likely; Jar signature invalidated
Type: Client (map_client.txt)
Texture Pack: faithful32pack.zip
Profiler Position: N/A (disabled)
Vec3 Pool Size: 25 (1400 bytes; 0 MB) allocated, 11 (616 bytes; 0 MB) used
java.lang.NoSuchFieldError: keyBindSprint
at bfi.a(MovementInputFromOptions.java:39)
at bfj.c(EntityPlayerSP.java:166)
at ng.l_(EntityLiving.java:817)
at sq.l_(SourceFile:203)
at bdv.l_(SourceFile:45)
at aab.a(SourceFile:1336)
at aab.g(SourceFile:1314)
at aab.h(SourceFile:1221)
at net.minecraft.client.Minecraft.l(Minecraft.java:1926)
at net.minecraft.client.Minecraft.K(Minecraft.java:830)
at net.minecraft.client.Minecraft.run(Minecraft.java:755)
at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT 6260cdae ----------

EDIT: I had Optifine and Better Sprint installed on my client, and taking better spring off seems to have solved the issue.

You can subscrooble above.

Or not.

It's your choice, really.


#18

Shoukaseikyo
  • Location: Canada
  • Minecraft: ShoukaSeikyo

Posted 22 May 2013 - 04:36 AM

View PostPorpoiseBrock, on 22 May 2013 - 04:29 AM, said:

Everything works fine for me, up until joining a server...

I get this crash log:

Could you give me a list of mods you're using ? I'm pretty sure it is an incompatibility.

#19

UnDrac
    UnDrac

    Tree Puncher

  • Members
  • 35 posts

Posted 22 May 2013 - 06:42 AM

View PostDaRkMaStEd, on 21 May 2013 - 05:15 PM, said:

What does this do?
This enables the option to have a "Fullscreen" Window of Minecraft.

View PostEmoKnight, on 21 May 2013 - 06:07 PM, said:

why not just hit F11?
Because when you alt+tab away from minecraft it turns fullscreen off and defaults to the small window.

View Postsupermitch68, on 21 May 2013 - 07:11 PM, said:

Or you use the fullscreen option in the settings (Yes, that is different from F11)
It doesn't matter which setting you use, Minecraft's fullscreen setting just turns itself off when you alt+tab, and please don't be dumb and say "Then don't alt tab!".

View PostVashM16, on 22 May 2013 - 04:10 AM, said:

Can't you do this already?
Just hit the box in the middle of the x and the -?
If you enjoy having that ugly looking window title up there along with the window's borders then yeah, you can do that. But this is to make it a "FullScreen" window, without the borders, or title bar, or the annoying fullscreen deactivation when you alt+tab.

If any of you didn't find this useful, then by all means don't use it, it's not like he's forcing you to do it, he simply shared his idea of a setting for Minecraft, which in my opinion was the "Best thing Mojang never did but was very useful".

#20

Roi_Louis

Posted 22 May 2013 - 07:38 AM

Really nice ! congrats shouka !