Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Can't move my mouse while pressing 'W'

mouse problems

  • Please log in to reply
15 replies to this topic

#1

Drex550
    Drex550

    Out of the Water

  • Members
  • 4 posts

Posted 02 May 2013 - 12:53 AM

So I got a new laptop and I got downloaded Minecraft(as usual).
I start playing, and everything is good.
But then, when I move forward/sprint, my view won't move, and I'm just stuck running forward.
So I got a better way to explain.
While I'm pressing the "W" key to walk and I like touch the trackpad to turn, but it's like the trackpad is not working at all, the then again, if I jump once, it gets fixed until I stop walking.
Its NOT the glitch where you're not holding any WASD buttons and you're keeping moving, it's different.
The WASD works fine. Its just the trackpad I guess.
But my trackpad works fine. When I'm just standing, I can look around no problem. Its just when I start moving. BTW I tried force updating, but no change.
And I found out while I'm moving in only one direction, if I jump once, then it's fixed for only that run and it's annoying. Can anyone help me? My minecraft isn't laggy at all, since I got a beast laptop. I tried deleting Mincraft but doesn't work.
I made multiple worlds and all the same.
Please help(:

I've seen something about "Palm Rejection" or something like that.. I have an Acer running Windows 8. I've also tested it while in notepad but the same thing happens with any button.

Register or log in to remove.

#2

cestislife
    cestislife

    Resident Fuzzball

  • Sectional Moderator
  • 6581 posts
  • Location: Malaysia
  • Minecraft: LORDVENOM0001

Posted 02 May 2013 - 02:05 AM

Try updating LWJGL.

Posted Image


#3

gerbil
    gerbil

    Support Guru

  • Members
  • 4908 posts

Posted 02 May 2013 - 03:52 AM

Most likely caused by the configuration of your touch pad.
On a synaptics touch pad it's in the Properties -> Pointing -> Sensitivity -> PalmCheck
On a Dell touchpad it's in the Properties -> Sensitivity -> TouchGuard

These features basically disable the touch pad while you are using the keyboard.

#4

WastedisBaaaaaaaaaaaaast

Posted 27 June 2013 - 11:37 AM

That happens to me but I have a computer not laptop how do I fix it on my computer!?

#5

crazyman1001

Posted 27 June 2013 - 04:31 PM

View PostWastedisBaaaaaaaaaaaaast, on 27 June 2013 - 11:37 AM, said:

That happens to me but I have a computer not laptop how do I fix it on my computer!?

Laptop is a computer, lol.

#6

Matexo2006

Posted 03 July 2013 - 08:54 PM

Has anoyone found a solution to this?
It is not related to the PalmCheck or TouchGuard etc. , that is for fixing a slightly different problem which briefly locks the mouse. This problem only stops the mouse while a key is held down, meaning it continues to work once the key is released, whereas the other problem related to PalmCheck actually freezes the mouse upon the press of a key or any other keyboard activity, and keeps it frozen for a few moments after keyboard activity stops.
As Drexx said, it can be fixed during each run by tapping space (or in fact any key) but only works for the duration of that key-holddown.

I am working on a patch of sorts to help a friend with the exact same problem. I'll post a link here when I'm done, perhaps it will be of use to some.

#7

CC362
    CC362

    Tree Puncher

  • Members
  • 15 posts
  • Minecraft: CC362

Posted 18 August 2013 - 01:41 PM

I keep having the same problem so my dad keeps fixing it. I think he goes in Control Panel-> Hardware and Sound -> Device Manager -> and that's all I remember. I might be wrong, but I practically KNOW he went in Control Panel.

#8

FEAPlayer1

Posted 28 August 2013 - 02:37 AM

i looked it up it said that it could be caused by blocks showing up again after being broken.

#9

Squantonias

Posted 10 October 2013 - 02:58 AM

Yeah this is a commen problem with newer laptops watch mi video on how to fix this error

>> it is simple and to the point


Like and sub if it helped Thanks

Yeah this is a commen problem with newer laptops watch mi video on how to fix this error

>> it is simple and to the point


Like and sub if it helped Thanks

#10

kittenkween

Posted 15 October 2013 - 08:40 PM

I have the same problem but on a desktop and after I installed camstudio

#11

Matexo2006

Posted 18 October 2013 - 11:33 PM

I'm starting to get frustrated. No one is reading the posts before they open their mouths.
Have a look guys. ITS NOTHING TO DO WITH THE TRACKPAD SETTINGS.
Your video doesn't solve this problem. Your dad going into control panel doesn't solve this problem. Please read what the problem is and previously suggested solutions before posting!!

#12

TheEBlocker
  • Location: Maryland, USA
  • Minecraft: TheEBlocker

Posted 19 October 2013 - 12:25 AM

my laptop does the exact same thing. get a mouse. first of all, the problem is solved, and second the gaming experience is WAY BETTER.
Posted Image
Hello. I'm TheEBlocker.
Skype: TheEBlocker
Email: [email protected]

#13

Matexo2006

Posted 22 October 2013 - 03:50 PM

No, because the fix is entirely different.
With the trackpad settings, tapping a single key during the holding down of the w key does nothing, because any keyboard input suspends trackpad input until for a certain amount of time until no more keyboard input is found.
What is happening is when Drex walks, he can jump and then during that same walk he is able to look around, but finds that after stopping that single walk, then starting to walk again, he can't look.
It is a problem related to the way a keyboard inputs information, and changing trackpad settings does nothing.
I explained all this already, after Drex explained it, hence why I said people actually need to read.
I'm aware that it occurs in notepad, and anywhere on the computer in fact, yeah, it has nothing to do with any of those things, because it's a technical problem.

The temporary fix is to write a program that simulates multiple key taps each time a key is pressed, thus freeing the mouse each time. I managed to do that, but it gets complicated when you only want that to occur in minecraft, and not in program like notepad or word, because that would result in several letters appearing each time you tried to type. That is fixable however than I remembered the chat/command feature of minecraft, as well as naming worlds. Realistically there is no way to determine when a player is using these features instead of walking around, so there's no way I can make it work automatically, I have to have a key which switches it on and off. On when you wanna walk around, switch off to use chat etc, then switch back on to walk around again. Essentially that's a pain and not user friendly, but I don't know enough to create a true patch that integrates with the minecraft program itself, someone would have to work from the inside to do that.

What really frustrates me is that everyone assumes it is a trackpad problem and posts the exact same meaningless stuff when it has already been proven not to be that problem, by Drex himself, when he explained the nature of the problem. Obviously the people putting forwards these "solutions" don't even understand what they're talking about, because this isn't how track pad guards work. Everyone sees a problem related to not being able to look around, and they jump in and assume its the trackpad. Even if it was that problem, there's no need to post it again and again. Seeing as how it cannot be that problem, based on the description of the problem Drex gave, yes, I feel completely trolled. I came here looking for useful solutions to the problem I have which is identical to the one Drex described, that's how I know the "solutions" don't do a thing to fix it. I'm not trolling you.

#14

MarshTheMonkey

Posted 25 December 2013 - 03:29 PM

I have tried these steps but when I click settings on device settings I get a different menu to what you get and nobody seems to have the same problem as me do you have any suggestions

#15

Rocket4wheel
  • Minecraft: rocket4wheel

Posted 20 January 2014 - 06:34 PM

View Postcrazyman1001, on 27 June 2013 - 04:31 PM, said:

Laptop is a computer, lol.

More commonly described as Computer instead of Laptop, is a Desktop.
you know, those large bulky things that are not portable at all?
Computer = Desktop
Laptop = Laptop/Computer.
Posted Image

#16

magic864
    magic864

    Newly Spawned

  • Members
  • 1 posts

Posted 08 February 2014 - 01:33 AM

hope this helps :)
http://www.eightforu...ff-windows.html