Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

How do you add files to Minecraft.jar with 7z?


  • Please log in to reply
11 replies to this topic

#1

SomePlayer

Posted 17 March 2013 - 07:02 PM

I currently make mods for Civilization IV so I thought adding a mod to Minecraft would be easy.  It ain't.

I want to add Mo' Creatures to my Minecraft game but I have no idea how to add Minecraft Forge to the minecraft.jar file.  I've opened 7z and the drag n' drop option doesn't work.  There is an "Add" option in the top left corner but the operation isn't supported.  I heard someone saying you have to "unzip" the program but I have no idea how to.  Can anyone help me?

Note: I've been searching on this for an hour or two and I can't find any thread that specifically says how to edit minecraft.jar.  If there is, please direct me to it.
Also, I didn't see a mods folder in .minecraft so I created one.  Should I have done that?

Register or log in to remove.

#2

DiegoAtravesar
  • Location: Canada
  • Minecraft: DiegoAtravesar

Posted 17 March 2013 - 09:26 PM

View PostSomePlayer, on 17 March 2013 - 07:02 PM, said:

I currently make mods for Civilization IV so I thought adding a mod to Minecraft would be easy.  It ain't.

I want to add Mo' Creatures to my Minecraft game but I have no idea how to add Minecraft Forge to the minecraft.jar file.  I've opened 7z and the drag n' drop option doesn't work.  There is an "Add" option in the top left corner but the operation isn't supported.  I heard someone saying you have to "unzip" the program but I have no idea how to.  Can anyone help me?

Note: I've been searching on this for an hour or two and I can't find any thread that specifically says how to edit minecraft.jar.  If there is, please direct me to it.
Also, I didn't see a mods folder in .minecraft so I created one.  Should I have done that?

Haha it can be difficult to get into the process of modding Minecraft on Your own, so hopefully I can help out with this, as I spend a good chunk of my time putting together sets of mods myself, it just takes some practice and getting familiar with the process.

so, to start: Minecraft Forge is requried by *most*(Not all) mods nowadays, and I'm sure You know where to get it, but if not, You can find it here.

To add it to the minecraft.jar:
RIght click Your minecraft.jar and select open with: 7zip. This will open it in a window, and You should see the contents of the jar(A bunch of folders and files with odd names). This is good. :)

Delete the META-INF folder in the minecraft.jar. This step must ALWAYS be done the first time You open the .jar, otherwise nothing will load and You'll end up with a black screen.

Next: Open Forge using the same method. You *Should* be able to just drag it over, but if not, then You're going to have a bit of a different approach to this.

If You can't Drag and drop as You've said, rather than opening the Forge file in 7zip, right click it and there should be an "extract..." option, or something similar that has the 7zip logo. Select that, and extract the files into a fodler(Preferably a empty one so You dont get it mixed up with other stuf). Then, You can use the add option in 7zip(The minecraft.jar one) to add the forge files from that folder.

Obviously, drag and drop is easier, so if for some reason You keep having that issue, I might recommend WinRar. Its the same as 7zip, just looks different, but Drag and Drop does work fine with it, and saves You taking that extra step of extracting first.

Once You've put the Forge files into the .jar, just close 7zip(Make sure to save the .jar with the new files in it) and then run minecraft. If everything went well, the game will load, and You will see a bunch of text in the bottom left corner about which FML, MCP, and Forge versions are installed. That just means it worked. If so, just close the game, and You should see a mods folder in the minecraft folder; Just put Your mods in that.

the mods folder only exists after running Minecraft with Forge installed, so if it wasn't there before, don't worry too much, thats normal.

Check on the thread for the mods You're installing where it says to put it. Some mods(Most) will go in the mods folder, which is the simplest place to install to. Some will have to go in coremods, which is the same as mods, its just a different folder. make sure You put everything in the right place, or it won't work.

for anything that says install to the jar, just use the same method You used for Forge to install it.

For Mo' Creatures, also make sure You get the GUIAPI and CustomSpawner mods, as it requires those to work as well.

Hopefully this helps, and if You have any other questions, feel free to either ask here, or PM me if You want a faster response from me, as I check my PM's far more than I check my previous posts in threads.

Good Luck! :)
Servers I play on: NearbyNation Sub Server
Current Project: Universal Configs (On hold currently)

#3

SomePlayer

Posted 17 March 2013 - 11:36 PM

I did as you said but after I log in to minecraft I get this:
Posted Image
And the screen is frozen like that.

#4

Abhann
    Abhann

    Tree Puncher

  • Members
  • 17 posts

Posted 17 March 2013 - 11:45 PM

I'm nowhere as good as DiegoAtravesar at this but try this:

- delete minecraft.jar (or even the whole bin folder)
- start minecraft, it will do an update and replace with a new clean .jar
- if it launches and starts properly then use DiegoA's instructions to add Forge again

Let us know how it works :)

PS: After adding forge maybe open minecraft.jar again to check, there should be a at least one file starting with FML in the top level (or root) of the zip.  It's easy to drag or copy into folders wrong

#5

SomePlayer

Posted 18 March 2013 - 12:30 AM

I already tried that, it didn't work.

Maybe the link for forge on Mo' Creatures is outdated.
Name: minecraftforge-universal-1.4.7-6.6.1.524.zip

#6

Abhann
    Abhann

    Tree Puncher

  • Members
  • 17 posts

Posted 18 March 2013 - 01:42 AM

View PostSomePlayer, on 18 March 2013 - 12:30 AM, said:

I already tried that, it didn't work.

Maybe the link for forge on Mo' Creatures is outdated.
Name: minecraftforge-universal-1.4.7-6.6.1.524.zip

That one should work, I think.  I'm currently running different sets of Mo's creatures with Forge 6.6.0.497 and Forge 6.6.2.534, but to be sure you can use the link from DieagoA and download.

You need three things for Mo's Creatures(4 incl forge):Mo's Creatures, GUI API and DrZhark's Custom Spawner, check DrZhark's thread for how to install, none of them go into the minecraft.jar (except forge, of course)

#7

DiegoAtravesar
  • Location: Canada
  • Minecraft: DiegoAtravesar

Posted 18 March 2013 - 02:25 AM

Like I said to OtherPlayer in a PM, I think we figured out the issue. Mo'Creatures is still only out for 1.4.7, and unless He downgraded(He hasn't yet responded, but I'm making an assumption by saying he probably hasn't(Correct me if I'm wrong), so He's installing 1.4.7 Forge and Mo' Creatures into MC 1.5, which won't work.

Downgrade methods:
MCNostalgia
MultiMC

I recommend using MultiMC as it has an easy to use GUI for both downgrading and installing mods, it gets rid of the hassle of having to extract, and copy files into and out of the jar and mods folder; You can still use that method if You so wish, but with that GUI it's not neccessary. :)

Hopefully that is all the problem is; Anytime Minecraft gets stuck on loading like that it does tend to be a Forge issue, especially with a Forge built for a different version of Minecraft.
Servers I play on: NearbyNation Sub Server
Current Project: Universal Configs (On hold currently)

#8

Abhann
    Abhann

    Tree Puncher

  • Members
  • 17 posts

Posted 18 March 2013 - 02:47 AM

View PostDiegoAtravesar, on 18 March 2013 - 02:25 AM, said:

snip. . . Mo'Creatures is still only out for 1.4.7, . . .snip

(slapping forehead) I just posted about checking versions on the Mo's Creatures thread, not sure why I missed it here.  As I said you are WAY better at this than I am.

I use MultiMC and find it great, especially now when half my favorite mods are 1.5 and half 1.47

#9

DiegoAtravesar
  • Location: Canada
  • Minecraft: DiegoAtravesar

Posted 18 March 2013 - 02:50 AM

View PostAbhann, on 18 March 2013 - 02:47 AM, said:

(slapping forehead) I just posted about checking versions on the Mo's Creatures thread, not sure why I missed it here.  As I said you are WAY better at this than I am.

I use MultiMC and find it great, especially now when half my favorite mods are 1.5 and half 1.47
Haha "better" is relative my friend :) I missed it as well, It's been a while since the last update, that sort of thing hasn't crossed my mind since then and You start to forget that that might be an issue except in rare, special cases ;)
Servers I play on: NearbyNation Sub Server
Current Project: Universal Configs (On hold currently)

#10

SomePlayer

Posted 18 March 2013 - 07:13 PM

I tried universal and it worked, for some reason, I got the updating screen and it was frozen at 0% but now it loaded fine.  And I've got the mods folder now.  Just gotta wait for the latest version of Mo' Creatures to come out.

#11

td1901
    td1901

    Out of the Water

  • Members
  • 3 posts

Posted 25 June 2013 - 02:05 AM

how do i fix my minecraft when i deleted the gui folder from 7zip and now it is completely messed up.

#12

DragnHntr

Posted 25 June 2013 - 02:17 AM

View Posttd1901, on 25 June 2013 - 02:05 AM, said:

how do i fix my minecraft when i deleted the gui folder from 7zip and now it is completely messed up.
delete the minecraft jar and force update in the launcher.