Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

memory connection overburdened


  • Please log in to reply
15 replies to this topic

#1

xsaeshx
    xsaeshx

    Carpenter

  • Members
  • 41 posts

Posted 20 February 2013 - 12:31 PM

Hey,

Since i have updatet some mods and Java to 7 my minecraft sucks and laggs every 5 Minutes for 1-3 seconds.

In my Log i found something that called: memory connection overburdened

Anyone know this? What can i do?

I have got a High end PC and Win7 Ultimate 64 Bit and Java7 64 Bit. I have also installed a Good amount of mods. But i changed nothing. And a few days earlier everything was okay.

Whats the Problem and how to fix it??

Register or log in to remove.

#2

Hidinginthelight

Posted 21 February 2013 - 01:35 AM

Posting a copy of the log would help us to help you.

#3

inversedarkfox

Posted 29 March 2013 - 12:51 AM

I am getting simlar probelms but I am lagging more than 1-3 seconds.
I am using MagicLauncher 1.0, Java 6 (down dated to 6 when I thought the issue was 7), and use rei's mini map, and optifine mods.  I run a creative off server and smp server.  I have attached my specs for my mac in blue, and the magic launcher information in red.

Processor  2.53 GHz Intel Core i5
Memory  8 GB 1067 MHz DDR3
Graphics  NVIDIA GeForce GT 330M 256 MB
Software  OS X 10.8.3 (12D78)

MagicLauncher 1.0.0
java.home: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
java.runtime.name: Java™ SE Runtime Environment
java.runtime.version: 1.6.0_43-b01-447-11M4203
os.name: Mac OS X
os.version: 10.8.3
os.arch: i386
sun.arch.data.model: 32

*** Starting Minecraft ***
Minecraft version: 1.5.1
Minecraft.jar: minecraft.jar
Mods:
  OptiFine_1.5.1_HD_U_B1.zip
Inactive external mods:
  [1.5]ReiMinimap_v3.3_02.zip
  ModLoader.zip
  OptiFine_1.5.0_HD_U_A2.zip
  OptiFine_1.5.0_HD_U_A4.zip
  OptiFine_1.5.1_HD_U_A7.zip
Java path: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/java
Memory: 3072 MB
LauncherPath: /Applications/MagicLauncher.app/Contents/Resources/Java/MagicLauncher.jar
LauncherPath: /Applications/
*** MagicMinecraftLauncher 1.0.0 ***
Disable inactive mods
Disabled: [1.5]ReiMinimap_v3.3_02.zip
Disabled: ModLoader.zip
Disabled: OptiFine_1.5.0_HD_U_A2.zip
Disabled: OptiFine_1.5.0_HD_U_A4.zip
Disabled: OptiFine_1.5.1_HD_U_A7.zip
229 recipes
27 achievements
2013-03-28 18:43:15 [CLIENT] [INFO] Setting user: inversedarkfox
(Session ID is -1963115861)
Client asked for parameter: server
2013-03-28 18:43:15 [CLIENT] [INFO] LWJGL Version: 2.4.2
[OptiFine]
[OptiFine] OptiFine_1.5.1_HD_U_B1
[OptiFine] Thu Mar 28 18:43:15 MDT 2013
[OptiFine] OS: Mac OS X (x86_64) version 10.8.3
[OptiFine] Java: 1.6.0_43, Apple Inc.
[OptiFine] VM: Java HotSpot™ 64-Bit Server VM (mixed mode), Apple Inc.
[OptiFine] LWJGL: 2.4.2
[OptiFine] OpenGL: NVIDIA GeForce GT 330M OpenGL Engine version 2.1 NVIDIA-8.10.44 304.10.65f03, NVIDIA Corporation
[OptiFine] OpenGL Version: 2.1
[OptiFine] Checking for new version
[OptiFine] Version found: B1
[OptiFine] (Reflector) Class not present: ModLoader
[OptiFine] (Reflector) Class not present: FMLRenderAccessLibrary
[OptiFine] (Reflector) Class not present: LightCache
[OptiFine] (Reflector) Class not present: BlockCoord
[OptiFine] (Reflector) Class not present: net.minecraftforge.common.MinecraftForge
[OptiFine] (Reflector) Class not present: net.minecraftforge.common.ForgeHooks
[OptiFine] (Reflector) Class not present: net.minecraftforge.client.ForgeHooksClient
[OptiFine] (Reflector) Class not present: cpw.mods.fml.common.FMLCommonHandler
[OptiFine] (Reflector) Class not present: cpw.mods.fml.client.FMLClientHandler
[OptiFine] (Reflector) Method not pesent: acn.getSkyRenderer
[OptiFine] (Reflector) Method not pesent: acn.getCloudRenderer
[OptiFine] (Reflector) Class not present: net.minecraftforge.client.IRenderHandler
[OptiFine] (Reflector) Class not present: net.minecraftforge.common.DimensionManager
[OptiFine] (Reflector) Class not present: net.minecraftforge.event.world.WorldEvent$Load
[OptiFine] (Reflector) Class not present: net.minecraftforge.event.EventBus
[OptiFine] (Reflector) Class not present: net.minecraftforge.event.world.ChunkWatchEvent$UnWatch
[OptiFine] (Reflector) Method not pesent: apa.getBedDirection
[OptiFine] (Reflector) Method not pesent: apa.isBedFoot
[OptiFine] (Reflector) Method not pesent: apa.canRenderInPass
[OptiFine] (Reflector) Field not present: mp.captureDrops
[OptiFine] (Reflector) Field not present: mp.capturedDrops
[OptiFine] (Reflector) Method not pesent: ml.isCurativeItem

Starting up SoundSystem...
Restoring disabled mods
Initializing LWJGL OpenAL
    (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
OpenAL initialized.

[OptiFine] Loading custom colors: /misc/grasscolor.png
[OptiFine] Loading custom colors: /misc/foliagecolor.png
[OptiFine] ConnectedTextures: ctm/ctm/block102.properties
[OptiFine] ConnectedTextures: ctm/ctm/block102a.properties
[OptiFine] Render pass not supported: 3
[OptiFine] ConnectedTextures: ctm/ctm/block20.properties
[OptiFine] Render pass not supported: 2
[OptiFine] ConnectedTextures: ctm/ctm/block20a.properties
[OptiFine] Render pass not supported: 3
[OptiFine] ConnectedTextures: ctm/ctm/glass.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/beacon.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/block113.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/block113a.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/block85.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/block85a.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/bookshelf.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/brick.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/dirt.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/grass_side.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/grass_top.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/reeds.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/sandstone_carved.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/sandstone_side.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/sandstone_smooth.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/stonebrick.properties
[OptiFine] Number of weights must equal the number of tiles: /ctm/sphax_ctm/stonebrick.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/stonebricksmooth.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/stoneslab_top.properties
[OptiFine] Number of weights must equal the number of tiles: /ctm/sphax_ctm/stoneslab_top.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/thinglass_top.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_a.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_b.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_c.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_d.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_e.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_f.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_g.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_h.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_i.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_j.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_k.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_l.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_m.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm/trapdoor_n.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm2/blockDiamond.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm2/blockEmerald.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm2/blockGold.properties
[OptiFine] ConnectedTextures: ctm/sphax_ctm2/blockIron.properties
[OptiFine] Tile size for terrain: 32
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/lava_flow.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/water_flow.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/blockRedstone.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/dragonEgg.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/fire_0.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/fire_1.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/furnace_front_lit.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/hellrock.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/lava.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/lightgem.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/netherquartz.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/oreRedstone.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/portal.txt
2013-03-28 18:43:19 [CLIENT] [INFO] Found animation info for: textures/blocks/water.txt
[OptiFine] Tile size for items: 32
2013-03-28 18:43:20 [CLIENT] [INFO] Found animation info for: textures/items/clock.txt
2013-03-28 18:43:20 [CLIENT] [INFO] Found animation info for: textures/items/compass.txt
2013-03-28 18:43:20 [CLIENT] [SEVERE] ########## GL ERROR ##########
2013-03-28 18:43:20 [CLIENT] [SEVERE] @ Post startup
2013-03-28 18:43:20 [CLIENT] [SEVERE] 1281: Invalid value
2013-03-28 18:43:21 [CLIENT] [SEVERE] ########## GL ERROR ##########
2013-03-28 18:43:21 [CLIENT] [SEVERE] @ Pre render
2013-03-28 18:43:21 [CLIENT] [SEVERE] 1281: Invalid value
2013-03-28 18:43:33 [SERVER] [INFO] Starting integrated minecraft server version 1.5.1
2013-03-28 18:43:33 [SERVER] [INFO] Generating keypair
[OptiFine] ViewRadius: 10, for: iw@51927ba1 (constructor)
[OptiFine] ViewRadius: 10, for: iw@296068c9 (constructor)
[OptiFine] ViewRadius: 10, for: iw@78f77c8e (constructor)
2013-03-28 18:43:33 [SERVER] [INFO] Preparing start region for level 0
loading single player
2013-03-28 18:43:34 [SERVER] [INFO] inversedarkfox[/127.0.0.1:0] logged in with entity id 205 at (-432.88869012355406, 87.64999856786228, 519.7397195620224)
2013-03-28 18:43:35 [SERVER] [INFO] Saving and pausing game...
2013-03-28 18:43:35 [SERVER] [INFO] Saving chunks for level 'New World'/Overworld
2013-03-28 18:43:35 [SERVER] [INFO] Saving chunks for level 'New World'/Nether
2013-03-28 18:43:35 [SERVER] [INFO] Saving chunks for level 'New World'/The End
2013-03-28 18:44:03 [CLIENT] [WARNING] Memory connection overburdened; after processing 2500 packets, we still have 1329 to go!
2013-03-28 18:44:28 [CLIENT] [WARNING] Memory connection overburdened; after processing 2500 packets, we still have 1664 to go!
2013-03-28 18:44:40 [CLIENT] [WARNING] Memory connection overburdened; after processing 2500 packets, we still have 278 to go!
2013-03-28 18:44:54 [SERVER] [INFO] Saving and pausing game...
2013-03-28 18:44:54 [SERVER] [INFO] Saving chunks for level 'New World'/Overworld
2013-03-28 18:44:55 [SERVER] [INFO] Saving chunks for level 'New World'/Nether
2013-03-28 18:44:55 [SERVER] [INFO] Saving chunks for level 'New World'/The End
2013-03-28 18:44:57 [SERVER] [INFO] Stopping server
2013-03-28 18:44:57 [SERVER] [INFO] Saving players



Please let me know if you can figure out how to help me, and xsaeshx or if you need more information.

#4

TheCyberTronn
  • Location: The green arrow in the bottom right hand corner!
  • Minecraft: cybermanme

Posted 02 April 2013 - 02:33 PM

It's a RAM thing. The only way of fixing it (That I know of) is to completely bump up your specs. RAM and CPU are the parts to upgrade.
Posted Image

#5

inversedarkfox

Posted 02 April 2013 - 11:13 PM

View PostTheCyberTronn, on 02 April 2013 - 02:33 PM, said:

It's a RAM thing. The only way of fixing it (That I know of) is to completely bump up your specs. RAM and CPU are the parts to upgrade.

Thats a bit weird for me as I have upgraded from 4 to 8 GB of ram and the CPU is pretty fast for my mac.  I haven't had these problems before and I didn't think that mods were that memory hogish.

#6

FC360
    FC360

    Stone Miner

  • Members
  • 94 posts

Posted 11 May 2013 - 07:30 PM

I have the same and find it hard to believe it's a ram problem since I get it on both my PC and my laptop however my circumstances are different as I'm getting it on a FTB modpack but yet don't get it on another modpack which uses some of the same mods. If it was the ram then you would be experiencing issues outside of Minecraft too and I for 1 am not, I did have some bad ram but recently replaced it with my currently installed 2x4GB ram sticks.

#7

olagarde
    olagarde

    Tree Puncher

  • Members
  • 21 posts

Posted 15 June 2013 - 10:37 PM

I think it's in the A.E. mod.

It only happens to me when A.E. specific blocks are spawned *and* placed in the world.  Rate of incidence increases roughly linearly with the number of recipes added to the A.E. crafting provider module (I'm testing with the minimum size, 3x3x3).  It also appears to trigger much more regularly with longer chains of crafting recipies;  I've tested with recipies for storage units since they're roughly 3N additive with respect to the number of constraints that have to be resolved to satisfy each successively higher recipie, ie: storage cell --> segment --> block --> cluster.  If I add one more layer, such as trying to autocraft a 64k storage unit (which requires a cluster, which requires 3 blocks, each of which requires three segments, etc., etc.) the failure is, so far, 100% repeatable.

Interestingly I've also noticed that failures with lower ranks of recipe "chaining" are usually not fatal, and that the longer the "chain" the more often they are fatal (ie., by locking up entirely or dropping mc into one fatal dump or another).

#8

olagarde
    olagarde

    Tree Puncher

  • Members
  • 21 posts

Posted 15 June 2013 - 10:51 PM

Also, from the system diags side of the fence:

- no memory bounding issues reported via strace (no alloc failures, no tremendous growth in segment footprint)
- no significant swap activity during any failures (swap activity delta across failure is less than 1%)
- no significant memory pressure at peak load or during any failures (max so far is ~2.2G, cap is 3G)

I'm gonna bet a coffee it's not a memory problem at all.

BTY the strace is just an 'strace -fFvp {task}' where {task} is the java launch with the session key already determined so that the strace can monitor MC rather than an MC launcher, ie.,

#!/bin/sh

USERNAME='FOO'
PASSWORD='BAR'

JAVAOPTS='-d64 -Xms1024m -Xmx2048m'
CLASSPATHS='minecraft.jar;lwjgl.jar;lwjgl-util.jar;jinput.jar'
MAINCLASS='net.minecraft.client.Minecraft'


STRACE="{path to strace de jour}/strace -fFvp "


if [ ! -z "$1" ] ;then
    SESSION=$(/usr/bin/curl -s -d "user=$USERNAME" -d "password=$PASSWORD" -d "version=13" https://login.minecraft.net |/usr/bin/cut -d: -f4)
    if [ -r "$1/bin/minecraft.jar" ] ;then
    $STRACE /usr/bin/java $JAVAOPTS -Djava.library.path="$1/bin/natives/" -cp "$1/bin/*" "$MAINCLASS" # "$USERNAME" "$SESSION"
    else
    /bin/echo "unable to find/read '$1/bin/minecraft.jar'"
    fi
else
    echo 'no minecraft build location specified'
fi



#9

olagarde
    olagarde

    Tree Puncher

  • Members
  • 21 posts

Posted 16 June 2013 - 02:52 AM

Sorry, forgot -- drop the '-p' strace flag unless you're attaching to a pre-existing PID on a "sufficiently POSIX.2 compliant" platform.

#10

minecraftnut

Posted 16 June 2013 - 08:30 AM

Just throwing more ram at a client is rarely the fix for such problems. If you are not running with a 64x64 or higher texture pack, then you shouldn't need gigabytes of ram allocated for Minecraft.

I noticed a huge memory usage difference between 1.4.7 and 1.5.x With 1.5.2, I can't get a 32bit java minecraft client running well with a moderate modpack.
Up to MC 1.5 , you could easily run a heavily modded MC client using 32 bit java 7 with -Xms512mb -Xmx1gb. With graphics turned down to fast and rendering to normal and playing on server (so your client isn't generating the chunks), you could even combine it with a 32x32 texture pack. With 1.5.2 I haven't been able to do this yet without getting ridiculous lagspikes (with high fps). Memory usage keeps running against max memory.
My guess, 1.5.2 has a memory leak, which becomes more noticable if you are running mods.

#11

Muphet
    Muphet

    Tree Puncher

  • Members
  • 37 posts
  • Location: Poland
  • Minecraft: muphet

Posted 27 June 2013 - 03:53 PM

u have to be wrong.
Today i made own pack with like 100 mods and everything worked fine. I launched game like 3 times no problem.
I restarted PC and game loads forever, and logs says exactly same as guy above. I've got 16gb of RAM and never experienced this problem. It just happened with no reason.

there must be bug with some mods

#12

Max Littlemore

Posted 04 August 2013 - 03:23 AM

I just found this doing a google search for "memory connection overburdened minecraft"
@Muphet, you have to be wrong. I don't have any mods on my copy of Minecraft and this issue happens frequently for me. I haven't done as much research as others above, all I have done is increased the amount of memory available at launch and this delayed the onset of the problem, but after that initial delay the problem seems as frequent.
For me moving too quickly seems to make it happen more. For example if I flick the mouse for a rapid 180 degree turn, the game graphics slow to a crawl and the warning pops up in the log.
I think there's definitely some sort of memory management issue in more recent versions of minecraft, possibly an interaction between minecraft and lwjgl. It only started for me with more recent versions.

#13

Dracolyth

Posted 28 August 2013 - 08:27 PM

It looks like it might be mod problems with Forge. I think it was Chickenbones had a note at the top of his mod that said for 1.6.2 that you need to use scala-library.jar because of an error in Forge. I recently took that out of my mods folder and started getting this error. So maybe get that mod (on the Forge website maybe?) and that might help at least some of your problem.

#14

noc00
    noc00

    Tree Puncher

  • Members
  • 18 posts

Posted 08 November 2013 - 01:28 PM

I also have this prroblema with 1.6.4! mod I have a package of personnel and are about 65/70 mod and when I open the client every now and then gives me an error that says:

minecraft connenction overburdened, after processing 2500 packets, we still have to go!
Cant 'keep up! did the system time change or is the server overloaded?

I do not understand why it's so ... my old package had 91 mods on 1.5.2 and I have never had problems with 1.6.4 and has started to make me so ... I note that in less than 20 mod

as it does tell me that the server is overloaded when I'm opening the client minecraft? how you can solve?

#15

Sgt_Madness
  • Location: England
  • Minecraft: TomL2000

Posted 04 December 2013 - 01:39 AM

I'm having this problem only in 1.6.4. This happens when I reach around 100 mods or so. It never happened before, in 1.5.2, I was using over 320 mods and it was fine... -_-
I too have a fairly decent PC.

   Posted Image


#16

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8080 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 04 December 2013 - 01:43 AM

View PostSgt_Madness, on 04 December 2013 - 01:39 AM, said:

<SNIP>
Then make your own thread detailing your issue with error logs etc.