Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Forge has found world ID mismatches


  • Please log in to reply
8 replies to this topic

#1

DieXyberGamer

Posted 15 February 2013 - 07:24 PM

Hello i just installed Tropicraft on my Minecraft-Vanilla Server and I played with some friends.But since today i can not join the Server anymore.When i log in it says:


Forge Mod Loader has found world ID mismatches
ID 22760 (ModID: WeatherMod, type weather.worldObjectives.ItemTornado) is missing
ID 22761 (ModID:WeatherMod, type weather.worldObjectives.ItemTornado) is missing
ID 1900 (ModID: WeatherMod, type weather.blocks.BlockTSensor) is missing
ID 190 (ModID: WeatherMod, type weather.blocks.BlockTSiren) is missing
ID 22758 (ModID: WeatherMod, type weather.worldObjectives.ItemTornado) is missing
ID 22759 (ModID: WeatherMod, type weather.worldObjectives.ItemTornado) is missing
ID 22757 (ModID: WeatherMod, type weather.worldObjectives.ItemTornado) is missing


If you need more Information im free to give it to you :D


Sorry if i make mistakes my grammar sucks. :D

Register or log in to remove.

#2

TheITGS
    TheITGS

    Ghast Hunter

  • Members
  • 2575 posts
  • Location: Right behind you. With a Nokia 3310. Lethal.

Posted 15 February 2013 - 07:41 PM

Looks like some files are missing... Try re-downloading and re-installing the mod.

Posted Image


#3

DieXyberGamer

Posted 15 February 2013 - 08:15 PM

Thanks but it is still not working :D

Could it be the config file in the config folder in the server?

#4

xblastz123
  • Location: Among Thieves
  • Xbox:PS3

Posted 20 February 2013 - 02:15 PM

If you have deleted a mod, the world that you are trying to load has content that is in the mod, so the map will be trying to load with the stuff that was in the mod but then that stuff is gone so it cant, so forge tells you that you haven't got it by saying ID mismatches.

Other reason could be because you didn't install the mod well.
Please wait while I attempt to give a damn...
Posted Image  

#5

MineWaffle

Posted 27 February 2013 - 11:18 PM

Yeah, but I think he means, "How do I get all of the block ID mismatches out of the world without deleting it?

#6

KickFlow
    KickFlow

    Zombie Killer

  • Members
  • 203 posts
  • Location: That's....... •_•) ( •_•)>⌐■-■ (⌐■_■) confidential
  • Minecraft: snag2ninjaboi

Posted 03 March 2013 - 06:38 PM

It may be a case of mis-matched config files. If the server and his config files dont share the same ID's then it will give this error.
Posted Image Posted Image Meet Jurinoa and Tarpson, dragons of, what should be, a Earth and Hellfire Dragon. If they doesn't get enough views they might die! So lend a hand will you?

#7

Conraad
    Conraad

    Iron Miner

  • Curse Premium
  • Curse Premium
  • 250 posts

Posted 28 March 2013 - 01:09 PM

We encountered some Forge MisMatch ID's yesterday and googling the error brought me to this thread, which did not solve my problem, but after some intense bug hunting we finally found the problem, and I thought it would be best to share this here on this thread for anyone in the future that might be experiencing this problem or similar problems.

Now it appears Forge now has a variety of reason why it would spit out mismatch ID's between client and server:

The ID Mismatch from this thread comes from a world being loaded that has block id's either not being used due the mods being removed.

Another instance comes from the client and server config files for the mods being used not being the same, so your client and server config files need to match so the block ID and Item ID must match.

If your server is being upgraded and you remove any mods, the existing Block id's used by the mod not present anymore will cause problems when blocks from that mod has been placed in world, this could default to zero id entities and cause all sort's of weird problems, so as a precaution if you do remove a mod entirely use MidAs world id changer and change the block id that was used by this mod to something like dirt and you problem will be solved, you can also use that tool to swap out block id's and comes in handy when you have mods on block id's where minecraft is now using that same block id.

Now another instance where your client will spit out the mismatch error and dissalow you to connect is when the loading order of your mods aren't the same, now back in the days this would not have cause a problem but it does now, so make sure that the loading order is exactly the same, and example of this would be we had repower on the server using the original jar names, but on the client connecting to the server the redpower files were rename to have a y in front like yredpower.jar  redpower loaded after mod x on client and before mod x on server and amazingly that cause a mismatch id and client could not connect why in the world that would be like that I have no idea but it had some implications.

Forge modloader has an extensive log file being generated now, but it won't always provide you with this type of information so i hope this helps someone in the near future.
Posted Image

#8

Crazy_Mind

Posted 08 June 2013 - 05:32 PM

I found the way to solve this problem! The first thing you have to do is download the mod ID Resolver, install and run the game minecraft. In the boot menu enter the game options and then in Global Mod Option. There, open ID Resolver, open and pressing Reload Entries Generate ID Status Report with Expanded Free IDs. Ahead, in the txt document you just created, you can find what is the mod that have IDs that cause the problem. Later in the same document txt search free slots. You go to the folder".minecraft" and open the mod file in the folder "config" that contains the problematic IDs, for example, in the case of BuildCraft, the file that contains the IDs is called "main.conf". Then you have to open the file with blog notes and change the number of IDs problematic for to the free slots. Any doubt tell :)

#9

Loudgreencow
  • Minecraft: Warpiggy22

Posted 22 July 2013 - 06:03 PM

i got id 17