Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Bukkit - java not recognized


  • Please log in to reply
39 replies to this topic

#1

PrettyLazy

Posted 04 February 2013 - 01:14 PM

Hi guys. Trying to run a bukkit server for me & my friends, and I get this error-
'Java' is not recognized as an internal or external command

I'm running Windows 8 64-bit.

Here's my Java path which I put into my environmental variables
C:\Program Files (x86)\Java\jre7\bin\java.exe

I've reinstalled Java twice. Can anyone help me out?

Register or log in to remove.

#2

CorruptedHelix

Posted 04 February 2013 - 01:26 PM

How are you running Bukkit? You need to launch it with a batch script, which can be found here.
If I helped you, make sure to upvote my posts.

#3

PrettyLazy

Posted 04 February 2013 - 01:28 PM

View PostCorruptedHelix, on 04 February 2013 - 01:26 PM, said:

How are you running Bukkit? You need to launch it with a batch script, which can be found here.

Yes I'm running it through a .bat file in my documents. Sorry I forgot to mention that. Here's the contents of the .bat
java -Xms1024M -Xmx1024M -jar craftbukkit.jar -o true
PAUSE

#4

CorruptedHelix

Posted 04 February 2013 - 01:40 PM

Is the name of your .jar actually craftbukkit.jar? If it is, I know there's a way to specify a direct path to the java.exe in the .bat, but I forgot what it was...

EDIT: Actually, try installing both Java 32bit and 64bit and then try again.
If I helped you, make sure to upvote my posts.

#5

kyle_will_eat_u
  • Location: Scotland
  • Minecraft: Kyle_will_eat_u

Posted 04 February 2013 - 01:53 PM

Hey PrettyLazy, you want to make sure the batch file is located in the same folder as the craftbukkit.jar. You also want to make sure that you rename the Craftbukkit you downloaded to Craftbukkit or in the batch file change it to the snapshot name.

Batch should look like this
java -Xms1024M -Xmx1024M -jar craftbukkit.jar -o true
PAUSE
And your craftbukkit.jar should say craftbukkit.jar not craftbukkitsnapshot1.4.7.jar.

Posted Image


#6

PrettyLazy

Posted 04 February 2013 - 02:01 PM

It wasn't craftbukkit.jar but I changed it to that and it didn't work. My batch does look like that btw.

@Corrupted; can't seem to find a Java 32 bit installation on the Java site. It picks up that I'm on Windows 8 and gives me an automatic download of the 64 bit version.

#7

bedmen
    bedmen

    Iron Miner

  • Members
  • 326 posts
  • Location: holland
  • Minecraft: bedmen123

Posted 04 February 2013 - 04:11 PM

il prefer you to use spigot and not craftbukit first of all it wil increase the speed of your server and it might fix the problem
If my I was helpful you can leave a donation (Klik on this text).
I wil be 99% of the time be open to install plugins for you or give advice.

#8

PrettyLazy

Posted 04 February 2013 - 04:16 PM

To be honest I just want to be able to use /spawnmob and such on my server. I know it's easy to do with Bukkit.

#9

bedmen
    bedmen

    Iron Miner

  • Members
  • 326 posts
  • Location: holland
  • Minecraft: bedmen123

Posted 04 February 2013 - 04:57 PM

View PostPrettyLazy, on 04 February 2013 - 04:16 PM, said:

To be honest I just want to be able to use /spawnmob and such on my server. I know it's easy to do with Bukkit.

try to download other versions of java. that might fix it
If my I was helpful you can leave a donation (Klik on this text).
I wil be 99% of the time be open to install plugins for you or give advice.

#10

PrettyLazy

Posted 04 February 2013 - 05:12 PM

Tried that already

#11

bedmen
    bedmen

    Iron Miner

  • Members
  • 326 posts
  • Location: holland
  • Minecraft: bedmen123

Posted 04 February 2013 - 05:23 PM

i mean i heard of special java extensions!
If my I was helpful you can leave a donation (Klik on this text).
I wil be 99% of the time be open to install plugins for you or give advice.

#12

PrettyLazy

Posted 05 February 2013 - 05:15 AM

Bump - please help me guys.

#13

AliStarr
    AliStarr

    Retired Staff

  • Retired Staff
  • 4280 posts
  • Location: Adelaide, South Australia
  • Minecraft: AliStarr
  • Xbox:WalkIngD1sasT3R

Posted 05 February 2013 - 06:56 AM

Maybe try run your command prompt as admin?

And don't bump your thread please.

Posted Image


Please quote me to get my attention in a thread.

Please read the forum global rules, server section rules and Bumping rules before posting.


#14

PrettyLazy

Posted 05 February 2013 - 07:10 AM

View PostAliStarr, on 05 February 2013 - 06:56 AM, said:

Maybe try run your command prompt as admin?

And don't bump your thread please.

Tried that. So wait, if no one is able to help me, I just have to leave it at that?... Fair enough.

#15

AliStarr
    AliStarr

    Retired Staff

  • Retired Staff
  • 4280 posts
  • Location: Adelaide, South Australia
  • Minecraft: AliStarr
  • Xbox:WalkIngD1sasT3R

Posted 05 February 2013 - 07:14 AM

It's the forum rules.

There is a solution for this. I had it for a while but I can't remember how I fixed it. I'll do some searching.

Do you have java6 installed?

here is the link for 32bit java for windows. (Version 6 Update 39)

Posted Image


Please quote me to get my attention in a thread.

Please read the forum global rules, server section rules and Bumping rules before posting.


#16

PrettyLazy

Posted 05 February 2013 - 07:27 AM

View PostAliStarr, on 05 February 2013 - 07:14 AM, said:

It's the forum rules.

There is a solution for this. I had it for a while but I can't remember how I fixed it. I'll do some searching.

Do you have java6 installed?

here is the link for 32bit java for windows. (Version 6 Update 39)

I just installed that to give it a try, same results =(

#17

AliStarr
    AliStarr

    Retired Staff

  • Retired Staff
  • 4280 posts
  • Location: Adelaide, South Australia
  • Minecraft: AliStarr
  • Xbox:WalkIngD1sasT3R

Posted 05 February 2013 - 07:36 AM

Restart your computer, then point your environment path to the 32bit java then try again

Posted Image


Please quote me to get my attention in a thread.

Please read the forum global rules, server section rules and Bumping rules before posting.


#18

Dr_Alopex

Posted 23 March 2013 - 09:34 PM

I have the same problem trying to get bukkit going.  According to bukkit's instructions you are supposed to add the java path to Windows 8 so that you can run that batch file.  I added it to the path, but when I run the batch file it give the same error PrettyLazy is reporting.  

CorruptedHelix said "I know there's a way to specify a direct path to the java.exe in the .bat".  Does anyone know how that is done?  Being able to run that batch file will most likely solve everything.

#19

Dr_Alopex

Posted 23 March 2013 - 09:53 PM

Okay, I solved the problem and I came back here to let PrettyLazy and anyone else know how I did - hope this works for you too.  You have to successfully get the Java.exe directory into your windows path.

You have to go to My Computer and right click to get properties, then choose Advanced System Settings.  At the bottom of the window that pops up click Environment Variables. Find the variable "path" and highlight it select Edit.  

Here is where you are supposed to put a semi-colon at the end and add your path, which for my version of java and Windows 8 was: C:\Program Fiels (x86)\Java\jre7\bin .  However, this wasn't working.  I finally tried adding that at the very beginning as the first path defined and put a semi-colon after it, and it worked.  For whatever reason it wasn't accepting the path addition at the end.  

Then I ran the batch file for Bukkit, no problem.  Good luck to anyone else having this issue.  It was very frustrating because there is apparently no solution posted anywhere that I can find.

#20

The11thDoctor

Posted 30 March 2013 - 05:23 PM

I just want to say, what Dr_Alopex said worked for me perfectly, thanks!