Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

NEI error


  • Please log in to reply
7 replies to this topic

#1

PonyAtMe
    PonyAtMe

    Tree Puncher

  • Members
  • 31 posts

Posted 24 January 2013 - 02:18 AM

How do i fix this problem with nei. When I play the game it says error written in nei and some othr stuff. I hope some one can fix this

NEI Version: 1.4.5.1
java.lang.ClassCastException: bu cannot be cast to bq
	at codechicken.nei.NEIClientConfig.loadWorld(NEIClientConfig.java:315)
	at codechicken.nei.ClientPacketHandler.handleSMPCheck(ClientPacketHandler.java:123)
	at codechicken.nei.ClientPacketHandler.handlePacket(ClientPacketHandler.java:26)
	at codechicken.core.PacketCustom$ClientPacketHander.handle(PacketCustom.java:90)
	at codechicken.core.PacketCustom$CustomPacketHandler.onPacketData(PacketCustom.java:59)
	at cpw.mods.fml.common.network.NetworkRegistry.handlePacket(NetworkRegistry.java:243)
	at cpw.mods.fml.common.network.NetworkRegistry.handleCustomPacket(NetworkRegistry.java:233)
	at cpw.mods.fml.common.network.FMLNetworkHandler.handlePacket250Packet(FMLNetworkHandler.java:71)
	at ayh.a(NetClientHandler.java:1483)
	at di.a(SourceFile:59)
	at cf.b(MemoryConnection.java:80)
	at net.minecraft.client.Minecraft.l(Minecraft.java:1909)
	at net.minecraft.client.Minecraft.J(Minecraft.java:846)
	at net.minecraft.client.Minecraft.run(Minecraft.java:771)
	at java.lang.Thread.run(Unknown Source)

bump

Register or log in to remove.

#2

NobodyCare
    NobodyCare

    Retired Staff

  • Retired Staff
  • 1112 posts
  • Minecraft: NobodyCare

Posted 24 January 2013 - 11:05 AM

Try installing forge in a new minecraft.jar. Also, you should make sure that NEI and CCC are in the coremods folder.

Please quote my post when you are replying to me so that you make sure that I read it.

  Global Rules    Mapping and Modding


#3

Atlantisspy

Posted 25 January 2013 - 05:26 AM

You're most likely missing ChickenBonesCore,
Posted Image
A mysterious force pulls towards the eggs....

#4

Smurfoid
    Smurfoid

    Zombie Killer

  • Members
  • 246 posts

Posted 28 January 2013 - 04:05 PM

Eh, ccc can't be the problem. I got the same problem, I've got the most recent version of both mods (just)installed, and it still gives this error. Might try using a new forge, but I am using ftb, so?!?
Posted Image

#5

mgriffith67
  • Location: New England USA

Posted 31 January 2013 - 04:33 PM

I am getting the same errors!!  It totally screwed up our FTB world/quarry and my NEI invo pages.  UGH!! it happened after the FTB update the other day too. I tried fresh install and everything. Don't quite know what to do Posted Image

#6

xtremeqg

Posted 01 February 2013 - 10:32 PM

I just encountered this issue myself... Im not entirely sure what the root cause is but I guess it is due to corrupted mod and/or config files. Personally, I am using the FTB launcher in order to obtain the Direwolf20 mod pack. Initially I tried a force update using the launcher after deleting the mod folder... However this was not enough as the error remained.

The solution was to backup my saves folder (and options.txt) and delete the entire minecraft folder (except launcher). I then forced update once more and obtained a 100% clean installation. I then placed back my saves folder and options.txt.

Just to be sure, I also deleted the NEI.dat and NEI folder that reside in the saves folder. I am not entirely sure, but I think these two items may be the root problem.

After this your world should load fine once again, with NEI functioning properly. You will have to reset your quarrys (break them, place landmarks, place quarry) as their state seems corrupted.

#7

nDutio
    nDutio

    Out of the Water

  • Members
  • 6 posts

Posted 20 February 2013 - 03:44 AM

I solved the problem, I just deleted the NEI folder and the file nei.dat. Then I opened the launcher and worked.

#8

iggy30
    iggy30

    Out of the Water

  • Members
  • 2 posts

Posted 15 May 2013 - 08:53 PM

I'm having a similar problem except it occurs when forge is loading. It go's until it says minecraft validated, launching. It then just stops. The mods I have are ferullos gun mod, shurtugal, thaumcraft 3, metallurgy 3, rei's minimap, eight bit pack, and twilight forest. I know I installed everything correctly. I've force updated and even deleted my .minecraft folder yet nothing works and when I delete the nei folder it still wont work and I cant find the nei.dat. I really need the mod since I cant remember every recipe so can you please help me. There's no files in my saves folder.