Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

What firewall ports need to be open for internal lan only - Windows 8

firewall ports 25565

  • Please log in to reply
4 replies to this topic

#1

mojomatt
    mojomatt

    Out of the Water

  • Members
  • 3 posts

Posted 26 December 2012 - 11:48 PM

Hi Guys,  I'm running a Minecraft server on Windows 8.  I can connect to it just fine from the same box the server is running on.  When I try to connect to it from another server on the same internal network, I'm blocked.  If I allow tcp port 25565 traffic to the server, I'm still blocked.  If I disable the private firewall, then I can connect to it from other pc's on my lan.  I noticed that when I do connect, it's not over port 25565 but seemingly a random port such as 50457 according to the Minecraft Server display.  Does anyone know what settings are needed to the Windows 8 firewall to allow other pc's on my internal lan to connect to the Minecraft server?  I'd rather not disable the private firewall.  Thanks in advance for any suggestions.

Register or log in to remove.

#2

mojomatt
    mojomatt

    Out of the Water

  • Members
  • 3 posts

Posted 27 December 2012 - 01:01 AM

Continued...  This is the output from my server... [INFO] Starting minecraft server version 1.4.6
[INFO] Loading properties
[INFO] Default game type: CREATIVE
[INFO] Generating keypair
[INFO] Starting Minecraft server on *:25565
[INFO] Preparing level "world"
[INFO] Preparing start region for level 0
[INFO] Done (0.692s)! For help, type "help" or "?"
[INFO] ReachesHigh[/127.0.0.1:50457] logged in with entity id 59 at (-232.36201625800567, 64.0, -283.6811198626373)

#3

mojomatt
    mojomatt

    Out of the Water

  • Members
  • 3 posts

Posted 27 December 2012 - 02:08 AM

Finally figured it out.  Although I had my inbound rule properly set, Java had programmatically set up a firewall rule to block all inbound traffic using targeting the javaw.exe program.  Therefore, to fix the issue I had to adjust that rule and remove it from the private firewall profile.  All is good now.

#4

linemen
    linemen

    Tree Puncher

  • Members
  • 21 posts

Posted 31 December 2012 - 12:19 AM

I have the same problem. Could you tell me what exactly you did?

View Postmojomatt, on 27 December 2012 - 02:08 AM, said:

Finally figured it out.  Although I had my inbound rule properly set, Java had programmatically set up a firewall rule to block all inbound traffic using targeting the javaw.exe program.  Therefore, to fix the issue I had to adjust that rule and remove it from the private firewall profile.  All is good now.


#5

linemen
    linemen

    Tree Puncher

  • Members
  • 21 posts

Posted 31 December 2012 - 04:22 AM

Got it done. Windows Firewall advanced settings, inbound connections, for Java open the ports TCP and UDP.