Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Modloader 1.4.5 getting it to work with Minecraft 1.4.5


  • Please log in to reply
20 replies to this topic

#1

warriorellis

Posted 29 November 2012 - 12:55 AM

Hi,

Having problems with Modloader 1.4.5. I am familiar with the process of loading Modloader into the minecraft jar and have had Modloader work for me when using Minecraft 1.2.5. However, every version since then I can not get mods to work and Minecraft crashing on loading.

I run %appdata% which takes me to .minecraft folder. inside this folder is the bin folder which has the minecraft jar zip file.

Inside the minecraft jar is a Meta INF folder.

I delete the meta INF folder

I then open up Modloader zip file 1.4.5 and drag all the files into the minecraft jar

I do the same for Modloader MP

and the same for Forge(as some mods require Forge)

I have read that you have to do it in this order or things won't work.

On running minecraft it crashes.

I have a Train Mod which worked in version 1.2.5 but since then Mods just don't like working and Modloader seems to make Minecraft crash.

Can anyone give me some advice.

thanks

paul

Register or log in to remove.

#2

joshy020504

Posted 29 November 2012 - 01:13 AM

Dont Know.

#3

Lithead
    Lithead

    Newly Spawned

  • Members
  • 1 posts

Posted 29 November 2012 - 01:16 PM

Modloader and Forge are not compatible. I saw this mentioned in the mod list for 1.4.4 and 1.4.5 mods. Sorry D:

#4

warriorellis

Posted 30 November 2012 - 03:54 AM

I have the most recent Minecraft 1.4.5 and have now ditched Modloader and modloader MP. Instead i have Minecraft Forge and when I run minecraft it says I have 3 mods.

All my old mods don't work. Is that because they are for a different minecraft version like 1.2.5 or 1.3.1 etc?

Now I am using version 1.4.5 do all my mods need to be for that version for them to work.

Thanks

paul

#5

nworB_cirE
    nworB_cirE

    Lapis Lazuli Collector

  • Members
  • 936 posts
  • Location: Utah, USA
  • Minecraft: nworB_cirE

Posted 30 November 2012 - 03:55 AM

View Postwarriorellis, on 30 November 2012 - 03:54 AM, said:

I have the most recent Minecraft 1.4.5 and have now ditched Modloader and modloader MP. Instead i have Minecraft Forge and when I run minecraft it says I have 3 mods.

All my old mods don't work. Is that because they are for a different minecraft version like 1.2.5 or 1.3.1 etc?

Now I am using version 1.4.5 do all my mods need to be for that version for them to work.

Thanks

paul

Yes. All mods have to match the minecraft version.
Posted Image
PLEASE! Learn to use spoiler tags, especially when posting crash reports: [spoiler]YOUR TEXT HERE[ /spoiler]

#6

warriorellis

Posted 30 November 2012 - 04:02 AM

when a new version of minecraft is released how do you keep the old version that you already have so that your existing mods still work. Is there a way of having separate minecraft folders for each version on your computer?

warriorellis

#7

SilverSatin
  • Location: your very nosey aren't you?

Posted 30 November 2012 - 07:38 PM

Why hustle with modloader when   Forge has Forge Modloader that works just fine  ?

..:: CM Cosmos II | Phenom II X4 955 | EVGA GTX 670 SC2 | Corsair 16 GB Vengeance | Asus Crosshair V Formula-Z ::..
..:: WD Caviar 3TB | WD Caviar 2TB | WD Caviar 2TB | WD Caviar 320GB | Patriot SSD 30GB ::..


#8

warriorellis

Posted 01 December 2012 - 01:08 AM

Agree. I am now using Forge but when a new version of minecraft gets released and you update the version all your mods are afftected and none work. You then have to wait until until your mods are updated to the new version of mincraft and update your minecraft jar with the new files.

Is there a simpler way of this not happening everytime a new release of minecraft gets released.

#9

nworB_cirE
    nworB_cirE

    Lapis Lazuli Collector

  • Members
  • 936 posts
  • Location: Utah, USA
  • Minecraft: nworB_cirE

Posted 01 December 2012 - 01:46 AM

View Postwarriorellis, on 30 November 2012 - 04:02 AM, said:

when a new version of minecraft is released how do you keep the old version that you already have so that your existing mods still work. Is there a way of having separate minecraft folders for each version on your computer?

warriorellis

Yes, get MultiMC or MagicLauncher to have multiple instances of minecraft. To downgrade, use MCNostalgia.
Posted Image
PLEASE! Learn to use spoiler tags, especially when posting crash reports: [spoiler]YOUR TEXT HERE[ /spoiler]

#10

warriorellis

Posted 01 December 2012 - 02:56 PM

View PostnworB_cirE, on 01 December 2012 - 01:46 AM, said:

Yes, get MultiMC or MagicLauncher to have multiple instances of minecraft. To downgrade, use MCNostalgia.


Thanks to you guys for all the advice. Modding is new to me and i'm doing this for my 9yr old. I really do appreciate any positive comments that will help me to mod. BTW he's been wanting a mod called Christmascraft but it's version 1.0 and when I put this into his minecraft jar it screws his minecraft up and minecraft won't load. Would this be because the mod is not the same version as my minecraft 1.4.5?

Thanks, I will try using MultiMC or MagicLauncher  as you suggest.

Paul

#11

Ewery1
    Ewery1

    Zombie Killer

  • Members
  • 191 posts
  • Location: A place that exists. I think.
  • Minecraft: Ewery1

Posted 02 December 2012 - 12:34 PM

Forge and Modloader are incompatible, just download fml (forge mod loader), it adds modloader along with forge.

#12

xXNerdxProXx

Posted 03 December 2012 - 06:06 AM

can someone post a link to download FML? Thanks
Posted Image

#13

Hov
    Hov

    Gold Miner

  • Members
  • 479 posts

Posted 03 December 2012 - 09:00 PM

http://www.minecraftforge.net/forum/

#14

chri60a1

Posted 04 December 2012 - 09:41 PM

View Postwarriorellis, on 30 November 2012 - 04:02 AM, said:

when a new version of minecraft is released how do you keep the old version that you already have so that your existing mods still work. Is there a way of having separate minecraft folders for each version on your computer?

warriorellis
'


yes just go to %APPDATA%/roaming
and either copy it and paste it somewhere else or just rename it from .minecraft to whatever.

View PostSilverSatin, on 30 November 2012 - 07:38 PM, said:

Why hustle with modloader when   Forge has Forge Modloader that works just fine  ?
Depends on the modder, dosn't really matter for the users. some say its best to code a mod in Modloader, some say forge.
Posted Image

#15

Theoxylo
    Theoxylo

    Zombie Killer

  • Members
  • 230 posts

Posted 04 December 2012 - 10:05 PM

To the OP: ModLoaderMP is only available for 1.3.2, not 1.4.5.

#16

zubazoo
    zubazoo

    Tree Puncher

  • Members
  • 16 posts
  • Location: Stalking you from your window...
  • Minecraft: zubazoo

Posted 06 December 2012 - 05:14 AM

I got a crash after installing modloader on 1.4.5 vanilla and got this

---- Minecraft Crash Report ----
// Daisy, daisy...

Time: 12/6/12 12:08 AM
Description: Exception occured in ModLoader

java.lang.VerifyError: (class: mod_WeirdHybrids, method: addRenderer signature: (Ljava/util/Map;)V) Incompatible argument to function
    at java.lang.Class.getDeclaredFields0(Native Method)
    at java.lang.Class.privateGetDeclaredFields(Unknown Source)
    at java.lang.Class.getDeclaredFields(Unknown Source)
    at ModLoader.setupProperties(ModLoader.java:1964)
    at ModLoader.addMod(ModLoader.java:372)
    at ModLoader.readFromModFolder(ModLoader.java:1380)
    at ModLoader.init(ModLoader.java:900)
    at ModLoader.addAllRenderers(ModLoader.java:215)
    at bbj.<init>(RenderManager.java:93)
    at bbj.<clinit>(RenderManager.java:14)
    at net.minecraft.client.Minecraft.a(SourceFile:259)
    at net.minecraft.client.Minecraft.run(SourceFile:515)
    at java.lang.Thread.run(Unknown Source)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- System Details --
Details:
    Minecraft Version: 1.4.5
    Operating System: Windows 7 (x86) version 6.1
    Java Version: 1.7.0_09, Oracle Corporation
    Java VM Version: Java HotSpot™ Client VM (mixed mode), Oracle Corporation
    Memory: 402235184 bytes (383 MB) / 518979584 bytes (494 MB) up to 1037959168 bytes (989 MB)
    JVM Flags: 2 total; -Xms512m -Xmx1024m
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Suspicious classes: ModLoader, EntityRendererProxy, ModTextureStatic, ...]
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    ModLoader: Mods loaded: 1
ModLoader 1.4.5

#17

Hov
    Hov

    Gold Miner

  • Members
  • 479 posts

Posted 06 December 2012 - 04:11 PM

Don't use Modloader just Forge it has modloader in it.

#18

promodude511

Posted 08 December 2012 - 02:09 AM

Hey, I think I know why it's not working.  There are certain versions of Modloader, ModloaderMP, and Forge. These versions have to be by the same person unless there the ones on the forums. If not, they aren't compatabe with each other. Forge for 1.3.1 to 1.4.5 also isn't compatable with modloader 1.3.1 to 1.4.5 or modloaderMP 1.3.1 to 1.4.5 and so on

If you dont belive it. BELIVE IT!!!!!!!!!!!!!!

#19

Matt0706
    Matt0706

    Out of the Water

  • Members
  • 2 posts

Posted 14 December 2012 - 03:34 AM

View Postwarriorellis, on 30 November 2012 - 03:54 AM, said:

I have the most recent Minecraft 1.4.5 and have now ditched Modloader and modloader MP. Instead i have Minecraft Forge and when I run minecraft it says I have 3 mods.

All my old mods don't work. Is that because they are for a different minecraft version like 1.2.5 or 1.3.1 etc?

Now I am using version 1.4.5 do all my mods need to be for that version for them to work.

Thanks

paul
   Yes paul, the mods that are outdated do not work on the new files, things get switched for the better, and the files have to be ready for the version ;D

#20

Ora the Owlish
  • Location: In a tree, stealing your internet connection.

Posted 14 December 2012 - 04:52 AM

View Postwarriorellis, on 01 December 2012 - 02:56 PM, said:




Thanks to you guys for all the advice. Modding is new to me and i'm doing this for my 9yr old. I really do appreciate any positive comments that will help me to mod. BTW he's been wanting a mod called Christmascraft but it's version 1.0 and when I put this into his minecraft jar it screws his minecraft up and minecraft won't load. Would this be because the mod is not the same version as my minecraft 1.4.5?

Thanks, I will try using MultiMC or MagicLauncher  as you suggest.

Paul

ChristmasCraft is definitely a 1.4.5 mod--your problem is likely your method of installation. It goes in the "mods" folder, not the .jar. :)
Ask me about giant, Canadian, zombie-steampunk tyrannosaurus rexes. Posted Image
I own one, and her name is Cuddlemuffins.