Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Draw distance in Minecraft?


  • Please log in to reply
10 replies to this topic

#1

Smac
    Smac

    Zombie Killer

  • Members
  • 205 posts
  • Location: Bay Shore, NY
  • Minecraft: Smac3223

Posted 12 November 2012 - 10:30 PM

I'm not sure how to explain this. So I have pictures to hopefully show you what I'm talking about.

Now this problem didn't persist in the past and ever since I formatted my computer? It's been here and bothering me to no end...
At first I thought it was a problem with anti-aliasing. I looked up the problem and found that most "before" pictures when compared to the "after" ones looked similar to my problem and how my Minecraft looked. So naturally I tried going into my Nvidia control panel and finding my javaw.exe so I can force anti-aliasing on and hopefully fix my problem.

But of course that did nothing. The problem has never happened before and I cannot for the life of me figure out why it's happening.

Posted Image

Looking at it fullscreen you might see how the dirt REALLY looks like just noise and static instead of just blurred but smooth in the distance. It may be somewhat hard to see in the next picture but hopefully you'll see what I'm talking about. The grass seems to have static simply through out it. I occasionally get random blue lines that cut through, the land resembles a static TV channel with just the black and white fuzz but overlayed onto minecraft so colors show through. It gets worse the further up and back you go in the picture. Of course I don't expect far distance to look pretty, I also don't expect it to look like the land is on vibrate.

Posted Image

This is pure vanilla Minecraft JUST installed. And yes I've tried re-installing a few times already. I've installed the latest drivers and this problem doesn't happen to any other games. Just Minecraft. It's driving me insane.
And before anyone says that's just how Minecraft is supposed to look I played for well around a year without this problem. In addition I've seen HD videos of youtube fullscreen on my second monitor and compared. My game is definitely suffering from something.

I've  been spending more time trying to figure out and fix this problem than actually playing now. As a moderator for my favorite server this is really bothering me as I'd like to get back to playing with all the fine people I've met so far

If anyone has any ideas please speak up, I'm at a loss on how to get my minecraft back to looking normal.

Register or log in to remove.

#2

Luis
    Luis

    Nether Resident

  • Members
  • 2083 posts
  • Minecraft: Luis_

Posted 12 November 2012 - 10:43 PM

I don't see an issue?

#3

Smac
    Smac

    Zombie Killer

  • Members
  • 205 posts
  • Location: Bay Shore, NY
  • Minecraft: Smac3223

Posted 12 November 2012 - 11:23 PM

I'm fearing the only way I'm going to be able to show my problem is if I record a video...but of course if the quality is scaled what I'm trying to show will be undetectable

Posted Image

I know it's rather crude but I looking at it I can clearly see the static. Compare it to the one I posted above and perhaps you'll see the same movement I'm seeing.

Now if you can see it, imagine that rapidly going back and forth and going all fuzzy whenever you move in the slightest. Would get rather annoying no?

#4

Natecraft

Posted 12 November 2012 - 11:39 PM

If you can't get the computer to fix it with built-in settings you could always try Optifine if only to just get access to the Anti-Alising and Mipmapping settings.
ragnarock200: awesome, are those things with the creeper faces pistons or furnaces
Snowey1994: There dispensers

#5

The_Fool76
    The_Fool76

    Glowstone Miner

  • Curse Premium
  • Curse Premium
  • 3032 posts
  • Location: Under the Sea

Posted 12 November 2012 - 11:40 PM

Minecraft doesn't do mipmaps so it's always suffered from that problem.  (Or at least it has since I started playing in alpha)
You generally don't see it in videos because the compression artifacts hide the moire effect you get from the default textures.

The simplest solution is to find a texture pack with less noise in the textures but that tends to mean using the 'simple' packs which might not be the look you want.  Other options include patching your game with a mod that allows mipmaps or distance blurring.
Tis far better to be a witty fool than a foolish wit.
Posted Image

#6

Phycozz
    Phycozz

    Nether Resident

  • Members
  • 2248 posts

Posted 12 November 2012 - 11:45 PM

That's just the way Minecraft looks. Minecraft and your GPU's anti-aliasing don't work together. You could get Optifine which has AA in it.
Posted Image

#7

Smac
    Smac

    Zombie Killer

  • Members
  • 205 posts
  • Location: Bay Shore, NY
  • Minecraft: Smac3223

Posted 12 November 2012 - 11:45 PM

I just don't get it....why would I need a mod or other texture pack or anything when this problem is new? The game used to be smooth for me. Being able to see far without trouble and none of this crazy noise.


I've played for almost a year without this problem. I re-install windows after formatting and get everything set up, go to play Minecraft, and boom. I notice it looks really bad.

#8

Luis
    Luis

    Nether Resident

  • Members
  • 2083 posts
  • Minecraft: Luis_

Posted 12 November 2012 - 11:51 PM

Oh, now I see what your problem is.

Hmm, that's weird. I've never actually noticed that myself and I have an nvidia card. I have anti aliasing turned off, though.

View PostPhycozz, on 12 November 2012 - 11:45 PM, said:

That's just the way Minecraft looks. Minecraft and your GPU's anti-aliasing don't work together. You could get Optifine which has AA in it.

Actually, false. When I enable anti aliasing on my computer, it smooths things out.

#9

The_Fool76
    The_Fool76

    Glowstone Miner

  • Curse Premium
  • Curse Premium
  • 3032 posts
  • Location: Under the Sea

Posted 12 November 2012 - 11:52 PM

View PostSmac, on 12 November 2012 - 11:45 PM, said:

I just don't get it....why would I need a mod or other texture pack or anything when this problem is new? The game used to be smooth for me. Being able to see far without trouble and none of this crazy noise.

I've played for almost a year without this problem. I re-install windows after formatting and get everything set up, go to play Minecraft, and boom. I notice it looks really bad.
Minecraft itself does not do anything that would lead to distant textures being less noisy, so it sounds to me like you had some options set in your video driver that you didn't reset when you re-installed everything.  I suggest opening the control panel for your graphics card and seeing what you can adjust.  

One word of warning, forced anti-aliasing tends to result in faintly visible edges around transparent textures.  So if you start seeing a bunch of 'boxes' around your torches, flowers, and other such things, then that's probably the cause.
Tis far better to be a witty fool than a foolish wit.
Posted Image

#10

asCaio
    asCaio

    Tree Puncher

  • Members
  • 36 posts
  • Location: P. Sherman, 42 Wallaby Way, Sydney
  • Minecraft: asCaio

Posted 12 November 2012 - 11:56 PM

I have the same problem, I found this topic about AA with nvidia, maybe it help you.
http://www.minecraft...r-nvidia-users/

:D


#11

Smac
    Smac

    Zombie Killer

  • Members
  • 205 posts
  • Location: Bay Shore, NY
  • Minecraft: Smac3223

Posted 13 November 2012 - 12:08 AM

asCaio delivers the goods.

When I went to put the anti-aliasing on for my Minecraft I put it on max. 32x CSAA along with 8x supersample. That for some reason blurred it all together or something. I'm not entirely sure. I just lowered the anti-aliasing to simply 8x and I've got my smooth Minecraft back! Even better, the text for John Smith looks absolutely epic once again.

I'm guessing it's as The Fool said, I must've forgotten to re-enable that setting correctly. Guess that makes me the fool =p