Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Mods Dont Work For Me


  • Please log in to reply
4 replies to this topic

#1

synester102

Posted 05 November 2012 - 08:11 PM

Hi everyone. I need some help.

I've tried to install numerous mods, but NONE of them work. i will try to give as many details as i can.

Firstly, i always start with a fresh and updated Minecraft.jar (i force update before trying to install a mod.)
Then, i put in modloader (which i don't even know if it works).
When i tried to install any mod (Tale of Kingdoms, Rei's Minimap, Mo' Creatures, etc.) they don't even work.

First, i download the mod. Then i put the files from the zip into my mincraft.jar using ZipGenious 6. I delete the Meta-inf, and the game starts normally. However, when i start up a world, the mods don't take effect.

I dont know what the problem is. I REALLY want Tale Of Kingdoms, but it never works. Please help me. I dont know what to do.

Also, sorry if you can find an easy solution. Im new to mods, but ive been playing minecraft for a long time (since 1.8 pre-release). Im also new to the forums, so again, sorry if there is such a simple answer that i didnt see.

Register or log in to remove.

#2

DiegoAtravesar
  • Location: Canada
  • Minecraft: DiegoAtravesar

Posted 05 November 2012 - 09:01 PM

View Postsynester102, on 05 November 2012 - 08:11 PM, said:

Hi everyone. I need some help.

I've tried to install numerous mods, but NONE of them work. i will try to give as many details as i can.

Firstly, i always start with a fresh and updated Minecraft.jar (i force update before trying to install a mod.)
Then, i put in modloader (which i don't even know if it works).
When i tried to install any mod (Tale of Kingdoms, Rei's Minimap, Mo' Creatures, etc.) they don't even work.

First, i download the mod. Then i put the files from the zip into my mincraft.jar using ZipGenious 6. I delete the Meta-inf, and the game starts normally. However, when i start up a world, the mods don't take effect.

I dont know what the problem is. I REALLY want Tale Of Kingdoms, but it never works. Please help me. I dont know what to do.

Also, sorry if you can find an easy solution. Im new to mods, but ive been playing minecraft for a long time (since 1.8 pre-release). Im also new to the forums, so again, sorry if there is such a simple answer that i didnt see.
Make sure that if the mod needs Minecraft FORGE that You are getting that. Modloader and Forge are different, and are not always compatible. You could also try using the MultiMC launcher, it greatly simplifies the amount of work required to install mods, and then if something goes wrong, its much simpler to uninstall things.
You also might not need to put the mod in the .jar, many mods haveto be placed in the "/mods" folder now.

Hope this helps some. :)
Servers I play on: NearbyNation Sub Server
Current Project: Universal Configs (On hold currently)

#3

synester102

Posted 05 November 2012 - 09:17 PM

I just tried using Forge instead of modloader, and it still didnt work. I used both (maybe it would have) but it didnt work. I tried not using it at all, and it didnt work. Its just the mods and my computer. I dont think Modloader or Forge have to do with it.

Heres a list of all the mods i can remember trying to install:

Tale of Kingdoms
Rei's Minimap
Mo' Creatures
Creeps & Weirdos
Divine RPG Craft
Elemental Creepers Mod
More Explosions
Planetary Mod

And also, the installation guide to Tale of Kingdoms said to use Modloader. Really, thats the main mod i want.

#4

DiegoAtravesar
  • Location: Canada
  • Minecraft: DiegoAtravesar

Posted 05 November 2012 - 09:47 PM

View Postsynester102, on 05 November 2012 - 09:17 PM, said:

I just tried using Forge instead of modloader, and it still didnt work. I used both (maybe it would have) but it didnt work. I tried not using it at all, and it didnt work. Its just the mods and my computer. I dont think Modloader or Forge have to do with it.

Heres a list of all the mods i can remember trying to install:

Tale of Kingdoms
Rei's Minimap
Mo' Creatures
Creeps & Weirdos
Divine RPG Craft
Elemental Creepers Mod
More Explosions
Planetary Mod

And also, the installation guide to Tale of Kingdoms said to use Modloader. Really, thats the main mod i want.

Quoting directly from the Tales MCF 1.4.2 thread:

Quote

How to Install Tale of Kingdoms?

1: start with a fresh .minecraft that is version 1.4.2!!
2: Delete META-INF!!!!!
3: install Forge version 6.0.1.341
4: Drag TaleOfKingdoms V1.4.0 Pre-Release 4.2 into the mods folder (the whole zip file!!!)
5: test if everything works!! (else start again!)
6: have fun

side note: be patient!!! it takes a while before your world will be loaded, it has to do quite some stuff!!!

ToK needs forge, I recommend getting Forge 349. its the most stable version I've seen recently, and seems to be compatible with the largest number of mods.make sure You put the Tales .zip file in the MODS folder, and that you're not unzipping it into the jar. It wont work in the jar.

Quoting from the Mo Creatures MCF thread:

Quote

To download just click on the right upper corner: 'Skip Ad'

Other files needed:
1. Forge Client(adf.ly) (direct) webpage (Forge 6.0.1)
2. GUI Api 0.14.8
3. CustomMobSpawner 1.7 Mirror (forum)  please make sure you have the latest version of CustomMobSpawner.
Make sure You installed the GUIAPI and Custom MobSpawner as well, otherwise This mod wont work correctly.

Reis will work with whatever, It can go in either the jar or the mods folder, for sake of simplicity, put it in the mods folder.

Creeps and wierdos doesn't appear to have updated out of 1.2.5 yet, which means You won't be using it unless You want to be using 1.2.5 mods for ALL of the above mods. I'd recommend skipping this mod until it updates to 1.4.2.

Divine RPG should only require Forge, based on its MCF thread.

Elemental Creepers hasnt updated for 1.4.2 yet. in which case either Your installing 1.4.2 mods into a 1.3.2 Minecraft, which wont work, or your installing a 1.3.2 mod into a 1.4.2 minecraft, which again wont work. You'll have to skip this mod if You want everything to work properly.

I assume you mean the More Explosives mod with this one. This mod must be installed into the jar file. Requires Forge.

I dont know what the last mod is referring to, I can't find anythign by that name. Make sure it requires forge, and that it is updated for 1.4.2. If it isn't, Don't use it, as it wont work if You try to.
If it is updated, make sure to install it to either the jar file or the mods folder, depending on what the installation instructions are.

hopefully this helps, if not, I'll try my best to help You out.

I might suggest getting the MultiMC launcher to make mod installing (and getting the right version of forge) much easier. with it You wont have to extract zp files to install them into hte jar any longer, it does it all for you.

Good luck. Posted Image

Edited by DiegoAtravesar, 05 November 2012 - 09:49 PM.

Servers I play on: NearbyNation Sub Server
Current Project: Universal Configs (On hold currently)

#5

Skizshot45

Posted 11 February 2013 - 10:27 PM

if u have a mac:
to download divine rpg, you just take the .jar file and put it in the 'mods' folder.
BANGBANGBANGABNGABNGABNAGBNAGBNAGBNAGABNAGBNAGBNAGBNAGBNAGBNAGBNAGBANGBANGABNGABNGABNAGBNAGBNABVBNGBANGABBAGBABABNGBAGNAGBANAGBANAGBANAG