Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Mo creatures problems?


  • Please log in to reply
20 replies to this topic

#1

BigPanda
    BigPanda

    Out of the Water

  • Members
  • 7 posts

Posted 03 November 2012 - 05:52 PM

Okay, so I installed mo creatures mod for minecraft 1.3.2 (Newest version before current 1.4.2). And it has some odd problems. Its definately installed correctly because most things about it function normally, except for a few small issues.

1. My saddled horse wont jump. Im assuming it uses the space bar to jump, right? I can ride the horse just fine, but when I press space it wont jump. Its not a problem with my keyboard because my player jumps just fine.

2. My tamed bigcats wont attack enemy mobs that target me (Normal difficulty). They only attack the occasional skeleton that shoots them in an attempt to shoot me.

Can someone please tell me what I am doing wrong? I have minecraft forge client, and I simply moved mo creatures mod.zip into the mods folder.

Register or log in to remove.

#2

rivvest
    rivvest

    Gold Miner

  • Members
  • 388 posts

Posted 03 November 2012 - 06:02 PM

All of your questions are answered on the Mo Creatures thread.. check the known bugs and change log.

Revamp - Rivvest's Enhanced Villagers and Mob Performance
http://www.minecraft...ob-performance/


#3

Kadecamzies

Posted 03 November 2012 - 06:31 PM

For me, horses are white.

#4

RebeccaB1234
  • Location: United Kingdom
  • Minecraft: RebeccaB1234

Posted 03 November 2012 - 06:53 PM

A lot of websites have been saying that there have been a few problems with the latest update.
Here is a list:


-Horse breeding not working well
-ExtraBiomesXL integration hasn't been implemented yet, it causes a crash error. To temporarily solve the problem, the "extrabiomes" folder in the MoCreatures.zip has to be deleted if you use ExtraBiomesXL.
-inventory does not work for horses
-When riding a horse, the jump key is disabled
-vanishing / appearing fx not happening on other clients
-vanishing horses perstis on clients
-Bug when picking up small creatures and fishbowls
-Ogres do not raise arms when smashing
-kittylitters, bunnys do not attract mobs
-Scorpions do not poison, attack animation is not working well
-snakes head rotation is wrong
-snake attack animation not shown
-kitty attack animation not shown
-legs and tails of fairy horses and some insects move too fast
-unable to tame horses or dolphins by mounting them, it crashes the game!
-Unable to name tamed creatures
-all MoCreatures spawning eggs have wrong colors
-ducks do not move their wings
-BigCats size, health and attack power is not set up properly
-Missing insects and turkeys sounds
-vanilla mobs spawning is only partially changed
-Werewolves head rotation is buggy
-Litterboxes and Kitty beds can't be placed in the world
-health bars are not working properly
-when the player scapes the crocs grab, there is a sync error

I'm sure your issue is in the list.


#5

rivvest
    rivvest

    Gold Miner

  • Members
  • 388 posts

Posted 03 November 2012 - 07:30 PM

View PostKadecamzies, on 03 November 2012 - 06:31 PM, said:

For me, horses are white.
http://www.minecraft...0#entry18932620

Revamp - Rivvest's Enhanced Villagers and Mob Performance
http://www.minecraft...ob-performance/


#6

Ambi11
    Ambi11

    Tree Puncher

  • Members
  • 26 posts
  • Minecraft: Essie11

Posted 06 November 2012 - 06:02 PM

my problem is i can't use whip, can't put saddle on ostrich and ostriches die when i am feeding; wheat, apples and such

#7

MultiDarkShadow777
  • Location: California
  • Minecraft: rjlefty96

Posted 06 November 2012 - 07:12 PM

View PostAmbi11, on 06 November 2012 - 06:02 PM, said:

my problem is i can't use whip, can't put saddle on ostrich and ostriches die when i am feeding; wheat, apples and such
That is all fixed in a latest version (v4.1.2) of Mo' Creatures.

#8

Siejuro
    Siejuro

    Tree Puncher

  • Members
  • 24 posts

Posted 11 November 2012 - 03:45 AM

1.4.2 I hatched a snake, right clicked it, and its stuck on me!! how do I remove it!?

#9

Sarah3149

Posted 17 January 2013 - 11:36 PM

Is there a problem with the minecraft mo creatures 1.4.7, because i installed minecraftforge 1.4.7 and
GuiApi 0.15.2-1.4.6, and when i logged into my minecraft, it was stuck on the "Updating" page, is there something wrong with the GuiApi, or did i install the wrong one? please help!

#10

DerVormund
  • Location: California
  • Minecraft: DerVormund

Posted 28 January 2013 - 07:03 AM

I have a problem with Mo' creatures and I haven't found a solution thus far. I run Mo' creatures on my server (along with IC2, Buildcraft, and Railcraft). I use the latest version of each mod and mincraft. I have installed the mods properly and they work fine. However, I can't seem to prevent things like fire ogres from spawning. I have tried changing the spawn frequency of specific creatures to "0", but they spawn anyhow. I have tried waiting a day (I've waited many minecraft days). I've tried restarting the server. I've tried moving to a new area. The only hint of a solution I have is a "mocreatures.properties" file, which I cannot find. Even if I could, I'm told to put it where my lastlogin and options.txt files are and the server doesn't have those. Is there anyone who has encountered this issue before, or can provide assistance?

Update: This method of setting frequency to zero works for other mobs. The only ones I'm certain it works for are the various insects.

#11

west_pi
    west_pi

    Tree Puncher

  • Members
  • 22 posts

Posted 05 April 2013 - 06:36 AM

i can't get off my horse or any other rideable pets. and yes ive tried shifting and re logging in. also the crocodiles drag me and it glitches so im not actually there or something, so i take damage and can't see them attacking me

#12

Francisco_Yeah

Posted 05 April 2013 - 10:32 PM

Hey Guys, i have a problem with the frequency. if i set the frequency of all mobs and creatures on 0 the game crash. Is it a bug or i do somting wrong?

#13

west_pi
    west_pi

    Tree Puncher

  • Members
  • 22 posts

Posted 14 April 2013 - 07:53 PM

i have so many problems. ostriches and elephants aren't in the desert, hearts just recently stopped showing up. no scorpions or nightmares in the nether. torch animations are just black squares. I can't put armor on special horses. sharks won't spawn. I reinstalled the mod like 3 times, and nothing worked. the mod slowly gets worse and worse even though i don't do anything. do I have to reinstall minecraft too?

#14

Rafi007
    Rafi007

    Out of the Water

  • Members
  • 7 posts

Posted 18 April 2013 - 11:16 AM

Hey Guys... This is A  Easy Fix for The Get Off Glitch in Mo' Creatures....
it's simple...haha...since the last update. the get-off key changed into F

#15

zakatez
    zakatez

    Out of the Water

  • Members
  • 2 posts

Posted 03 June 2013 - 12:25 PM

View Postwest_pi, on 05 April 2013 - 06:36 AM, said:

i can't get off my horse or any other rideable pets. and yes ive tried shifting and re logging in. also the crocodiles drag me and it glitches so im not actually there or something, so i take damage and can't see them attacking me

check the controls i had the same problem apparently my minecraft set it so i can get off with F

#16

Aslan21342

Posted 05 June 2013 - 07:32 PM

I can't get my horses to breed

#17

Ashbabc
    Ashbabc

    Out of the Water

  • Members
  • 8 posts

Posted 24 July 2013 - 10:46 PM

View PostAmbi11, on 06 November 2012 - 06:02 PM, said:

my problem is i can't use whip, can't put saddle on ostrich and ostriches die when i am feeding; wheat, apples and such


Umm... for the ostriches you have to hatch them from the eggs yourself to take them and saddle them. Did you do this and then have that problem?

#18

ScorpionExtreme

Posted 25 July 2013 - 01:17 AM

please do not let him die "http://dragcave.net/view/vawxQ

#19

zippleback

Posted 29 September 2013 - 11:02 PM

i just cant get the fairy horsePosted Image

#20

Jyuli
    Jyuli

    Newly Spawned

  • Members
  • 1 posts

Posted 16 November 2013 - 09:18 PM

I'm looking for someone who had this problem and fixed it: I can breed every single mob except the unicorn and the pegasus, I can't make a fairyhorse. The hearts don't appear and tehy just won't breed! somebody pls help