Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

GLSL Shaders OF

glsl shaders

  • Please log in to reply
977 replies to this topic

#301

MikuLoverHachune

Posted 22 November 2012 - 09:38 AM

View Postid_miner, on 22 November 2012 - 07:55 AM, said:

If you are seeing waving grass then the shaders mod is working.
Follow the instructions properly, you have to install a shader too!



I dont have a Mac, but I suppose, any text editor will do.

idminer i ran minecraft,closed minecraft,went to minecraft.jar and delete META-INF and put in the Optifine Ultra HD 1.4.5 first and then GLSL Shaders 1.4.5 and closed the .minecraft window and the minecraft.jar window and ran minecraft and i got this blackscreen,it is annoying me. yes i have the drivers for it. because some time today before i started a new minecraft and this happened,i used the minecraftnostalgia and inverted it to 1.4.2 and used the skydaz installer for it and it worked fine. but then i went to delete .minecraft and then closed minecraft and .minecraft window. and then (what i told you at the beginning of the message) but i still got this black screen. could you tell me what might be wrong with it? that would be great if you could respond soon. great mod though,64 diamonds for you

Register or log in to remove.

#302

MikuLoverHachune

Posted 22 November 2012 - 09:48 AM

Wait NVM. The mod did work i saw waving grass,but where is the shadows and everything else thats promised?!

#303

Ball_Lightning42
  • Minecraft: BalLightning

Posted 22 November 2012 - 12:11 PM

View PostMikuLoverHachune, on 22 November 2012 - 09:48 AM, said:

Wait NVM. The mod did work i saw waving grass,but where is the shadows and everything else thats promised?!

Did you download and install the shaders? This mod is not the shaders, this just allows you to use the shaders!



#304

elementalgodz11

Posted 22 November 2012 - 11:00 PM

I said this before, but got no reply:

Looks good

A couple of things, sometimes the shadows don't appear, the water shaders do not work, as of does the sun glare. Help!

I said this before, but got no reply:

Also, you know what would be great, if we could install it as an .exe or something and in the Options, we can chose what Shaders options to Enable and Disable, turn on or off motion blur etc, so you can customise the shaders?

#305

cuong40
    cuong40

    Out of the Water

  • Members
  • 2 posts

Posted 23 November 2012 - 12:13 AM

I followed the guide but when I test the glsl shaders minecraft is a black screen the log shows this:


*** MagicMinecraftLauncher 1.0.0 ***
Disable inactive mods
27 achievements
208 recipes
Setting user: cuong42, -169895863798440943
Client asked for parameter: server
LWJGL Version: 2.4.2

OptiFine_1.4.5_HD_D3
Thu Nov 22 19:12:06 EST 2012
OS: Windows 7 (amd64) version 6.1
Java: 1.7.0_04-ea, Oracle Corporation
VM: Java HotSpotâ„¢ 64-Bit Server VM (mixed mode), Oracle Corporation
LWJGL: 2.4.2
OpenGL: AMD Radeon HD 7800 Series version 4.2.11931 Compatibility Profile Context, ATI Technologies Inc.
OpenGL Version: 4.0
OpenGL Fancy fog: Not available (GL_NV_fog_distance)
Checking for new version
Version found: D3
Exception in thread "Minecraft main thread" java.lang.NoClassDefFoundError: VertexData
at bao.<init>(Tessellator.java:196)
at bao.<clinit>(Tessellator.java:107)
at net.minecraft.client.Minecraft.I(SourceFile:346)
at net.minecraft.client.Minecraft.a(SourceFile:243)
at net.minecraft.client.Minecraft.run(SourceFile:515)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: VertexData
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 6 more

Can any one help me with getting the shaders to work?

#306

froggi87654321
  • Location: The End...
  • Minecraft: froggi87654321

Posted 23 November 2012 - 01:00 AM

Great to see this mod updated, I've had a problem with world rendering though.

Minecraft launches and enters main screen fine, without crashing. When I load an SSP world or join a server, it either completes the 'loading world' text and freezes on the dirt backing before crashing quickly without a crash report or renders my hotbar/guis but with black around them before promptly crashing. I installed the mod from this thread first then the shader folder as a zip (v1.08 from sonicether) after. I use magic launcher and have a couple of mods installed that might be confilcting. I'm guessing dynamic lights might. I have Optifine D3 Ultra for 1.4.5 but I have MC 1.4.4. Could this be it? I might not have the correct drivers, could someone link me to a specs requirement page? I don't know my graphics card but if anyone can work it out what it is if I tell you my laptop's a samsung R519 I'd be grateful. Should I try another shader pack off the wiki to fit my drivers? Didn't provide a crash report so probably drivers I'm guessing.

Hope someone can give some advice soon

#307

evoandroidevo
  • Location: Where Everything Is Possible
  • Minecraft: evoandroidevo

Posted 23 November 2012 - 02:37 AM

View Postid_miner, on 20 November 2012 - 09:43 AM, said:

sniped

Are you using sonic's v10?
If you are, then you have to use a modified texture pack.

yea im the custom texture pack and i still get that

figured it out but does anyone know how to stop leaves on trees from waveing i dont mind the grass but the leaves kill my fps

Posted Image

Feel Free To Gain My Space http://db.tt/4PhfLiNS


#308

MincraftWero
    MincraftWero

    Lapis Lazuli Collector

  • Curse Premium
  • Curse Premium
  • 1066 posts
  • Location: Veracruz, Mexico
  • Minecraft: MinecraftWero
  • PSN:IsaacTobalina

Posted 23 November 2012 - 03:30 AM

this doesn't work for mac right? cause i installed it correctly and i just lag ALOT ive installed this mod before without any problems but since 1.4.2 it doesnt work for me
Posted Image

#309

evoandroidevo
  • Location: Where Everything Is Possible
  • Minecraft: evoandroidevo

Posted 23 November 2012 - 04:04 AM

man my game crashes so much with this

Posted Image

Feel Free To Gain My Space http://db.tt/4PhfLiNS


#310

SuperPigMinecraft
  • Minecraft: Jmd21598

Posted 23 November 2012 - 09:43 AM

My water looks like this after installing SEUS Core for Windows.. Posted Image
Posted Image

#311

Breuddwyd

Posted 23 November 2012 - 03:20 PM

View Postevoandroidevo, on 23 November 2012 - 02:37 AM, said:

yea im the custom texture pack and i still get that

figured it out but does anyone know how to stop leaves on trees from waveing i dont mind the grass but the leaves kill my fps

1. Open your minecraft.jar with Winrar or 7zip.
2. Open the Shaders folder
3. Extract gbuffers_terrain.vsh to your desktop.
4. Open this file with an editor like Notepad++
5. Lines 13-16 have this text:
   #define WAVING_GRASS
   #define WAVING_WHEAT
   #define WAVING_LEAVES
   #define WAVING_FIRE
To disable any of these, just place // at the beginning of the line. For example, //#define WAVING_LEAVES
6. Save the file, drag it back into the Shaders folder in your jar (and overwrite), and you are all good!

#312

id_miner

Posted 23 November 2012 - 03:47 PM

View Postfroggi87654321, on 23 November 2012 - 01:00 AM, said:

Great to see this mod updated, I've had a problem with world rendering though.

Minecraft launches and enters main screen fine, without crashing. When I load an SSP world or join a server, it either completes the 'loading world' text and freezes on the dirt backing before crashing quickly without a crash report or renders my hotbar/guis but with black around them before promptly crashing. I installed the mod from this thread first then the shader folder as a zip (v1.08 from sonicether) after. I use magic launcher and have a couple of mods installed that might be confilcting. I'm guessing dynamic lights might. I have Optifine D3 Ultra for 1.4.5 but I have MC 1.4.4. Could this be it? I might not have the correct drivers, could someone link me to a specs requirement page? I don't know my graphics card but if anyone can work it out what it is if I tell you my laptop's a samsung R519 I'd be grateful. Should I try another shader pack off the wiki to fit my drivers? Didn't provide a crash report so probably drivers I'm guessing.

Hope someone can give some advice soon

Use MC 1.4.5.
Try it without any other mods and with the lite version of the shaders.

View Postcuong40, on 23 November 2012 - 12:13 AM, said:

I followed the guide but when I test the glsl shaders minecraft is a black screen the log shows this:

OptiFine_1.4.5_HD_D3

Can any one help me with getting the shaders to work?

You are using the wrong version of Optifine.

View PostMikuLoverHachune, on 22 November 2012 - 09:38 AM, said:

idminer i ran minecraft,closed minecraft,went to minecraft.jar and delete META-INF and put in the Optifine Ultra HD 1.4.5 first and then GLSL Shaders 1.4.5 and closed the .minecraft window and the minecraft.jar window and ran minecraft and i got this blackscreen,it is annoying me. yes i have the drivers for it. because some time today before i started a new minecraft and this happened,i used the minecraftnostalgia and inverted it to 1.4.2 and used the skydaz installer for it and it worked fine. but then i went to delete .minecraft and then closed minecraft and .minecraft window. and then (what i told you at the beginning of the message) but i still got this black screen. could you tell me what might be wrong with it? that would be great if you could respond soon. great mod though,64 diamonds for you

I can't tell you nothing, unless you post a log.

Check out my Mod:
Posted Image


#313

id_miner

Posted 23 November 2012 - 03:54 PM

View Postelementalgodz11, on 22 November 2012 - 11:00 PM, said:

I said this before, but got no reply:

Looks good

A couple of things, sometimes the shadows don't appear, the water shaders do not work, as of does the sun glare. Help!

Sonic's v10 version of the shaders is not released yet, if you experience problems switch back to the v8 version.

View Postelementalgodz11, on 22 November 2012 - 11:00 PM, said:

I said this before, but got no reply:

Also, you know what would be great, if we could install it as an .exe or something and in the Options, we can chose what Shaders options to Enable and Disable, turn on or off motion blur etc, so you can customise the shaders?

You can make your own shaders, I don't have time for learning GLSL shaders programming.
I have thought about selectable shaders too, loading it like a texturepack, maybe in a future version.

Check out my Mod:
Posted Image


#314

id_miner

Posted 23 November 2012 - 04:04 PM

View PostxXDHG95Xx, on 22 November 2012 - 08:06 AM, said:

I need help i have installed:
GLSL Shaders OF 1.4.5 1.0.5.zip
Optifine_1.4.5_HD_U_D3.zip
shaders.zip (which is actually just Ultra 0.8)


Wrong sequence.
First must be Optifine!

View PostPablare, on 21 November 2012 - 03:19 PM, said:

cool thank you but im still interested what are the changes to the texture

Search on Sonic's thread: http://www.minecraft...c-shadows-more/

View PostPablare, on 21 November 2012 - 03:19 PM, said:

edit: tried it out  
while the water shader and the light effect looks awesome the textures look kind of weird they are really weird depending on the angle and the are these lines between them i just want to know if i am doing something wrong or if it is meant this wayPosted Image

I think it is the (broken) bump map, try an another texture pack.

Check out my Mod:
Posted Image


#315

id_miner

Posted 23 November 2012 - 04:12 PM

View Postclavdivs, on 21 November 2012 - 02:32 PM, said:

Is there some kind of guide or tutorial on how to configure the shader files to do what I want? The mod works fine, but I have no idea how to create a custom setup like some people in this thread have been doing.

Look at theese threads:

http://www.minecraft...c-shadows-more/
http://www.minecraft...adows-and-more/

View Postclavdivs, on 21 November 2012 - 02:32 PM, said:

Also, is there any way for torches or other light sources to cast shadows as well, or does that only work for the sun and moon? It's a little weird to have those gorgeous dynamic shadows up on the surface and then the old shadowless Minecraft lighting indoors or underground.

Anything can be done, you only have to learn GLSL shaders programming .

Check out my Mod:
Posted Image


#316

froggi87654321
  • Location: The End...
  • Minecraft: froggi87654321

Posted 23 November 2012 - 05:58 PM

View Postid_miner, on 23 November 2012 - 03:47 PM, said:

Use MC 1.4.5.
Try it without any other mods and with the lite version of the shaders.
I've now updated to MC 1.4.5 and deactivated all other mods via magic launcher. I kept the correct version of optifine loaded and then your mod then v0.8 shaders lite, all for 1.4.5. Same crashing symptons as before really. Bit disappointed at this as I was really looking forward to getting it working. Discovered my graphics card is an intel if that's any help.

Hoping that the alienware I'm getting soon's superior graphics card might help resolve this. If there is another solution though that you know of, would be glad to hear it.

#317

minicasio

Posted 23 November 2012 - 07:34 PM

Minecraft 1.4.5 is a black screen
The log :
*** Starting Minecraft ***
Minecraft version: 1.4.5
Minecraft.jar: minecraft.jar
Mods:
  OptiFine_1.4.5_HD_D3.zip
  GLSL-Shaders-OF-Mod-1.4.5.zip
Java path: C:\Program Files\Java\jre7\bin\java
Memory: 512 MB
LauncherPath: /C:/Users/DarkOsx/Desktop/Mod/Magic/MagicLauncher_1.0.0.exe
*** MagicMinecraftLauncher 1.0.0 ***
Disable inactive mods
27 achievements
208 recipes
Setting user: 123, 1576413281
Client asked for parameter: server
LWJGL Version: 2.4.2
OptiFine_1.4.5_HD_D3
Sat Nov 24 02:27:58 ICT 2012
OS: Windows 7 (amd64) version 6.1
Java: 1.7.0_09, Oracle Corporation
VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
LWJGL: 2.4.2
OpenGL: ATI Radeon HD 4800 Series version 3.3.11653 Compatibility Profile Context, ATI Technologies Inc.
OpenGL Version: 3.3
OpenGL Fancy fog: Not available (GL_NV_fog_distance)
Checking for new version
Exception in thread "Minecraft main thread" java.lang.NoClassDefFoundError: VertexData
	at bao.<init>(Tessellator.java:196)
	at bao.<clinit>(Tessellator.java:107)
	at net.minecraft.client.Minecraft.I(SourceFile:346)
	at net.minecraft.client.Minecraft.a(SourceFile:243)
	at net.minecraft.client.Minecraft.run(SourceFile:515)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: VertexData
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	... 6 more
Version found: D3
Someone is closing me!


#318

sy7hf7tgtgrf
  • Location: Seattle,WA
  • Minecraft: Sy7hf7tgtgrf

Posted 23 November 2012 - 11:37 PM

Can someone give me a detailed tutorial on how to use Sonic's RC5 of v10 with 1.4.4 of GLSL? I tried using the tutorial a few pages back but all I got was a blue shade color on everything with Ozo's v10 modified texturepack.
Posted Image

#319

Enx
    Enx

    Newly Spawned

  • Members
  • 1 posts

Posted 24 November 2012 - 12:35 AM

This configuration is working fine for me but I just had one quick question: The motion blur is not enabled in this version as far as I know. Do you have any idea when it will be available? This feature was one of the things that made this mod so amazing.

#320

minicasio

Posted 24 November 2012 - 01:54 AM

View Postcuong40, on 23 November 2012 - 12:13 AM, said:

I followed the guide but when I test the glsl shaders minecraft is a black screen the log shows this:


*** MagicMinecraftLauncher 1.0.0 ***
Disable inactive mods
27 achievements
208 recipes
Setting user: cuong42, -169895863798440943
Client asked for parameter: server
LWJGL Version: 2.4.2

OptiFine_1.4.5_HD_D3
Thu Nov 22 19:12:06 EST 2012
OS: Windows 7 (amd64) version 6.1
Java: 1.7.0_04-ea, Oracle Corporation
VM: Java HotSpotâ„¢ 64-Bit Server VM (mixed mode), Oracle Corporation
LWJGL: 2.4.2
OpenGL: AMD Radeon HD 7800 Series version 4.2.11931 Compatibility Profile Context, ATI Technologies Inc.
OpenGL Version: 4.0
OpenGL Fancy fog: Not available (GL_NV_fog_distance)
Checking for new version
Version found: D3
Exception in thread "Minecraft main thread" java.lang.NoClassDefFoundError: VertexData
at bao.<init>(Tessellator.java:196)
at bao.<clinit>(Tessellator.java:107)
at net.minecraft.client.Minecraft.I(SourceFile:346)
at net.minecraft.client.Minecraft.a(SourceFile:243)
at net.minecraft.client.Minecraft.run(SourceFile:515)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: VertexData
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 6 more

Can any one help me with getting the shaders to work?

You want change the OptiFine_1.4.5_HD_D3 to OptiFine_1.4.5_HD_U_D3