Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Minecraft Forge Universal modding problems

forge done loading problem modding help

  • Please log in to reply
3 replies to this topic

#1

Noveltyjack

Posted 22 October 2012 - 08:30 AM

I've been having a lot of trouble with modding recently, originating with just trying to set up a BTW mod server after someone I knew failed to get it to work.

So here's the issue: I've been trying to install Minecraft Forge Universal for 1.3.2 on my brand new gaming laptop. I've googled countless forum threads for hours on end, looking for someone with the same issue I'm having and boy did I find a lot. It looks like having problems with MF:U is pretty common, but apparently not many find solutions.

To begin, here are my specs:

Windows 7 x64 Home Premium
Java x32/64 (I originally had just x32, but I was experiencing a ton of lag in smp so I installed x64 and it solved the issue :D)
16GB RAM
NVIDIA GeForce GTX 675M 4GB VRAM with Optimus
2.6Ghz Quad-core Intel Core i7
Winrar x32/64 (Apparently the archiving software doesn't matter since I've seen posts from many people who use different ones and they all have exactly the same issue as me)

I've done several clean installs of everything, going so far as to redownload all the mod .zip files and MC itself to make absolute sure everything was fresh and clean as you're told to do when installing MF:U. Obviously, the META-INF was deleted and I even tried running MC with the META-INF to cover all my bases and no dice. The latest builds of MF:U do not need any form of modloader to be installed as I keep hearing so I never bothered with it especially after searching through the Forge archive and seeing modloader in there. I searched around for ways to install Forge and there doesn't appear to be any steps beyond a typical mod install by dragging and dropping the files from the .rar into minecraft.jar and that's exactly what I've done numerous times and every single method I've gone through with slight variations has ended up with me staring at a "Done Loading" screen with my middle finger in the air and a silent curse on my lips. Nothing, absolutely NOTHING changes every time I try something slightly different or even greatly different during the installation process and every attempt has been from scratch, following all instructions to the letter before starting over with something new.

I have absolutely NO idea what to do. The only way I've had any different results has been from keeping the META-INF folder in and getting a black screen. The sad thing about this all is that I was using an older rubbish laptop before this one and everything ran fine on it. Forge was always an easy install on that one. Judging from that, I assess it may be an issue with 64-bit systems and software...? In all my hours of googling, I never actually came across that suggestion, though.

BTW, everything is up to date on my system and I do mean EVERYTHING. I made damn sure of that several times.

If anyone has any idea what to do here, I'd greatly appreciate your help. I REALLY want to play the TerraFirmaCraft mod, but I have to get through this, first and I'm completely stumped T_T

Register or log in to remove.

#2

foreverblu
  • Location: Coruscant
  • Minecraft: foreverblu

Posted 22 October 2012 - 08:54 AM

You open the minecraft.jar with whatever unzipping tool you use, and they just drag all the files in, making sure to MERGE folders and not replace them(like net and paulscode) Hope this helped,

Foreverblu :Diamond:
Posted Image <-------Help this poor little hatchling and watch it grow! It needs you :) Just1 Click on the picture would help a lot~~!!! THX!

#3

rivvest
    rivvest

    Gold Miner

  • Members
  • 388 posts

Posted 22 October 2012 - 09:34 AM

Logs or at least crash reports?  They will be in your .minecraft directory if Forge is in your jar.  What version of Forge are you trying?  You say "drag from the .rar" but Forge comes as a .zip.  I lost track of whether you were still trying to mod a client or a server at the end. As a general rule, when modding the client, delete META-INF; when modding the server, do not.  There is no installation difference between 32 and 64 bit.  Give us a run down of the steps you take in detail and maybe we can figure something out.

Revamp - Rivvest's Enhanced Villagers and Mob Performance
http://www.minecraft...ob-performance/


#4

Noveltyjack

Posted 27 October 2012 - 01:33 PM

Nevermind, guys it was just the version of Forge that was incompatible. I was using the latest version and it just doesn't work with TFC so I tried a couple earlier versions and it worked, no biggie.