Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Internal exception: java.net.SocketException: Software caused connection abort: recv failed

error need help

  • Please log in to reply
85 replies to this topic

#1

IceTundra6

Posted 17 October 2012 - 11:58 PM

Hey,

I have recently started getting this error. I have searched and searched but haven't found a solution. I got my computer around the middle of august and have reformatted it 3-4 times since then. This happens on every server I join including tekkit servers. I have flushed the dns, and pretty much did everything that others have said works such as deleting the "jinput" file. It looks like some people are saying that it's the network interface card (mine is atheros) but I don't know what to do about that. I connect to the internet through a wireless network connection instead of a wired one (atheros).
Would it help if I used a wired one or is it the modem/router I am connected to?
I am happy to provide any additional information if you have any knowledge on this error.

Thanks,
Ice Posted Image

Register or log in to remove.

#2

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8033 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 18 October 2012 - 12:57 AM

could we see any error logs you have
post them using spoilers like this
[spoiler] the error report [/spoiler]


#3

IceTundra6

Posted 18 October 2012 - 01:37 AM

Sorry, but how might I find these logs? It just disconnects me from the server, minecraft doesn't crash or anything. I can take a screen shot of what it says if that helps.

#4

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8033 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 18 October 2012 - 01:44 AM

the client isn't crashing?

do you connect to the server at all?

any mods installed when using the normal client?

#5

IceTundra6

Posted 18 October 2012 - 02:03 AM

No, the client is not crashing.

Yes I do connect to the server, but only for a few seconds. The map fully loads all chunks and people walk around and talk, but then it crashes.

I have the McPvP mod installed, as well as optifine, zombe, and inventory tweaks mod. I don't think this is the problem though, because I still get the error message when I have a vanilla client.

#6

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8033 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 18 October 2012 - 02:06 AM

does it happen on all servers, or just one?

#7

IceTundra6

Posted 18 October 2012 - 02:10 AM

all servers, minecraft and tekkit servers

#8

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8033 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 18 October 2012 - 02:29 AM

that rules out the server being at fault then.
can you connect up wired and then see if the crash happens

#9

IceTundra6

Posted 18 October 2012 - 02:34 AM

I don`t have an ethernet cable, and I am rather far from my modem/router :( I tried on my sisters laptop and she seems to also get disconnected from servers.

#10

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8033 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 18 October 2012 - 02:38 AM

hhmm.. so disconnects happen on any server, and when wired and wireless.
but you are able yto make the initial connection and load some chunks
correct?

#11

IceTundra6

Posted 18 October 2012 - 02:45 AM

Sorry, I forgot to mention that my sisters laptop is also connected wirelessly to the router.

Yes I am able to make the initial connection to the server as if there was no problems, but only for a few minutes at most.

#12

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8033 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 18 October 2012 - 02:55 AM

can you get the laptop connected to the router with a wire to test that, this will help limit down the issue, at the moment we can't tell if its the wireless causing the problem or not

#13

IceTundra6

Posted 18 October 2012 - 03:07 AM

Ok, I just tried it on my desktop that is directly connected to the router and it is working fine without any disconnections, so I think it may be the wireless connection that is causing the problems.

#14

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8033 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 18 October 2012 - 03:29 AM

yeah that would point at the wireless being the problem.

#15

IceTundra6

Posted 18 October 2012 - 01:57 PM

Do you know of any solution I can use besides wiring it?

#16

pmelli525

Posted 18 October 2012 - 02:46 PM

hey. i am having this problem too. I also spoke with a friend in california that is having the same issue... Curious to see if anyone figures this out. At first I thought it was my system, my internet.... bla bla bla. But it must be something bigger than that because I am discovering that this is happening to many people. Let me know if you figure it out. I will do the same. :)

#17

pmelli525

Posted 18 October 2012 - 03:14 PM

By the way, are you running Norton or another program? Perhaps all of us having this issue are running firewall protection programs that are causing this error. Thanks.

#18

IceTundra6

Posted 18 October 2012 - 03:26 PM

I am running avg and windows firewall, but I have tried disabling both and I still get disconnected.

#19

ABlockMan

Posted 22 October 2012 - 12:54 AM

View PostIceTundra6, on 18 October 2012 - 03:26 PM, said:

I am running avg and windows firewall, but I have tried disabling both and I still get disconnected.
Same

#20

FubarP
    FubarP

    Tree Puncher

  • Members
  • 36 posts

Posted 22 October 2012 - 05:53 PM

I'm also having issue with this. Not just me but everyone on my server is having this issue.
I'm positive it is not my server since the drops are random and only happens to 1 player at a time. I was on for 50minutes bfore it dropped were some players drop minutes after logging in. I'm assuming this is a java issue but I'm not 100%

Like 2 minutes after I posted this minecaft main server went down. Now I'm just assuming minecraft is the issue and not bukkit.