Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

no modloader mods

request

  • Please log in to reply
26 replies to this topic

#1

MinesolarS
  • Location: y u need to know

Posted 28 September 2012 - 03:05 AM

Any mods out there modloader crashes my game:
*** MagicMinecraftLauncher 0.9.9 ***
java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
    at java.lang.Class.getDeclaredMethods0(Native Method)
    at java.lang.Class.privateGetDeclaredMethods(Class.java:2395)
    at java.lang.Class.getMethod0(Class.java:2642)
    at java.lang.Class.getMethod(Class.java:1579)
    at magic.launcher.Launcher.main(Unknown Source)

i have no idea what this means so any non modloader mods. i use 1.3.2 yes i use magic launcher.
Anyone know a mod?
Why are you reading this there's nothing here.

Register or log in to remove.

#2

MinesolarS
  • Location: y u need to know

Posted 28 September 2012 - 05:07 AM

i feel so lonely
Why are you reading this there's nothing here.

#3

mrspartan86

Posted 28 September 2012 - 03:45 PM

its impossible to make mods in without modloader
well without modloader you can have mods that change stuff already in minecraft
but you need modloader to add new items,swords etc because modloader loads new stuff so the modders can add rather than change

confusing i know

#4

TheBigApple47
  • Location: Chicago,IL

Posted 28 September 2012 - 05:21 PM

View PostMinesolarS, on 28 September 2012 - 03:05 AM, said:

Any mods out there modloader crashes my game:
*** MagicMinecraftLauncher 0.9.9 ***
java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Class.java:2395)
at java.lang.Class.getMethod0(Class.java:2642)
at java.lang.Class.getMethod(Class.java:1579)
at magic.launcher.Launcher.main(Unknown Source)

i have no idea what this means so any non modloader mods. i use 1.3.2 yes i use magic launcher.
Anyone know a mod?
well from what I can tell magic launcher is incompatible modloader, so if you use the normal launcher you will be able to use modloader mods.

View Postmrspartan86, on 28 September 2012 - 03:45 PM, said:

its impossible to make mods in without modloader
well without modloader you can have mods that change stuff already in minecraft
but you need modloader to add new items,swords etc because modloader loads new stuff so the modders can add rather than change

confusing i know
Hey just so you know you can add new stuff to minecraft without modloader it's just that modloaders does two things . 1- makes it easier. 2- makes more mods compatibly with each other.
Posted Image

#5

MinesolarS
  • Location: y u need to know

Posted 01 October 2012 - 01:09 AM

it still crashed
Why are you reading this there's nothing here.

#6

MinesolarS
  • Location: y u need to know

Posted 01 October 2012 - 01:21 AM

im nocturnal (not really)
Why are you reading this there's nothing here.

#7

ArmedAnt
    ArmedAnt

    Out of the Water

  • Members
  • 8 posts

Posted 01 October 2012 - 02:10 AM

use mcpatcher it works better for me than magic launcher

#8

MinesolarS
  • Location: y u need to know

Posted 01 October 2012 - 04:28 AM

View PostArmedAnt, on 01 October 2012 - 02:10 AM, said:

use mcpatcher it works better for me than magic launcher
mcpatcher didn't work the mods that i wanted wouldn't load  i had too many items installed(in the jar not the mods folder) and no new items no new blocks
Why are you reading this there's nothing here.

#9

MinesolarS
  • Location: y u need to know

Posted 01 October 2012 - 04:34 AM

thanks for trying to help but all i wanted were some mods... -_-'
Why are you reading this there's nothing here.

#10

MinesolarS
  • Location: y u need to know

Posted 01 October 2012 - 05:28 AM

http://imgur.com/a/wXStN pics fo proof
Why are you reading this there's nothing here.

#11

MinesolarS
  • Location: y u need to know

Posted 01 October 2012 - 05:49 AM

181 views! i didn't expect that many views. anyone have any non modloader mods? :)

Edited by MinesolarS, 01 October 2012 - 07:03 AM.

Why are you reading this there's nothing here.

#12

MinesolarS
  • Location: y u need to know

Posted 01 October 2012 - 06:05 AM

im not asking for someone to code them just tell me mods they know about
Why are you reading this there's nothing here.

#13

ThaTwinkeh
  • Minecraft: MrTwinkeh

Posted 01 October 2012 - 06:28 AM

Dude! No one makes them because they are inefficient! Say you find one and it adds a block, then you find another that adds another block, they will be incompatible! Plus, the possibilities of a non ModLoader mod are slim. ModLoader is the easiest mod to install, just drag and drop the files! And stop bumping this thread so that more people will search for non ModLoader mods while you don't do anything.

(Not so) Sincerely,
ThaTwineh
Posted Image
Click it!

#14

MinesolarS
  • Location: y u need to know

Posted 01 October 2012 - 06:35 AM

View PostThaTwinkeh, on 01 October 2012 - 06:28 AM, said:

Dude! No one makes them because they are inefficient! Say you find one and it adds a block, then you find another that adds another block, they will be incompatible! Plus, the possibilities of a non ModLoader mod are slim. ModLoader is the easiest mod to install, just drag and drop the files! And stop bumping this thread so that more people will search for non ModLoader mods while you don't do anything.

(Not so) Sincerely,
ThaTwineh
can you tell me why it crashes? what does the crashlog say? i have no experience with java or modding
Why are you reading this there's nothing here.

#15

mrokenroler

Posted 02 October 2012 - 12:21 AM

http://www.minecraft.../#entry17482131

#16

MinesolarS
  • Location: y u need to know

Posted 02 October 2012 - 01:06 AM

thank you
Why are you reading this there's nothing here.

#17

Tjokm12345
  • Location: Playing Video Games Somewhere.
  • Minecraft: Tjokm12345

Posted 02 October 2012 - 02:12 AM

Outdated Mod/Modloader.

YES, Im A Sky Fan.

NO, I Dont Call Gold Budder Or Hate On Squids.


#18

MinesolarS
  • Location: y u need to know

Posted 03 October 2012 - 01:22 AM

nope downloaded latest version directly from the forum
modloader was all i had installed

thank you mrokenroler your the only one who gets what im asking
Why are you reading this there's nothing here.

#19

microjunk
  • Minecraft: imrlyfkdnow

Posted 03 October 2012 - 01:27 AM

have you deleted your meta-inf folder when dragging modloader into minecraft jar?
Check out Builder Mod...here...
Find out how I generate....coolAlias...world structure generation and rotation tool...

#20

nerd-boy
    nerd-boy

    Ghast Hunter

  • Curse Premium
  • Curse Premium
  • 2975 posts

Posted 03 October 2012 - 07:52 AM

View PostMinesolarS, on 28 September 2012 - 03:05 AM, said:

Any mods out there modloader crashes my game:
*** MagicMinecraftLauncher 0.9.9 ***
java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Class.java:2395)
at java.lang.Class.getMethod0(Class.java:2642)
at java.lang.Class.getMethod(Class.java:1579)
at magic.launcher.Launcher.main(Unknown Source)

i have no idea what this means so any non modloader mods. i use 1.3.2 yes i use magic launcher.
Anyone know a mod?


An UnsupportedClassVersionError means that you are using a version of Java that is too old. Now I noticed you are also using mac OSX, i don't know how to update java on there. Just google it.


Also while we are on that subject, why didn't you just google "UnsupportedClassVersionError" in the 1st place? Would have saved a lot of trouble.



View Postmrspartan86, on 28 September 2012 - 03:45 PM, said:

its impossible to make mods in without modloader
well without modloader you can have mods that change stuff already in minecraft
but you need modloader to add new items,swords etc because modloader loads new stuff so the modders can add rather than change

confusing i know

Not true, modloader/forge just prevents incompatabilities by exposing methods that allow modders to easily add/change stuff.

Posted Image