Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

ERROR: Could not create the java virtual machine.

  • This topic is locked This topic is locked
111 replies to this topic


  • Location: On Your Computer Screen Go Look!!
  • Minecraft: Shark4675
  • Xbox:Shark4675

Posted 20 April 2013 - 08:30 PM

View Postfergstaz, on 03 September 2012 - 07:27 PM, said:

The only things I had done recently on my computer was download a game called slender, Also MCPatcher to patch a texture pack but when I patched it, thats whenj I opened my minecraft and got this error
You used MCPatcher? that must of caused your minecraft to explode go to MCPatcher and there should be a unpatch button it might start working after that I'm guessing it was working before MCPatcher screwed up minecraft not sure if that's the prob though
Minecraft is awesome but the more powerful god is not Notch it's the creator of valve
  Posted Image

Register or log in to remove.



    Newly Spawned

  • Members
  • 1 posts

Posted 25 April 2013 - 05:49 PM

I'm having the same problem on a pc I'm fixing for someone.  Minecraft has never been run on here, all I have done was download the .exe file.  When I try to run it I get the error:

"Could not create java virtual machine"

I have updated to the newest version of java, I have uninstalled java and re installed java and even downgraded to 1.6.0_45 and I still get the same error.  

Java debug gives no errors with 1.6 or 1.7.

I tried using MagicLauncher and I get this error:

java.lang.ClassNotFoundException: net.minecraft.client.Minecraft
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at magic.launcher.Launcher.main(Unknown Source)

This pc has Win XP and only has 1g Ram so not sure if that is the problem.  

I have tried running it through the .bat file and it does the same thing.

Any help would be appreciated...



Posted 30 April 2013 - 07:02 AM

i have the same dam problem when i tried installing divine rpg



Posted 01 May 2013 - 02:37 PM

View PostAshenEdict, on 19 September 2012 - 10:38 PM, said:

So, I found a rather idiotic solution. I just tested it several times and it works for me, but I have NO idea why. Just close all of your webpages and everything should work fine.

I usually just shut my PC down when it wasn't working and then opened it first thing because hey, maybe it just hasn't hit the error yet? Retarded logic, I know, but it seemed to work. Then, some times, it wouldn't work and then 45 minutes later BOOM! good and working. I found no rhyme or reason to this until I closed my browser to restart and hit MC by accident and, lo and behold, it opened. Then I opened my Chrome again, tried to open another MC and got the error, closed it and MC worked like a dream.

NO clue why this works, just seems to. Give it a shot and see if it works for you.

P.S. - I just copied this and then closed my browser and it worked, opened it, pasted this message and was greeted with a virtual machine error.

Hope this helps /:

EDIT: ... and now it's working with my browser open as long as I keep the original one open... what?
that actually worked.. thanks! :D
subscribe! :)



    Newly Spawned

  • Members
  • 1 posts

Posted 02 May 2013 - 01:44 PM

This is only for minecraft.jar, Launch.bat, tekkitlite.jar - dunno how to do it to minecraft.exe - but if you find out how to change it, the description below will make it work. :)

Right click minecraft, and press edit you will find -Xmx(numbers)g or m and -Xms(numbers)g or m - G is for gigabytes, and m is for megabytes. Change to this line -Xmx1024m -Xms1024m - the numbers indicate how much ram minecraft will run on if set too high it will not work cause it cant gather the requested megabytes. more ram = faster server/minecraft, now you can edit until you find the perfect option for your computer.

hope it helped all Posted Image

Regards Posted Image



Posted 04 May 2013 - 04:49 AM

none of this is working for me
any more suggestions



Posted 10 May 2013 - 01:57 AM

java version "1.7.0_21"
Java™ SE Runtime Environment (build 1.7.0_21-b11)
Java HotSpot™ Client VM (build 23.21-b01, mixed mode, sharing)

I get the same thing, please help!



Posted 13 May 2013 - 10:52 AM

If you are getting this then please follow these steps: "Could not create the java virtual machine"
[1] Replace your current version of Java with Java 6..
[2] Login to the FTB launcher
[3] Launch the modpack
[4] It should work!!!



    Tree Puncher

  • Members
  • 10 posts

Posted 13 May 2013 - 04:18 PM

View Postwolflover234, on 07 September 2012 - 11:09 AM, said:

Dont install the new one- Java 6 is the one you need. Java 7 is having bad problems, And it may or may not of caused this problem. I have this problem to. Un install java, Then re install java 6. *Make sure you install the one that goes to your computer, Meaning if you have 64 bit, Download 64 bit Java 6, If you have 32 bit then download java 32 bit 6* Im learning Java, But this sadly makes no sence to me. The message will change once you install java 6 to: "Could not create the java virtual machine". It's better *Im guessing, Due to the less errors.* But still wont let Minectraft run. Im not sure and I cant help you more then that >:C... Sorry. If I find an answer, I'll tell you C:<
Yeah thanks, Pro tip, go to configuration>java>Views and disable 7 and enable 6.



Posted 14 May 2013 - 12:35 PM

This error keeps on popping up when I've tried to open minecraft and its making me angry so I've reinstalled java 7 and everything someone plz help meeeee



Posted 16 May 2013 - 08:37 AM

can you place a java 6 link


  • Location: Serbia

Posted 17 May 2013 - 09:07 AM

Can some 1 help me i get an error saying Error: could not create java virtual machine.I have java 6.PLEASE HELP ME !!! Posted Image



Posted 17 May 2013 - 02:50 PM

java version "1.7.0_21"
Java™ SE Runtime Environment (build 1.7.0_21-b11)
Java HotSpot™ Client VM (build 23.21-b01, mixed mode, sharing)


  • Location: England
  • Minecraft: littlejack616

Posted 17 May 2013 - 05:46 PM

I think the problem is that people who have installed slender cant play mc. After I played slender I couldnt play mc.



Posted 19 May 2013 - 05:33 AM

Thanks!!! This topic really helped me out :).



Posted 19 May 2013 - 05:58 AM

View Postfergstaz, on 02 September 2012 - 06:55 PM, said:

ERROR: Could not create the java virtual machine.
ERROR: A fatal exception has occurred. Program will exit

I've been playing minecraft for a year perfectly, I started it this morning and gave me this error in a dialouge box. I tried running it with a modded, a vanilla, and no .minecraft folder at all. Always gives me this error! Please help!Posted Image
my to

View Postlittlejack61, on 17 May 2013 - 05:46 PM, said:

I think the problem is that people who have installed slender cant play mc. After I played slender I couldnt play mc.
i downt hawe slender



    Newly Spawned

  • Members
  • 1 posts

Posted 19 May 2013 - 09:27 PM

So we were troubleshooting a case for 5 days where any Minecraft client cannot start with any Java version saying "Cannot Create Java VM". We tried everything on the Internet we were able to find as a fix or work around and none of them helped. It was obvious that this is most probably related to some addware and/or malware and/or virus since the only thing installed was Avast Free.

Below is what we have done to resolve the issue:

- Stopped installing and reinstalling Java - just installed only Java 7 Update 21 JRE.
- Uninstalled Avast Free.
- Installed AVG Free. Updated it to the latest update available.
- Installed Malwarebytes, updated it to the latest update available.
- Initiated Full Scan on all phisical drives only in Malwarebytes - which scans all files for addware, malware and if virus is detected AVG will catch it on file open while Malwarebytes is opening it for scanning.
- Healed all malware, addware and viruses found by AVG and Malwarebytes. Rebooted PC as requested.
- Disabled AVG Free until restart as it fights with ComboFix.
- Installed and ran ComboFix.
- After it finished Minecraft is working with great FPS for the given PC and much better than before with Java 6 and 7.

We hope that this method will help someone. It helped us.



Posted 20 May 2013 - 09:59 AM

Hi Guys,

So i have this problem aswell.The first thing what i did was i deleted minecraft bin hoping it will solve this problem.But sadly no.Then i deleted all MC Patchers i had and still it doesn`t work.I have a java jre1.6.0.
I also tried  to restart my computer and then start minecraft.It didn`t work.So please can someone reply me with
any solution that i didn`t  try yet.And if you were wondering what programs i downloaded recently:

rzr Skyrim



Posted 24 May 2013 - 11:09 AM

Posted Image this happens to me to but i found a way to still play minecraft. you can use the magic launcher it still works.
But that is for me at least



    Out of the Water

  • Members
  • 9 posts

Posted 24 May 2013 - 01:12 PM

what should i really do?

View Postmagic_masterman, on 24 May 2013 - 11:09 AM, said:

Posted Image this happens to me to but i found a way to still play minecraft. you can use the magic launcher it still works.
But that is for me at least
how bout tekkit :(