Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Players can't talk on my server!


  • Please log in to reply
21 replies to this topic

#1

CubeGen
    CubeGen

    Zombie Killer

  • Members
  • 208 posts
  • Minecraft: CubeGen

Posted 28 August 2012 - 09:17 PM

Hye, i just started a server. i'm op so i can talk.

but when a friend came on he couldn't talk, so i made him op and he could talk again, but whe i deopt him he couldn't talk. how can i do so thay can talk?!

Register or log in to remove.

#2

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8072 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 28 August 2012 - 09:24 PM

are you running a vanilla or bukkit server?
if bukkit what plugins are you running?

#3

CubeGen
    CubeGen

    Zombie Killer

  • Members
  • 208 posts
  • Minecraft: CubeGen

Posted 28 August 2012 - 09:27 PM

View Postwebrosc, on 28 August 2012 - 09:24 PM, said:

are you running a vanilla or bukkit server?
if bukkit what plugins are you running?

i run a bukkit server. i use PermissionsEx

#4

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8072 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 28 August 2012 - 09:32 PM

do you have a chat manager or just pex and modify world?

you need to give groups the permissions to be able to chat

#5

Frogger131497
  • Location: Norfolk, VA, USA
  • Minecraft: Frogger1314
  • Xbox:hunterguy97

Posted 28 August 2012 - 09:33 PM

Since you're using Bukkit with Permissionsex, you'll have to setup permissions. The easiest thing to do would be to give your friend or default group this perm: modifyworld.*. If you don't know how to setup permissions than just ask for help Posted Image.
Also, be sure to enable ChatManager in config.yml as this would pose as a problem.

Posted Image


#6

CubeGen
    CubeGen

    Zombie Killer

  • Members
  • 208 posts
  • Minecraft: CubeGen

Posted 28 August 2012 - 09:37 PM

View PostFrogger131497, on 28 August 2012 - 09:33 PM, said:

Since you're using Bukkit with Permissionsex, you'll have to setup permissions. The easiest thing to do would be to give your friend or default group this perm: modifyworld.*. If you don't know how to setup permissions than just ask for help Posted Image.

and when i do modifyworld.* is it safe? i meane they can use every command of it than, i hope they can't do anything wrong with that?

View Postwebrosc, on 28 August 2012 - 09:32 PM, said:

do you have a chat manager or just pex and modify world?

you need to give groups the permissions to be able to chat

essentialschat,modifyworld and permissionsex

#7

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8072 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 28 August 2012 - 09:41 PM

give the permission essentials.chat
the modifyworld.* will also help as it will allow players to break blocks etc when not op
modify world limits usage of items and blocks, it doesn;t access the server important commands, OP can run the command /STOP and stop the server.

never give op to anyone you don't personally know and trust, you shouldn't really need to give op at all when running a permissions plugin

#8

CubeGen
    CubeGen

    Zombie Killer

  • Members
  • 208 posts
  • Minecraft: CubeGen

Posted 28 August 2012 - 09:44 PM

View Postwebrosc, on 28 August 2012 - 09:41 PM, said:

give the permission essentials.chat
the modifyworld.* will also help as it will allow players to break blocks etc when not op
modify world limits usage of items and blocks, it doesn;t access the server important commands, OP can run the command /STOP and stop the server.

never give op to anyone you don't personally know and trust, you shouldn't really need to give op at all when running a permissions plugin

Ok Thanx the worldedit.* worked!

Thx Guys

#9

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8072 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 28 August 2012 - 09:45 PM

i hope that was a typo, don't give worldedit.*

#10

CubeGen
    CubeGen

    Zombie Killer

  • Members
  • 208 posts
  • Minecraft: CubeGen

Posted 28 August 2012 - 09:46 PM

View PostFrogger131497, on 28 August 2012 - 09:33 PM, said:

Since you're using Bukkit with Permissionsex, you'll have to setup permissions. The easiest thing to do would be to give your friend or default group this perm: modifyworld.*. If you don't know how to setup permissions than just ask for help Posted Image.
Also, be sure to enable ChatManager in config.yml as this would pose as a problem.

View Postwebrosc, on 28 August 2012 - 09:41 PM, said:

give the permission essentials.chat
the modifyworld.* will also help as it will allow players to break blocks etc when not op
modify world limits usage of items and blocks, it doesn;t access the server important commands, OP can run the command /STOP and stop the server.

never give op to anyone you don't personally know and trust, you shouldn't really need to give op at all when running a permissions plugin

maby a last tiny question. i got EssentialsProtect,WorldGuard and ModifyWorld is that too much?

#11

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8072 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 28 August 2012 - 09:51 PM

essentials protect is good for adding sign protection and spawn protection, worldguard can protect any area you pick, and modifyworld is good for limiting players from using certain things.

my default group (new players who just logging in) can only open doors and press buttons , nothing else thanks to modify world

#12

CubeGen
    CubeGen

    Zombie Killer

  • Members
  • 208 posts
  • Minecraft: CubeGen

Posted 28 August 2012 - 09:56 PM

View Postwebrosc, on 28 August 2012 - 09:51 PM, said:

essentials protect is good for adding sign protection and spawn protection, worldguard can protect any area you pick, and modifyworld is good for limiting players from using certain things.

my default group (new players who just logging in) can only open doors and press buttons , nothing else thanks to modify world

and how do you edit the groups for modifyworld. i got a config file but with only this

item-restrictions: false
inform-players: false
whitelist: false
use-material-names: true
drop-restricted-item: false
item-use-check: false
messages:
message-format: '&f[&2Modifyworld&f]&4 %s'
default-message: Sorry, you don't have enough permissions
modifyworld.items.use: Stop, &a$1&4 won't fit into &a$3
modifyworld.login: You are not allowed to join this server. Goodbye!
modifyworld.blocks.interact: You are too jelly for &2$1
modifyworld.blocks.place: This is wrong place for &a$1
modifyworld.blocks.destroy: '&a$1&4 is tough for you'
modifyworld.damage.deal: Your level is too low for &5$1
modifyworld.chat: Your mouth is too dry
modifyworld.chat.private: Listener is deaf :(
modifyworld.items.have: Prohibited item &a$1&4 has been removed from your inventory.
modifyworld.items.drop: This is indecent to scatter &a$1&4 around
modifyworld.items.craft: Sorry, but &a$1&4 is too complicated
modifyworld.items.enchant: Sorry, &a$1&4 is too dangerous
modifyworld.vehicle.enter.boat: You are too heavy for this &a$1
modifyworld.vehicle.enter.minecart: Sorry, but &a$1&4 is too small
modifyworld.vehicle.destroy: This &a$1&4 is legal property of &bUnited States of America
modifyworld.tame: This &a$1&4 is too ferocious
modifyworld.bucket.fill: This bucket is holey
modifyworld.bucket.empty: You suddenly realized you still need &a$1
modifyworld.usebeds: You can't sleep yet, there are monsters nearby


#13

Frogger131497
  • Location: Norfolk, VA, USA
  • Minecraft: Frogger1314
  • Xbox:hunterguy97

Posted 28 August 2012 - 09:57 PM

EssentialsProtect is fine, I use it for Spawn protection mainly. You don't have to give anyone permissions for EssentialsProtect if you don't wish for players to have it. Only you can use most plugins by default as you have to give your players permissions for most.

Posted Image


#14

CubeGen
    CubeGen

    Zombie Killer

  • Members
  • 208 posts
  • Minecraft: CubeGen

Posted 28 August 2012 - 09:58 PM

View Postwebrosc, on 28 August 2012 - 09:45 PM, said:

i hope that was a typo, don't give worldedit.*
Oh, Ya that was a typo :D

#15

Frogger131497
  • Location: Norfolk, VA, USA
  • Minecraft: Frogger1314
  • Xbox:hunterguy97

Posted 28 August 2012 - 10:00 PM

With ModifyWorld (and any other plugins) just edit the permissions within plugins/Permissionsex/permissions.yml. There you can add groups, permissions, prefixes, etc. You could also add the modifyworld permissions in-game with Permissionsex commands.

Posted Image


#16

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8072 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 28 August 2012 - 10:01 PM

https://github.com/P...iki/Modifyworld
a little complex at first look, but this should explain what is possible with modify world

#17

CubeGen
    CubeGen

    Zombie Killer

  • Members
  • 208 posts
  • Minecraft: CubeGen

Posted 28 August 2012 - 10:06 PM

View Postwebrosc, on 28 August 2012 - 10:01 PM, said:

https://github.com/P...iki/Modifyworld
a little complex at first look, but this should explain what is possible with modify world

View PostFrogger131497, on 28 August 2012 - 10:00 PM, said:

With ModifyWorld (and any other plugins) just edit the permissions within plugins/Permissionsex/permissions.yml. There you can add groups, permissions, prefixes, etc. You could also add the modifyworld permissions in-game with Permissionsex commands.


Than i got 1 LAST question(i hope i don't bother u)

but i'm making a prison server and i defined a region. the rooom inlcudes workbenches and furnaces.
i've heard that people can use the workbenches in a defined region. but they doesn't seem to be able to use the furnaces.
i checked the flags but i can't find a proper one to let them use the furaces :)

Thx

#18

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8072 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 28 August 2012 - 10:22 PM

looking through the wiki http://wiki.sk89q.com/wiki/WorldGuard it looks like only chests are controllable.

#19

Frogger131497
  • Location: Norfolk, VA, USA
  • Minecraft: Frogger1314
  • Xbox:hunterguy97

Posted 28 August 2012 - 11:56 PM

Worldguard is a bit tricky in that way. When you flag the region with "use;allow" it doesn't seem to apply to furnaces. You could try making the room a parent, then select the furnaces as a region. Then set the parent room as build:deny and set the furnaces as build:allow. Not exactly sure if this would work, but just try :D.

Posted Image


#20

CubeGen
    CubeGen

    Zombie Killer

  • Members
  • 208 posts
  • Minecraft: CubeGen

Posted 29 August 2012 - 09:45 AM

View PostFrogger131497, on 28 August 2012 - 11:56 PM, said:

Worldguard is a bit tricky in that way. When you flag the region with "use;allow" it doesn't seem to apply to furnaces. You could try making the room a parent, then select the furnaces as a region. Then set the parent room as build:deny and set the furnaces as build:allow. Not exactly sure if this would work, but just try Posted Image.
  0.o your the head warden of hard8? i'm making a prison server aswell :)