Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Can't destroy or place blocks :(


  • Please log in to reply
2 replies to this topic

#1

Jakyl
    Jakyl

    Out of the Water

  • Members
  • 4 posts

Posted 27 August 2012 - 08:25 PM

Hi guys,

Don't know if this is a bug, or if i am an idiot. I tried looking for other threads but gave up after 10 pages and I noticed there is 400 pages.

Anyway, I was playing earlier today on single player survival and all was going well, I was quite impressed with what I had built (Probably rubbish, but I like it) so i switched from survival to creative mode so I can fly and take some pics.
I switched back to survival then quit the game to go and do real world stuff. When I came back and tried to play I found that I can't place blocks or destroy blocks (Yes, I am holding the button lol) I can still kill mobs, open doors and chests and stuff, just no block placing or destroying. I have tried copying my save file, re-installing minecraft and putting my savefile back, no joy Posted Image Tried re-assigning keys, still no joy Posted Image
I tried starting a new survival game and everything works fine, go back to my save file and it's still broke.

Is this a bug or do i need to re-enable something when i swich modes?

Some system info.

Version 1.3.2
Win XP Home SP3
Intel E6850 @3.00Ghz
2 gig DDR3 ram
Nvidea 8800 GTX

Please help, and thanks for listening to me ramble.

Register or log in to remove.

#2

Haive
    Haive

    Stone Miner

  • Members
  • 70 posts
  • Location: Iceland
  • Minecraft: TrancyMick

Posted 27 August 2012 - 08:31 PM

You're in Adventure mode (/gamemode 2). Just type /gamemode 0. 0 is survival mode, 1 is creative, and 2 is adventure mode, where you can't break or place any blocks; all you can do is interact with mobs , chests, and doors.

#3

Jakyl
    Jakyl

    Out of the Water

  • Members
  • 4 posts

Posted 27 August 2012 - 08:38 PM

Ahhhh, didn't know about mode 0. Not a bug, I must be an idiot lol.

You sir, are a star. Cheers :)