Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Can I change a survival mode file into a creative mode file?

creative survival minecraft hack mod code

  • Please log in to reply
12 replies to this topic

#1

piercey1
    piercey1

    Out of the Water

  • Members
  • 4 posts
  • Location: New jersey, usa
  • Minecraft: piercey1

Posted 25 August 2012 - 03:11 PM

I have this survival file that I've had for a while now, It's less of a survival file now and more of a "just building things for the heck of it" file. I don't really want to have to rebuild everything in a new creative file (because some of it is kind of cool)  so I was wondering if anyone on here knew how to change it from survival to creative.

Now, I've tried typing in the "gamemode 1" in the chat while playing like I've seen most people do and all it says in red text is "You do not have permission to use this command". Is there any alternative way to do this?

Register or log in to remove.

#2

RrreeedddstoneMiner
  • Location: The Internet
  • Minecraft: Appa102

Posted 25 August 2012 - 03:24 PM

Well, Either you did not have cheats On when you made it.  But Try Downloading single player commands or too many items. they both have a feature that allows you to switch game modes.  If not try going to your saves and playing around with the file and see if you cant find a switch.  good luck!

#3

H34DSH07
    H34DSH07

    Zombie Killer

  • Members
  • 165 posts
  • Location: Canada
  • Minecraft: H34DSH07

Posted 25 August 2012 - 03:36 PM

Use NBT edit to edit your world's properties.
I'm not a bad person, I'm just different.

#4

Nicholas_Wolfwood

Posted 25 August 2012 - 07:00 PM

if you dont want to mod download the minecraft world changer
http://tinyurl.com/3cn5k62

#5

Dr_Goop
    Dr_Goop

    Out of the Water

  • Members
  • 4 posts

Posted 25 August 2012 - 07:10 PM

If you open it as a Lan world in options and set cheats to on, it will work when you change the gamemode using the comand.

#6

piercey1
    piercey1

    Out of the Water

  • Members
  • 4 posts
  • Location: New jersey, usa
  • Minecraft: piercey1

Posted 25 August 2012 - 11:26 PM

View PostRrreeedddstoneMiner, on 25 August 2012 - 03:24 PM, said:

Well, Either you did not have cheats On when you made it.  But Try Downloading single player commands or too many items. they both have a feature that allows you to switch game modes.  If not try going to your saves and playing around with the file and see if you cant find a switch.  good luck!

Any suggestions on safely installing either of those with 1.3.2 on a mac? I'm kind of a noob when it comes to all this mod business Posted Image

#7

Nicholas_Wolfwood

Posted 26 August 2012 - 06:26 PM

the link i posted isnt a mod so its super easy just download it and run it, select the world you want, select the gamemode you want it to be in and boom

#8

Jpgar
    Jpgar

    Zombie Killer

  • Members
  • 220 posts

Posted 26 August 2012 - 07:23 PM

You can, just download nbedit, go to .minecraft, go to saves, and open level.dat, then change gamemode:0 to gamemode:1



#9

RrreeedddstoneMiner
  • Location: The Internet
  • Minecraft: Appa102

Posted 26 August 2012 - 11:35 PM

View Postpiercey1, on 25 August 2012 - 11:26 PM, said:

Any suggestions on safely installing either of those with 1.3.2 on a mac? I'm kind of a noob when it comes to all this mod business Posted Image
  Well, I have Windows so I really have no experience with a mac.  Mods aren't really built for macs.  but im sure you might be able to find something on google or youtube.  sorry.  D:

#10

OrangeBunny2168

Posted 27 August 2012 - 12:50 AM

View Postpiercey1, on 25 August 2012 - 03:11 PM, said:

I have this survival file that I've had for a while now, It's less of a survival file now and more of a "just building things for the heck of it" file. I don't really want to have to rebuild everything in a new creative file (because some of it is kind of cool)  so I was wondering if anyone on here knew how to change it from survival to creative.

Now, I've tried typing in the "gamemode 1" in the chat while playing like I've seen most people do and all it says in red text is "You do not have permission to use this command". Is there any alternative way to do this?
yes. If you have minecraft 1.3.1 go to options while your in game and press Open To LAN.
Make sure you put Cheats On. Then type /gamemode creative. that will make your world creative unless you put it back to /gamemode survival

#11

patkelly1336

Posted 27 August 2012 - 01:45 AM

Utilizing the cheats console, type in /gamemode 1 (this will change the game mode to creative mode, however it will still show up on game load screen as survival mode)... Hope this helps, and hope I didn't post what others had said

#12

piercey1
    piercey1

    Out of the Water

  • Members
  • 4 posts
  • Location: New jersey, usa
  • Minecraft: piercey1

Posted 27 August 2012 - 06:03 PM

View PostOrangeBunny2168, on 27 August 2012 - 12:50 AM, said:

yes. If you have minecraft 1.3.1 go to options while your in game and press Open To LAN.
Make sure you put Cheats On. Then type /gamemode creative. that will make your world creative unless you put it back to /gamemode survival

Can I close it to LAN afterwards and still have it on creative mode?

View PostRrreeedddstoneMiner, on 26 August 2012 - 11:35 PM, said:

Well, I have Windows so I really have no experience with a mac.  Mods aren't really built for macs.  but im sure you might be able to find something on google or youtube.  sorry.  D:

Also, FFFFFFFFFFUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU-okay.

#13

piercey1
    piercey1

    Out of the Water

  • Members
  • 4 posts
  • Location: New jersey, usa
  • Minecraft: piercey1

Posted 28 August 2012 - 06:31 AM

View PostDr_Goop, on 25 August 2012 - 07:10 PM, said:

If you open it as a Lan world in options and set cheats to on, it will work when you change the gamemode using the comand.

Thank you. It actually worked. Turns out if you open it to lan it closes when you save & quit (I know nothing of the multiplayer server stuff so don't be surprised if I sound like an idiot when I say that) and it keeps it as a creative mode file when I open the file again.

Also I want to thank everyone else who helped. :D thanks